OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

6 Pages V  « < 4 5 6  
Reply to this topicStart new topic
> Bochs (x86 emulator) on VGA Zaurus? Anyone?
Have you ever run Bochs on a VGA Zaurus machine before?
Have you ever run Bochs on a VGA Zaurus machine before?
Yes. It was easy [ 5 ] ** [10.42%]
Yes. It took a while to figure out and tweak. [ 7 ] ** [14.58%]
No. Tried, but couldn't get it to work [ 10 ] ** [20.83%]
No. Never Tried. [ 26 ] ** [54.17%]
Total Votes: 27
Guests cannot vote 
post Nov 25 2004, 02:01 PM
Post #76

Group: Members
Posts: 554
Joined: 19-April 04
From: Keokuk, Iowa
Member No.: 2,897

How about the DOS app I attached above? smile.gif
Go to the top of the page
+Quote Post
post Nov 25 2004, 08:01 PM
Post #77

Group: Members
Posts: 219
Joined: 10-February 04
Member No.: 1,807

I would just like to comment that I was successfully able to use the mcopy command of the Windows port of the mtools program to copy files from Windows to a hard disk image file. I believe that you need to install Cygwin for the mtools program to work, because when you untar the mtools-3.9.6-w32.tar file, it creates several symbolic links to the mtools.exe program, mapping various executable file names to mtools.exe. For example, when you use the mcopy.exe program to copy the files from Windows to the c.img file, the mcopy.exe program is actually a symbolic link to the mtools.exe file. Some Unix programs like uuencode/uudecode use this technique to alter their behavior depending on the program name with which they are called. I no longer recall where I got the mtools tar file, so I have attached it to this message. You can visit http://www.cygwin.com to download the Cygwin package, which allows you to run a lot of i386 Linux programs unmodified on a Windows system without rebooting into Linux.

1. Install Cygwin on your Windows computer.
2. Start Cygwin. You will then get a Unix command line prompt.
3. While in Cygwin, execute:

tar xvf /cygdrive/c/mtools-3.9.6-w32.tar

This assumes that you have saved the mtools-3.9.6-w32.tar file on the root directory of the C: drive. Cygwin mounts your Windows drives as:

/cygdrive/c for the C: drive
/cygdrive/d for the D: drive, and so forth

You can type the


command by itself to see how Cygwin has mapped your drives.

The process of extracting the files from the *.tar file creates a directory named mtools-3.9.6 which contains the mtools.exe program and the associated symbolic links. I copied all of these files to the /usr/local/bin directory, because that directory is in my PATH, to make the mtools program names executable from the command line without having to specify the full path to each program:

cd mtools-3.9.6
cp * /usr/local/bin
cd ..

Alternatively, you could add the mtools-3.9.6 directory to your PATH environment variable by adding the following line to the .bash_profile file so that the directory is in your PATH the next time that you restart Cygwin:


When you first enter Cygwin, you are in your default $HOME directory. You have to create a file in this directory named:


Note the period in front of the file name. This file needs to contain a single line which reads:

drive c: file="/cygdrive/c/c.img" partition=1

You can create this file without using vi or any other editor with a command:

echo 'drive c: file="/cygdrive/c/c.img" partition=1' > .mtoolsrc

The single quotes indicate a literal string.

This assumes that you have the c.img file on your C: drive.

You can then use the mcopy command as though it were the MSDOS copy command to copy files from your Windows hard drive to the c.img file. For example:

mcopy /cygdrive/c/filename.txt c:

When you are done, you can exit from Cygwin with the command:


You can also access the files of your Cygwin $HOME directory from Windows under:


The text files in Cygwin are terminated with Line Feed characters instead of Carriage Return / Line Feed pairs, so Notepad will not work directly on the text files in Cygwin.

This is longer than I expected it to be. Let me know if you have any problems with the steps that I listed.

I have Master of Orion v1.3 (the MSDOS version) running under Bochs on my Windows 98 system. My ATI Radeon 9700 Pro video card apparently uses so much ROM space that an EMS swap page cannot be set up, so I cannot run Master of Orion (MOO) natively. Running it under Bochs is nice, because MOO tends to crash occasionally, and a virtual reboot of the computer in Bochs is faster than a physical reboot.
Attached File(s)
Attached File  mtools_3.9.6_w32.tar ( 450K ) Number of downloads: 58
Go to the top of the page
+Quote Post
post Jan 20 2005, 02:51 PM
Post #78

Group: Admin
Posts: 3,495
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149

POSE on dosbox/qemu?

anyone gotten the Palm Emulator to run on Zaurus?
Go to the top of the page
+Quote Post
post Feb 5 2005, 01:24 PM
Post #79

Group: Members
Posts: 554
Joined: 19-April 04
From: Keokuk, Iowa
Member No.: 2,897

QUOTE(speculatrix @ Jan 20 2005, 04:51 PM)
POSE on dosbox/qemu?

anyone gotten the Palm Emulator to run on Zaurus?

Isn't that a little like having a Lamborghini emulate a VW bug? :-P :-D :-)

"Yeah... just listen to that Palm Emulator Roar when I rev' up the engine!" LOL. :-)

But in reality I do understand the need for it (A palm emulator). There are some applications that are written for the Palm that aren't yet written for the Zaurus (sadly enough), such as some e-book readers (oh I know that we have some readers that claim to read all... but I have some e-books that only work on palm. I hope someday that will change).
Go to the top of the page
+Quote Post

6 Pages V  « < 4 5 6
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 26th April 2018 - 01:32 PM