OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Got Earthmate USB GPS, now what?
post May 7 2004, 05:37 PM
Post #1

Group: Members
Posts: 53
Joined: 18-March 04
From: USA
Member No.: 2,388

I took the plunge and got the Delorme Earthmate USB GPS.

The 6000 recognize it right away as "Delorme USB Earthmate". dmesg says something about

USB HID v1.00 Pointer [Delorme Publishing Delorme Earthmate] on usb 1.27.0

Now what do I do? I installed qpegps but the defualt path is

-p /dev/ttyS0 -s -4800

Is that for connection through serial cale? What should I change it to?

One good thing about the setup is that the Z can power the GPS all by itself. The bad is that if qpegps is run in 640x480 mode, it looks skewed.

Please help me set this up.


Go to the top of the page
+Quote Post
Start new topic
post May 9 2005, 09:39 AM
Post #2

Group: Members
Posts: 4,512
Joined: 25-October 03
From: Bath, UK
Member No.: 464

The 2.4 kernel required patches to use the custom version of gpsd at http://trans.civil.northwestern.edu/~jay/gpsd.html



The patch is retiring. Please take a look at the kernel mode driver by Lonnie Mendez. The driver is working and it is only a mater of time for it to go into the official Linux kernel tree.

Looks like he's talking about a module, however it appears that it's for 2.6.x.


To use this GPS, we have two choices. The first one is to write a kernel module for this USB2Serial chip. However the current ( upto kerenl 2.6.5 ) usb2serial framework need to be patched in order to support interrupt transactions. The other approach is to utilize the USB DEVFS interface and communicate with the device directly from user space. The later method turned out to be easy.

seems to give two options:

1. patch the kernel to get over the difficulties caused by the usb2serial framework. I don't know whether this problem exists in 2.4.18, I don't know whether the code even exists in 2.4.18. I also don't know where one would find a patch (it seems to me that you would have to patch it yourself).

2. Use USB devfs (I don't know whether this is even supported on 2.4.18), even if it is, I'm afraid I'm not set up to build a kernel for anything other than a c7x0 atm anyway, however someone else may well be able to do so.

I imagine that libusb uses the USB (dev)fs so you will probably have no use for it.

Here (http://geocities.com/i0xox0i/), I read this:

There is also the EarthMate Userland Library project located here: http://emul.berlios.de
for people using Linux 2.4.x/2.6.x, Mac OS X/Darwin, and BSD.

Note the 2.4.x part.

I have provided the emul lib, and gpsd patched to use it. I've no idea if it'll work or not I'm afraid, but you can only try it out.

So you said you compiled it for OE, so what should I be using? OZ 3.5.3, Opie or GPE?

OZ 3.5.3, probably Opie, though GPE is an option - depends on what you want by way of apps, or whether you want to use an existing Qtopia (Sharp ROM) app (which will require Opie).

Take a look in the feeds and see if anything catches your eye, or ask on #openzaurus.

Link to images here: http://www.openzaurus.org/official/unstable/3.5.3/sl6000/
Link to main feed: http://www.openzaurus.org/official/unstable/3.5.3/feed/

Go to the top of the page
+Quote Post
post May 9 2005, 10:20 AM
Post #3

Group: Members
Posts: 124
Joined: 11-January 05
Member No.: 6,189

Although I've used Linux for years, I've spent 99% of my time on Perl, PHP, and MySQL. I don't have much experience with drivers (except for following explicit directions) and kernel modules (same).

So what I'm gathering from your posts is that I should just install the libraries (libusb and libemul) that you compiled, and install the gpsd binary that you compiled, and if everything worked right in compiler land, gpsd should work?

That would be great if it works. I'll let you know if it works for me. I know there was at least one other person in these forums with the same problem, hopefully he'll see these updates as well, and maybe we can get his feedback also.
Go to the top of the page
+Quote Post
post May 9 2005, 11:19 AM
Post #4

Group: Members
Posts: 124
Joined: 11-January 05
Member No.: 6,189

Tried to ipkg install the libusb you had up on that page; http://students.bath.ac.uk/enpsgp/Zaurus/e...-r1_armv5te.ipk

Installing.. blah blah
ipkg_conf_write_status_files: Can't open status file: /mnt/card/packages//usr/lib/ipkg/status for writing: Read-only file system.

The double slash (//) is not a typo.

When I try to usr sirfmon or emul_test I get errors.

sirmon wants a device name. I used
mknod /dev/usb/ttyUSB1 c 180 0
although I wasn't sure if that was correct or not.

But it just tells me No such device.


em_open: Device or resource busy
Check node permissions and device attachment.

Same error as before I ran mknod

I saw a page somewhere in the OE documents which had specific mknod instructions, but for the life of me I can't find it sad.gif
Go to the top of the page
+Quote Post

Posts in this topic
lwong   Got Earthmate USB GPS, now what?   May 7 2004, 05:37 PM
dmilligan   I am guessing /dev/ttyUSBXXX - you will probably n...   May 7 2004, 05:49 PM
lwong   Could you elaborate a little as I am not familiar ...   May 7 2004, 05:56 PM
Gondola   I got one of the iRiver adapters (great deal btw)....   Jan 25 2005, 02:23 PM
Gondola   I've tried to put "-p /dev/ttyUSB1" ...   Jan 25 2005, 07:45 PM
Gondola   Bump. I did some Googling in an attempt to figure...   Jan 27 2005, 08:18 AM
hellbilly   QUOTE(Gondola @ Jan 27 2005, 11:18 AM)Bump. ...   Apr 3 2005, 09:19 AM
Gondola   Bump.   Jan 29 2005, 07:44 AM
lardman   QUOTEI would appreciate if someone with more knowl...   Apr 3 2005, 10:16 AM
Gondola   Actually, it turns out that it's more complex ...   Apr 4 2005, 10:57 AM
Gondola   Bump. I'm still interested in getting my GPS ...   May 2 2005, 11:29 AM
lardman   Sorry, I lost track of this thread. I note from:h...   May 7 2005, 09:36 AM
lardman   Right, Mickeyl has given me a hand, and now the si...   May 8 2005, 06:18 AM
Gondola   QUOTE(lardman @ May 8 2005, 02:18 PM)Right, M...   May 9 2005, 07:41 AM
lardman   QUOTEThe 2.4 kernel required patches to use the cu...   May 9 2005, 09:39 AM
Gondola   Although I've used Linux for years, I've s...   May 9 2005, 10:20 AM
Gondola   Tried to ipkg install the libusb you had up on tha...   May 9 2005, 11:19 AM
Gondola   Ok, it looks like maybe the mknod should be ...   May 9 2005, 11:44 AM
lardman   I hadn't thought you'd need libusb, howeve...   May 9 2005, 02:45 PM
lardman   It's just occured to me that libusb may well b...   May 9 2005, 03:01 PM
Gondola   I appreciate your help, lardman. I'll try to ...   May 9 2005, 05:22 PM
lardman   Okay, do the following: 1. hrw has added libusb t...   May 10 2005, 03:14 AM
Gondola   Ok, some results... armv5te was already in my /et...   May 10 2005, 04:38 AM
lardman   QUOTEthe card, which is vfat, not ext2 Can you fo...   May 10 2005, 05:00 AM
Gondola   Well, after a couple hours I was able to get every...   May 10 2005, 10:19 AM
lardman   QUOTE- Installed libusb - Installed gpsd - Install...   May 10 2005, 02:14 PM
lardman   There's one more issue (of course), qpegps doe...   May 11 2005, 01:37 AM
Gondola   The sirfmon and emul_test programs aren't work...   May 11 2005, 08:45 AM
lardman   Are you online atm - come and talk in #openzaurus,...   May 11 2005, 08:50 AM
lardman   libusb must be working otherwise this would fail a...   May 11 2005, 09:04 AM
lardman   Next suggestion - see which module is grabbing the...   May 11 2005, 09:09 AM
Gondola   Ok, I need to verify the file names from the libus...   May 11 2005, 06:59 PM
lardman   You don't need ipkg-utils. You just need ipkg...   May 12 2005, 01:09 AM
dignome   Hi guys. Sorry about all the confusion with the p...   Jun 9 2005, 01:31 AM
zipmaster   so has anymore got it working using the emul thing...   Jun 9 2005, 03:46 PM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 18th June 2018 - 11:08 PM