OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Got Earthmate USB GPS, now what?
lwong
post May 7 2004, 05:37 PM
Post #1





Group: Members
Posts: 53
Joined: 18-March 04
From: USA
Member No.: 2,388



I took the plunge and got the Delorme Earthmate USB GPS.

The 6000 recognize it right away as "Delorme USB Earthmate". dmesg says something about

USB HID v1.00 Pointer [Delorme Publishing Delorme Earthmate] on usb 1.27.0

Now what do I do? I installed qpegps but the defualt path is

-p /dev/ttyS0 -s -4800

Is that for connection through serial cale? What should I change it to?

One good thing about the setup is that the Z can power the GPS all by itself. The bad is that if qpegps is run in 640x480 mode, it looks skewed.

Please help me set this up.

Thanks

FW
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
lardman
post May 11 2005, 01:37 AM
Post #2





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



There's one more issue (of course), qpegps doesn't work with the latest versions of gpsd - even if gpsd is spewing data out, qpegps won't recognise it and will remain red - so if you can find out when the changes occurred in gpsd, I'll see if I can find an old version and perform the emul patch on that.

Otherwise, you'll (or I'll) need to use the version of gpsd which the qpegps people have on their site, and try to patch that with the emul patch (sounds like a fair bit of work to do).

Anyway, the moral of the story is ignore qpegps for the time being and just test whether there are any comms by telneting to gpsd, and using emul_test.


Si

This post has been edited by lardman: May 11 2005, 01:39 AM
Go to the top of the page
 
+Quote Post
Gondola
post May 11 2005, 08:45 AM
Post #3





Group: Members
Posts: 124
Joined: 11-January 05
Member No.: 6,189



The sirfmon and emul_test programs aren't working.

QUOTE
root@tosa:/home/gondola# sirfmon emate
emate: No such file or directory
root@tosa:/home/gondola# emul_test
        em_open: Device or resource busy
        Check node permissions and device attachment.
root@tosa:/home/gondola# emul_test d1
em_open - Successfuly opened device.
em_open: dettached driver hid from device
em_open: failed to claim device
        em_open: Device or resource busy
        Check node permissions and device attachment.


There appears to be something possibly wrong with my libusb install.

QUOTE
root@tosa:/home/gondola# find / -name libusb*
/usr/bin/libusb-config
/usr/lib/ipkg/info/libusb.list
/usr/lib/ipkg/info/libusb.postinst
/usr/lib/ipkg/info/libusb.control
/usr/lib/libusbpp-0.1.so.4
/usr/lib/libusb-0.1.so.4
/usr/lib/libusbpp-0.1.so.4.4.2
/usr/lib/libusb-0.1.so.4.4.2


Although
QUOTE
root@tosa:/home/gondola# ipkg info 'libusb*'
Package: libusb
Version: 0.1.10a-r1
Depends: libstdc++6 (>= 3.4.3), libc6 (>= 2.3.2+cvs20040726), libgcc1 (>= 3.4.3)
Status: install user installed
Architecture: arm
Installed-Time: 1115829140


I tried to extract the ipk file to see if the filename matches the one in /usr/lib, but gunzip libusb.tar.gz says Invalid magic. Not sure how else to check it. The command line help for ipkg doesn't say anything about listing the contents of an ipk file, or I'm reading it wrong.
Go to the top of the page
 
+Quote Post

Posts in this topic
lwong   Got Earthmate USB GPS, now what?   May 7 2004, 05:37 PM
dmilligan   I am guessing /dev/ttyUSBXXX - you will probably n...   May 7 2004, 05:49 PM
lwong   Could you elaborate a little as I am not familiar ...   May 7 2004, 05:56 PM
Gondola   I got one of the iRiver adapters (great deal btw)....   Jan 25 2005, 02:23 PM
Gondola   I've tried to put "-p /dev/ttyUSB1" ...   Jan 25 2005, 07:45 PM
Gondola   Bump. I did some Googling in an attempt to figure...   Jan 27 2005, 08:18 AM
hellbilly   QUOTE(Gondola @ Jan 27 2005, 11:18 AM)Bump. ...   Apr 3 2005, 09:19 AM
Gondola   Bump.   Jan 29 2005, 07:44 AM
lardman   QUOTEI would appreciate if someone with more knowl...   Apr 3 2005, 10:16 AM
Gondola   Actually, it turns out that it's more complex ...   Apr 4 2005, 10:57 AM
Gondola   Bump. I'm still interested in getting my GPS ...   May 2 2005, 11:29 AM
lardman   Sorry, I lost track of this thread. I note from:h...   May 7 2005, 09:36 AM
lardman   Right, Mickeyl has given me a hand, and now the si...   May 8 2005, 06:18 AM
Gondola   QUOTE(lardman @ May 8 2005, 02:18 PM)Right, M...   May 9 2005, 07:41 AM
lardman   QUOTEThe 2.4 kernel required patches to use the cu...   May 9 2005, 09:39 AM
Gondola   Although I've used Linux for years, I've s...   May 9 2005, 10:20 AM
Gondola   Tried to ipkg install the libusb you had up on tha...   May 9 2005, 11:19 AM
Gondola   Ok, it looks like maybe the mknod should be ...   May 9 2005, 11:44 AM
lardman   I hadn't thought you'd need libusb, howeve...   May 9 2005, 02:45 PM
lardman   It's just occured to me that libusb may well b...   May 9 2005, 03:01 PM
Gondola   I appreciate your help, lardman. I'll try to ...   May 9 2005, 05:22 PM
lardman   Okay, do the following: 1. hrw has added libusb t...   May 10 2005, 03:14 AM
Gondola   Ok, some results... armv5te was already in my /et...   May 10 2005, 04:38 AM
lardman   QUOTEthe card, which is vfat, not ext2 Can you fo...   May 10 2005, 05:00 AM
Gondola   Well, after a couple hours I was able to get every...   May 10 2005, 10:19 AM
lardman   QUOTE- Installed libusb - Installed gpsd - Install...   May 10 2005, 02:14 PM
lardman   There's one more issue (of course), qpegps doe...   May 11 2005, 01:37 AM
Gondola   The sirfmon and emul_test programs aren't work...   May 11 2005, 08:45 AM
lardman   Are you online atm - come and talk in #openzaurus,...   May 11 2005, 08:50 AM
lardman   libusb must be working otherwise this would fail a...   May 11 2005, 09:04 AM
lardman   Next suggestion - see which module is grabbing the...   May 11 2005, 09:09 AM
Gondola   Ok, I need to verify the file names from the libus...   May 11 2005, 06:59 PM
lardman   You don't need ipkg-utils. You just need ipkg...   May 12 2005, 01:09 AM
dignome   Hi guys. Sorry about all the confusion with the p...   Jun 9 2005, 01:31 AM
zipmaster   so has anymore got it working using the emul thing...   Jun 9 2005, 03:46 PM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th December 2014 - 07:49 PM