OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Compiling with jdk 1.1.8 javac
prun769
post Jul 11 2004, 07:13 PM
Post #1





Group: Members
Posts: 24
Joined: 8-January 04
Member No.: 1,391



Has anyone had any luck compiling on their Z using the jdk 1.1.8 javac? I have it all set up using the jeode evm and the sun classes.zip. For command line programs it compiles great. When I try to compile an AWT program however, it throws an ArrayIndexOutOfBoundsException when attempting to load java.awt.GridBagLayout.

Out of curiousity, I compiled it using the wintel jdk 1.1.8 and it compiled fine. I tried both the windows and and solaris classes.zip, and both give the same behavior. I also tried including the classes.zip before the jeode jars in the classpath , and the only difference is that I get a ClassCastException instead.

I've switched to jikes in the meantime, but I was wondering if anyone actually got this to work on an awt program.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
smuelas
post Jul 1 2005, 12:46 PM
Post #2





Group: Members
Posts: 110
Joined: 15-October 04
Member No.: 5,026



Excuse me for going into your thread but I have observed serious faults on Z6000 using Jikes. Most specially when compiling quite big applications that use a lot of numbers, "double numbers".
It is simply totally faulty. On the contrary, with jdk1.1.8 from blackdown everything runs smoothly with exactly the same results, up to five digits, than in a "big" desktop and running Java5.
Perhaps I am doing something stupid with Jikes, but I've tried many times, compiling and/or downloading it. :-(
Smuelas
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st December 2014 - 03:11 PM