OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> dev-img-1.5 tmake, i can't find tmake
angst
post Aug 23 2004, 06:28 PM
Post #1





Group: Members
Posts: 33
Joined: 28-February 04
From: Oak Harbor, WA
Member No.: 2,077



I've been trying to set up dev-img-1.5 on my sl6000's ext2 SD card. The cramfs is mounted at /mnt/dev as the instructions say and image_setup.sh completes with no complaints.

I had to add /home/zaurus/develop/bin to the path in /home/QtPalmtop/qpe.sh in order to use g++ and gcc. Small hello world programs compile fine with both.

The problem is that I cannot find tmake anywhere on my zaurus. There are some tmake docs but no executable that i can find. I mounted another copy of dev-img-1.5 on my cf card and searched it with no luck either.

Any ideas? Suggestions?

TIA
Go to the top of the page
 
+Quote Post
clivel
post Aug 23 2004, 07:16 PM
Post #2





Group: Members
Posts: 84
Joined: 3-October 03
From: Vancouver, BC
Member No.: 560



Hi,
You can get Tmake from ftp://ftp.trolltech.com/freebies/tmake/.
Although, if I recall correctly it is written in Perl, which means that you will have to have Perl installed to run it.
Regards,
Clive
Go to the top of the page
 
+Quote Post
angst
post Aug 24 2004, 08:39 AM
Post #3





Group: Members
Posts: 33
Joined: 28-February 04
From: Oak Harbor, WA
Member No.: 2,077



Okay. Thanks, clivel. Seeing the tmake docs in the img made me think tmake was in the image.

dev_img-1.5 already has perl 5.8 in it. It spits out the version number when asked though it also complains about some locale (lang, money...) settings. I don't know enough about perl yet to test it out thoroughly.

Thanks.
Go to the top of the page
 
+Quote Post
iamasmith
post Aug 24 2004, 09:02 AM
Post #4





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



The locale warning can be got rid of by exporting the variable PERL_BADLANG=0.

I would suggest adding a line to /opt/Qtopia/bin/qpe.sh with the other exports to do this as .bashrc doesn't seem to run when you first start terminal but qpe.sh does.
Go to the top of the page
 
+Quote Post
freizugheit
post Aug 24 2004, 07:54 PM
Post #5





Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811



Angst,

Thanks for the pointer for the location of Perl 5.8.0.

As tmake requires perl to be under /usr/bin, the following step help check dev-img-1.5 installaion and acitvate symbolic linkage for perl :

- To check the installation by typing "which make", it should show "/mnt/card/.zgcc/bin/make" for my case

- To activate symbolic linkage for perl:

ln -s /mnt/card/perl/perl5.8.0/bin/perl /usr/bin/perl

The following has been tested with the t1 tutorial from qt.

- Type "tmake t1.pro > Makefile"
- Type "make" to compile and link the program and the resultant file is t1
- Type "./t1" to activate your qt application.


Voila!!!!
Go to the top of the page
 
+Quote Post
angst
post Aug 25 2004, 12:23 PM
Post #6





Group: Members
Posts: 33
Joined: 28-February 04
From: Oak Harbor, WA
Member No.: 2,077



Thanks for the tips iamasmith, freizugheit. I'll get this thing working properly sooner or later. Hopefully sooner than later.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd December 2014 - 04:49 PM