OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Start OZ from console
Richjn
post Dec 15 2003, 07:51 PM
Post #1





Group: Members
Posts: 121
Joined: 21-October 03
Member No.: 696



Hi

I have installed OZ 3.3.5 (gcc3.x) and have updated all of the packages from the unstable feed. (I had to download them all to an SD card as the only feed working is the stable feed) everthing went o.k and I rebooted the Z. The problem I know have is that on reboot you get a console login which works fine (just root and no password) but I dont know how to start the qtopia gui :oops: Can someone help.

Richard
Go to the top of the page
 
+Quote Post
Richjn
post Dec 15 2003, 08:01 PM
Post #2





Group: Members
Posts: 121
Joined: 21-October 03
Member No.: 696



Answering my own question it's just qpe to start but I now get a relocation error message for libopie.so.1. I guess the unstable feed is er-- unstable.

Richard
Go to the top of the page
 
+Quote Post
cgav8r
post Dec 15 2003, 09:38 PM
Post #3





Group: Members
Posts: 31
Joined: 15-December 03
Member No.: 1,193



I had the same results. The first time I had a debug overflow problem or something, whenever I touched the screen I got output that pushed the GUI up and blocked out the toolbar. So, I installed the tkc ROM. Then I found some posts about editing with the line "echo 1 > /proc/sys/kernel/printk" and thought I'd try oz again. Then I ended up like you. I gave in and installed Zynergy. I am able to work-around the package GUI installer by keeping the SD card installed.

I'll stay with Zynergy untill oz for 5600 becomes stable.
Go to the top of the page
 
+Quote Post
Mickeyl
post Dec 16 2003, 05:23 AM
Post #4





Group: Members
Posts: 1,497
Joined: 12-November 03
From: Germany
Member No.: 907



Sounds like you mixed gcc2 and gcc3 packages. Unfortunately as of now, there's no possibility for ipkg to warn about that.
Go to the top of the page
 
+Quote Post
Richjn
post Dec 16 2003, 05:33 AM
Post #5





Group: Members
Posts: 121
Joined: 21-October 03
Member No.: 696



Mickeyl

No, that's not it I have tried the gcc 2.x version and it is much more useable in terms of installing packages etc I just felt it was a step backwards for me so was retrying the gcc 3.x version but was careful to ensure that the updates I retreived were from the unstable feed not the gcc 2.x feed. One thing, however the package manager tries to look at the same source regardless of which version you have installed ? Does this mean that the unstable ipk,s folder is in fact all compiled with gcc 2.x which would explain my problem. If so it may be worth putting a note on the feeds so people know.

Thanks

Richard
Go to the top of the page
 
+Quote Post
Mickeyl
post Dec 16 2003, 07:00 AM
Post #6





Group: Members
Posts: 1,497
Joined: 12-November 03
From: Germany
Member No.: 907



I recommend looking at the file structure. A feed is always coupled with an initrd and the initrd tells by its suffix what gcc it is. If there is no suffix, it is gcc2. If there is a gcc2 or gcc3 suffix then it is gcc2 resp. gcc3.
Go to the top of the page
 
+Quote Post
Richjn
post Dec 16 2003, 02:42 PM
Post #7





Group: Members
Posts: 121
Joined: 21-October 03
Member No.: 696



Mickeyl

Thanks for info

I have checked back on my file sources and it seems (tired late at night) that I couldn't get a feed to work from OZ sight direct so set up a feed from handhelds.org here.

http://opie.handhelds.org/feed/openzaurus/unstable/

Which seemed to have more recent versions and in particular the new Opie Mail that I wanted to try. Checking back to the feed I can't find reference to whether it's 2.x or 3.x and would be interested to know.

If it is 2.x this explains why I had problems but brings us back to the original 3.x problem that you can't install *some* apps with the useual failure being "cant find application" when you try to launch from the gui and console. I have tried installing via gui and console and to root / cf /sd all with the same result. It's interesting to note that Oxegen has the same error despite being a pre installed app.

if you would like me to try something out I'm happy to run any tests you want.

Richard
Go to the top of the page
 
+Quote Post
Mickeyl
post Dec 16 2003, 02:46 PM
Post #8





Group: Members
Posts: 1,497
Joined: 12-November 03
From: Germany
Member No.: 907



The OpenZaurus feed on the Opie homepage is gcc2. The problems with launching some apps is due to the quicklauncher transition and seems to be corrected in cvs.
Go to the top of the page
 
+Quote Post
Richjn
post Dec 16 2003, 03:05 PM
Post #9





Group: Members
Posts: 121
Joined: 21-October 03
Member No.: 696



Mickeyl

Thanks again

I am keen to give it another go as I realy like the OZ apps and setup and am very much looking forward to OE when its ready. In the meantime can you supply an address to point a CVS client at to get the latest feed. Sorry if this sound dumb but I have never set up a CVS so will read up on it but I need a place to start.

Thanks

Richard
Go to the top of the page
 
+Quote Post
Mickeyl
post Dec 16 2003, 03:16 PM
Post #10





Group: Members
Posts: 1,497
Joined: 12-November 03
From: Germany
Member No.: 907



The feeds are not in cvs, only the source code is (cvs.handhelds.org). The corrected version will be available as soon as someone builds a feed out of the cvs.
Go to the top of the page
 
+Quote Post
Richjn
post Dec 16 2003, 03:40 PM
Post #11





Group: Members
Posts: 121
Joined: 21-October 03
Member No.: 696



Thanks

I will have a go at doing just that.

Richard
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st October 2014 - 05:59 PM