OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Getting opie-recorder to work in 3.5.1, on a 5500; quirks remain
post Oct 22 2004, 05:29 AM
Post #1

Group: Members
Posts: 366
Joined: 4-November 03
From: Slovakia
Member No.: 850

Hi all,

if anyone of you tried the sound recorder app that comes with 3.5.1, you probably produced samples of length 0.00 seconds - at least that's what happened to me. Turns out it can be fixed quite easily: edit /root/Settings/OpieRec.conf and in the [Hardware] section, add or modify these two lines:

Audio = /dev/dsp1
Mixer = /dev/mixer1

You should now be able to record audio with these caveats:
  • It seems that opie-recorder severely miscalculates maximum allowable sample duration (there must be a multiplication error somewhere). The upshot is that if you leave Limit Size (under Options) at Unlimited, recording will automatically stop after as little as a second (with 10MB of free storage left). The solution is to set Limit Size to the highest possible numerical value, i.e. 60.
  • If you change sample rate or bit depth, it is a smart move to shut down and re-start opie-recorder. Otherwise you will get .wav files with incorrect sample rate specifications - to great comic effect I must say.
  • You will not be able to play back what you record, because while /dev/dsp1 is the correct device for recording, /dev/dsp is the one for playback. opie-recorder currently does not support specifying one device for recording and another one for playback. Workaround: use xmms-embedded to play back your wav files. Alternatively, you can keep two versions of OpieRec.conf and set up scripts which will run opie-recorder with the proper version depending on whether you want to record or play back.
  • As for mixers, both /dev/mixer and /dev/mixer1 seem to work fine for playback although I once got an infinite loop with one of them, forcing a soft-reboot (can't remember which device it was, though). For recording, /dev/mixer1 seems logical (although I haven't actually tried altering input volume).
Hope this helps.

Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 22nd May 2018 - 02:34 AM