OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> `rm -rf /home/zaurus` by accident
suruaZ
post Oct 27 2004, 02:23 AM
Post #1





Group: Members
Posts: 123
Joined: 12-April 04
Member No.: 2,809



Accidentally deleted /home/zaurus folder sad.gif
Now can't start GUI - init eight times tried to start QT unsuccesfully and then prints:
"INIT: ld "ln" respawing too fast: disabled for 5 mintues."

I'm still able to login as root in console mode. Is there a way to fix the issue???

suruaZ
Go to the top of the page
 
+Quote Post
tumnus
post Oct 27 2004, 03:31 AM
Post #2





Group: Members
Posts: 1,176
Joined: 3-October 03
From: UK
Member No.: 547



Whoops. Been there, done that on my PC (I now have cron jobs setup to do automatic backups).

You'll have to restore the original files in /home/zaurus. I doubt you can use 'recover' since the filesystem is in RAM on your 5500.

To restore the original files:

1) Login to the console as root
2) cd /
3) tar xvf /root/.home_default.tar home/zaurus

(Note there is no '/' at the beginning of the 'home/zaurus' in the command above)
Go to the top of the page
 
+Quote Post
suruaZ
post Oct 27 2004, 05:19 AM
Post #3





Group: Members
Posts: 123
Joined: 12-April 04
Member No.: 2,809



QUOTE
1) Login to the console as root
2) cd /
3) tar xvf /root/.home_default.tar home/zaurus


Thanks tumnus! This made things to work again wink.gif

suruaZ
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th October 2014 - 10:58 AM