OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

4 Pages V  < 1 2 3 4 >  
Reply to this topicStart new topic
> ANN: ZMacSync-1.5b1 available
dhns
post Nov 11 2004, 06:30 AM
Post #31





Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043



QUOTE(ashikase @ Nov 11 2004, 02:55 PM)
Through some testing, I've found that when attempting to fetch data, for both b1 and b2, while it appears that an ssh connection is established, the 'dtm2xml' utility is never called. It looks like the ssh connection is cancelled as soon as the request for the command to execute is made... as if the command fails to run/is not found. Are any other commands run over ssh before dtm2xml?

Yes,
the auto-install is a "tar" command run through ssh in the b2 release before doing dtm2xml.

And there is a "chmod" in b1&b2 (and was in the 1.0a releases) to fix one of the permissions of the openssh-server files so that they don't crash Calendar in Month view (that is a really strange and unexpected interference between both). So, one of these both might fail on your machine.

I think all these hurdles can be removed and fixed with a new .ipk that installs all what is needed on the Zaurus in a proper way.

An additional reason I can think of is the ssh password (un?fortunately, there is no command line option for ssh to specify the password so that nobody can use "ps ax" for eavesdropping). If the ssh server wants to see a password, it asks the client on the Mac to type it into stdin. The logic in ZMacSync is to send the password as the first line if one is available (not if requested). So, if ssh wants to see one but ZMacSync does not provide, the process might hang or fail.

I will do some tests on that and there might be a more robust way to handle ssh passwords.

-- hns
Go to the top of the page
 
+Quote Post
ganoe
post Nov 11 2004, 08:15 AM
Post #32





Group: Members
Posts: 65
Joined: 31-January 04
Member No.: 1,607



QUOTE(dhns @ Nov 11 2004, 03:44 AM)
QUOTE(ganoe @ Nov 11 2004, 12:04 AM)
webcal://cscl.ist.psu.edu/public/calendar.ics
webcal://cscl.ist.psu.edu/public/hci/calendar.ics

Thank you very much. I have subscribed to all calendars and will have a deeper look into the file structure later. Interestingly, iCal prints messages about an invalid character in these two calendards. So iCalendar standard seems to have different interpretations...

OK, well I'm responsible for the code that generates those two calendars. What log, etc. are you looking at to see the invalid character messages?
QUOTE
QUOTE
Unfortunately, it created duplicates of all my addresses inside my Mac's Address Book.

For the duplicates we will have to look again into the unique-ID mechanism. It appears that firstly, your addressbook was copied to the Zaurus and then (because of lost references) added back.

Well this seems critical for syncing to work properly. If there is any other info I can provide, let me know.
Go to the top of the page
 
+Quote Post
dhns
post Nov 11 2004, 12:52 PM
Post #33





Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043



QUOTE(ganoe @ Nov 11 2004, 05:15 PM)
What log, etc. are you looking at to see the invalid character messages?

It is like

2004-11-11 08:07:13.514 iCal[412] Invalid char
(13) for PropertyValue in line 4
2004-11-11 08:07:13.514 iCal[412] Invalid char
(13) for PropertyValue in line 5
2004-11-11 08:07:13.515 iCal[412] Invalid char
(13) for PropertyValue in line 6
2004-11-11 08:07:13.515 iCal[412] Invalid char
(13) for PropertyValue in line 7
2004-11-11 08:07:13.515 iCal[412] Invalid char
(13) for PropertyValue in line 8
2004-11-11 08:07:13.516 iCal[412] Invalid char
(13) for PropertyValue in line 9
2004-11-11 08:07:13.516 iCal[412] Invalid char
(13) for PropertyValue in line 10

and so on in console.log. So it looks like (my) iCal 1.5.2 (v637) complains about a \r character although I am quite sure the iCalendar standard expects \r\n (CRLF) as a line separator.

And the one with yet unrecognized "TZ:" entries is http://www.hokiesports.com/cgi-bin/new-sch...?sport=football

-- hns
Go to the top of the page
 
+Quote Post
ashikase
post Nov 12 2004, 04:27 AM
Post #34





Group: Members
Posts: 280
Joined: 17-March 04
From: Osaka, Japan
Member No.: 2,375



I finally was able to get ZMacSync to work.

After further ssh debugging, I found that the process was failing on the command:
CODE
/bin/chown -R zaurus.qpe /home/zaurus/Documents/OpenSSH

I already had openssh installed before trying ZMacSync, so I didn't install your version. Thus, I didn't have the OpenSSH documentation folder. I solved the problem by just creating an empty OpenSSH directory.

I'm curious, though, why it is necessary to chown a documentation folder? It seems unnecessary. In fact, on my zaurus, my Documents folder is actually a link to my CF drive, which is formatted FAT32 - thus mod and ownership flags means nothing.

ZMacSync works now, though it still feels a little rough (er, no offense meant). I ran the sync a few times in a row, without changing any files, and yet it *appeared* to find differences (whether it actually did or not, I can't confirm).

I would definately prefer a 'no automatic sync' option... the constant fetching of data from the zaurus is a nuisance, especially since the GUI quits responding during the fetch. Plus, I don't feel the need to sync my data every few seconds... once a day is good enough for me.

Also, I tried setting the sync options to just adjust the clock, but when I then performed a sync, the program still fetched data from my Z, and appeared to be synchronizing the data (at least, according to the status messages).

Don't get me wrong, I really appreciate your work, and will gladly purchase a copy... once the wrinkles are ironed out (^_^;)

- ashikase
anpachi, gifu, japan
Go to the top of the page
 
+Quote Post
dhns
post Nov 12 2004, 06:34 AM
Post #35





Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043



QUOTE(ashikase @ Nov 12 2004, 01:27 PM)
I finally was able to get ZMacSync to work.

Great that it now works and I really appreciate such feedback!

The chmod issue with the Documents folder is a known bug at least in the ROM 3.10 for the 5500 series (I think there is already a thread here on ZUG) within the openssh-server package. It installs ALL files with "chmod 600" and "chown root" including those in the documentation folder. This has the strange effect that the Calendar application crashes in Month View. You might now wonder how this can happen as Calendar has nothing to do with openssh. The reason is that Calendar scans all Document folders to show the documents changed on a specific date. And this scanning process is not prepared to find a folder it has no access to (600 for root owner) because Calendar is running as user id "zaurus". So we have simply added a "fix" but did not expect your set-up of the documents folder. This can come up only in such a beta test.

So, for the next (beta) release, dtm2xml will include openssh-server with proper access rights - and without documentation. So if you install this, this issue should disappear.

If you want to look which "differences" ZMacSync thinks it has found, please click on the i button and a table will appear that lists all entries. One column is the status (A)dded, ©hanged, (D)eleted and the other is (A)ddress, ©alendar, (S)tickie, (T)odo. It typically shows some abbreviated contents or at least the unique-ID.

The auto-sync should come not faster than every 60 seconds or if the Zaurus becomes connceted - and run completely in the background. So, if a different application is in the active one you probably won't notice even. Making this a parallel thread to the user interface is something to consider for a 2.0 version... But I think we should now simply add a preference to enable/disable.

Finally, on the sync enable/disable. This behaviour comes from the following concepts:
* the enable/disable controls only writing to the database of a device.
* Fetching is always done to identify changes that occurred since your last sync.
* These changes are advertized to the other side and might get written.

So, if you disable everything for the Zaurus side besides the Clock, it will still have to fetch data, look for changes and advertize changes towards the Mac. If it is enabled there, it will update the Mac. So, it is a "write protect" feature and not a "read disable".

QUOTE
... and will gladly purchase a copy... once the wrinkles are ironed out (happy.gifwink.gif

That is exactly in line with our philosophy of defining software for your needs and running free beta tests. The software must convince you that it is worth its price.

-- hns
Go to the top of the page
 
+Quote Post
bgotori
post Nov 12 2004, 04:37 PM
Post #36





Group: Members
Posts: 11
Joined: 28-February 04
Member No.: 2,083



Hey dhns

Well I finally got some time to try this out. The Mac end seems to work fine on my Pismo 400 running OS X 10.3.6, but the Zaurus end doesn't seem to load the Openshh-server 3.6.1p 1 properly... Program finishes with the button at the end of loading to finish, but when I press it it kicks me to some sort of program that I can't get out of(file lookup kind of screen). If I flip the switch and restart shows the restart screen then it just keeps cycling with a countdown...

I'll try the Newer download and see if it clear things up.


Hope this works for me!!!

Brad
Go to the top of the page
 
+Quote Post
dhns
post Nov 12 2004, 10:50 PM
Post #37





Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043



QUOTE(bgotori @ Nov 13 2004, 01:37 AM)
but the Zaurus end doesn't seem to load the Openshh-server 3.6.1p 1 properly... Program finishes with the button at the end of loading to finish, but when I press it it kicks me to some sort of program that I can't get out of(file lookup kind of screen). If I flip the switch and restart  shows the restart screen then it just keeps cycling with a countdown...

I'll try the Newer download and see if it clear things up.

Hm,
that seems to be an issue with the installer and the openssh ipk. Openssh is the latest one that is stored on Killefiz (http://www.killefiz.de/zaurus/showdetail.php?app=1035). So please download from there and tell me if there are any differences. Which Zaurus model and ROM version did you use?

-- hns
Go to the top of the page
 
+Quote Post
bgotori
post Nov 13 2004, 04:45 PM
Post #38





Group: Members
Posts: 11
Joined: 28-February 04
Member No.: 2,083



Hey dhns

Well I got the openssh loaded!!! My problem is the last update for the Cacko 3.10 SL5000 ROM!!! Went back to the old version and it loaded!!! YEAH!!!

But trying the 1.5b2 ZMacSync, it starts up and shows the Window for about 9 sec's then quits... I noticed that the 1.5b2 version readme doesn't show loading the""dtm2xml-1.3_arm.ipk"". So I removed it. Same effect... Funny thing is when I tried to load the""dtm2xml-1.3_arm.ipk"" it finishes but it still Red in the Window... When oppenssh loaded and finished it turned Blue like usual... but I looked at it in the uninstall Screen, it shows its loaded...

I went back to the 1.5b1 version that one loads, but it doesn't sync... It says this""Commit error for Zaurus-1 with"" or this ""Data from Zaurus-1 not available""

I'm doing this with a Pismo 400 with 1gb ram, 80gb drive, and SuperDrive.


Thanks For All the Work Keep it UP!!!

Brad
Go to the top of the page
 
+Quote Post
dhns
post Nov 14 2004, 08:06 AM
Post #39





Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043



QUOTE(bgotori @ Nov 14 2004, 01:45 AM)
Well I got the openssh loaded!!! My problem is the last update for the Cacko 3.10 SL5000 ROM!!! Went back to the old version and it loaded!!! YEAH!!!

I also got a report for a C860 cacko Elena 1.21b with similar issues.

The console.log revealed that /usr/bin/killall was not available on that machine. So, does anybody know or can test if killall is on a different path on Cacko ROM? And/or if "/bin/busybox killall" does work?

The killall command is required to properly shut down all the PIM applications before writing anything to the DTM database.

QUOTE
Funny thing is when I tried to load the""dtm2xml-1.3_arm.ipk"" it finishes but it still Red in the Window... When oppenssh loaded and finished it turned Blue like usual... but I looked at it in the uninstall Screen, it shows its loaded...

This turned out to be a bug in the Package: entry of the .ipk file. Has been fixed for the next release.

Many thanks,
hns
Go to the top of the page
 
+Quote Post
bgotori
post Nov 14 2004, 08:51 AM
Post #40





Group: Members
Posts: 11
Joined: 28-February 04
Member No.: 2,083



Hey dhns

Thanks for All the Hard Work!!!

Wish I was a programmer type, to get my problems told to you in a better... I'm just a User...hehehe

Can't wait for the next release!!! I'm so close...hahaha


Thanks Again!!!

Brad
Go to the top of the page
 
+Quote Post
dhns
post Nov 15 2004, 02:43 PM
Post #41





Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043



NEW Release available for beta test: Version 1.5b3 at http://www.dsitri.de/wiki.php?page=ZMacSync

New features/fixed bugs:

* made more robust against ssh failures and prints more useful messages
* solved a bug with data loss error on pipe from ssh process (resulted in SIGPIPE, XML Parse Errors, Data not available etc.)
* new combined installer zmacsync.ipk (now contains dtm2xml and openssh-server)
* fixed problem with Package: entry in .ipk files
* solved several issues with parsing iCalendar entries
* Preferences added to enable/disable auto-fetch mode
* progress indicator added
* saves ZMacSync.plist on Zaurus to detect system reset/failure/last sync date, sync attempts with different Macs etc.
* now converts Calendar and ToDo towards the Zaurus

NOTE:You should get a message that your Zaurus has never been synced when starting. In this case, select "Ok". It resets the translation rables.

Many thanks to all those who sent in reports and suggestions!

Known bugs and still missing functionality:

* synced Calendar entries do not show on Zaurus
* synced ToDo entries have no Start, no Due date
* there is no sync of the Mac with the Zaurus for Calendar, ToDo and Notes/Stickies yet
* protected access with Passcode does not work
* the Restore function is not complete
* the Zaurus Owner record is not copied from the 'me' record of the Mac
* About, Help, Manual are missing

So, please test and provide additional feedback for this free beta version (limited in operation until end of November).

Thank you very much,
hns

http://www.dsitri.de/wiki.php?page=ZMacSync

PS: if you want to support this project, you can use KAGI at https://order.kagi.com/cgi-bin/store.cgi?storeID=QM4&&
Go to the top of the page
 
+Quote Post
ganoe
post Nov 16 2004, 08:05 AM
Post #42





Group: Members
Posts: 65
Joined: 31-January 04
Member No.: 1,607



2004-11-16 11:04:17.044 ZMacSync[1538] writeStatus: Loading plugins...
2004-11-16 11:04:18.093 ZMacSync[1538] writeStatus: Local.conduit initialized.
2004-11-16 11:04:18.343 ZMacSync[1538] writeStatus: Zaurus.conduit initialized.
Nov 16 11:04:18 Craigs-Computer /Applications/ZMacSync.app/Contents/MacOS/ZMacSync: objc: Both /Applications/ZMacSync.app/Contents/PlugIns/Local.conduit/Contents/MacOS/Local and /Applications/ZMacSync.app/Contents/PlugIns/Zaurus.conduit/Contents/MacOS/Zaurus have implementations of class mySync.
Nov 16 11:04:18 Craigs-Computer /Applications/ZMacSync.app/Contents/MacOS/ZMacSync: objc: Using implementation from /Applications/ZMacSync.app/Contents/PlugIns/Zaurus.conduit/Contents/MacOS/Zaurus.
2004-11-16 11:04:18.556 ZMacSync[1538] writeStatus: Fetching Local-1 data...
2004-11-16 11:04:18.625 ZMacSync[1538] writeStatus: Data from Local-1 not available.
2004-11-16 11:04:18.935 ZMacSync[1538] writeStatus: Zaurus-1 became available.
2004-11-16 11:04:21.084 ZMacSync[1538] stderr: /home/zaurus/Applications/ZMacSync.plist: No such file or directory
2004-11-16 11:04:21.092 ZMacSync[1538] terminated with error (<CFArray 0x17f8f0 [0xa01900e0]>{type = immutable, count = 6, values = (
0 : -2
1 : -l
2 : <CFString 0x14e890 [0xa01900e0]>{contents = "root"}
3 : <CFString 0x173f60 [0xa01900e0]>{contents = "192.168.129.201"}
4 : /bin/cat
5 : /home/zaurus/Applications/ZMacSync.plist
)})
2004-11-16 11:04:25.064 ZMacSync[1538] writeStatus: Data from Zaurus-1 not available.
2004-11-16 11:04:35.005 ZMacSync[1538] writeStatus: Fetching Local-1 data...
2004-11-16 11:04:35.052 ZMacSync[1538] writeStatus: Data from Local-1 not available.
Go to the top of the page
 
+Quote Post
dhns
post Nov 16 2004, 01:03 PM
Post #43





Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043



mad.gif There is always one more bug...

biggrin.gif NEW Release available for beta test: Version 1.5b4 at http://www.dsitri.de/wiki.php?page=ZMacSync

rolleyes.gif First feedbacks indicate that it might have been the last of the big, roadblocking ph34r.gifph34r.gifph34r.gifph34r.gif ones.

-- hns
Go to the top of the page
 
+Quote Post
bgotori
post Nov 16 2004, 02:50 PM
Post #44





Group: Members
Posts: 11
Joined: 28-February 04
Member No.: 2,083



Hey dhns

Can't wait to try this one tonight!!! Hope it works for me!!!

GREAT KAGI... I can send a money order through them!!!


Thanks Again!!!

Brad
Go to the top of the page
 
+Quote Post
bgotori
post Nov 20 2004, 01:09 PM
Post #45





Group: Members
Posts: 11
Joined: 28-February 04
Member No.: 2,083



Hey dhns

Well I tried everything I could think of to do, but I can't seem to load the newer ZmacSync.ipk... It just finishes loading without making the icon blue showing that it loaded... Tried both version of the Cacko ROM and tried loading the programs seperately but No Go... Will wait for a Newer version.


Thanks for all the Hard Work!!!
Can't wait for it to work for me...hehehe

Brad
Go to the top of the page
 
+Quote Post

4 Pages V  < 1 2 3 4 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th December 2014 - 09:20 AM