OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Info: Charging and Ghosting, Trials of the C860
post Nov 12 2004, 10:22 PM
Post #1

Group: Members
Posts: 183
Joined: 7-September 04
Member No.: 4,501

Hi All,

I've had a hectic week with my Z and I thought I'd post what happened and how I fixed it. A lot of info I got from this group so it really is a good repositry of information.

Anyway, for some reason my 'Digicom Universal Charger' 5V 1.0Amp decided to quit it and didn't charge my Z. I didn't notice till the battery actually went totally flat. After paying $50AUD on my charger I was a bit annoyed that it decided to quit, but apparently the eletronics shop won't replace a charger (Which I guess I can understand). I bought another one, same V same Amp.

Now I accidently reversed the polarity and my Z didn't start charging. After quickly realising my mistake (with heart in my throat and sweaty palms now), I switched the polarity so that the 'Center' is positive and the 'Outside' is negative.

Now my Z charged for maybe 2 minues, then the charge light started flashing on and off slowly. It certainly didn't charge enough to even start. I'm not sure even now if this was caused by the reversed polarity or the fact that it totally flattened.

Anyway, I suppose I should mention that my battery is an EA-BL08, that is supposed to charge to 4.2V apparently. Measuring between + and - with a multimeter showed a voltage of about 2.2V.

Now I can of course boot up fine with 'D+B', logging in as root and issueing a 'reboot' with the power plugged in.

I plugged it into the power and brought up the diagnostic screen with 'D+M'. Went to page 3, EXTRAS, 'Normal Diag Mode' and hit 'Clear Adjust Values', which blanked out 'Tablet' 'COM' and 'PHASE' on the main screen. This did not help (and in fact I think this has nothing to do with the battery charging).

Then went to Page 2, Batt Voltage Adjust, 'Battery Voltage Check'. It showed the following: -
Main Bat AD: 113 (2.2V)

Flash Data: ----

Seemed that the unit didn't know how much to charge the battery to. So I pulled the battery and connected the + terminal from the charger to the + on the battery and the - from the charger to the - on the charger and charged it manually, as per

Aussies HOWTO

When it hit 4.2V, I put it into the Zaurus, did D+M, page 2, Batt Voltage Adjust, 'Battery Voltage Adj' and hit 'S' to flash in the current voltage. Now a check shows the following: -
Main Bat AD:  208 (2.6V)

Flash Data:  213
  delta:  +439

ADJUST AD:  208->  647
                :  (4.1V)

And everything works fine. Phew.

However the 'Clear Adjust Values' step came back to haunt me when I booted into pdaXrom. I had a major ghosting effect, mainly seen down near the task bar. Also I had screen flicker. And now this is important, and probably also why some Z users see screen flicker in pdaXrom and others don't.

Went to D+M. Of course 'Tablet', 'COM' and 'Phase' are still '---'. So I went into Page 1, 'COM ADJ Setting', and set it to '114' which resulted in the image not flickering at all!. Then went into Page 1 'LCD Phase setting', and set it to '8' so I didn't have ghosting. No idea how I set 'Tablet', probably 'Touch Pane (VGA)', and its now currently 0.

Booted back into pdaXrom, and voila, no ghosting, no flickering.

My story. Hope it helps anyone in a similar situation.

I can't remember all the links to the posts that helped me, but I googled using both the terms 'Zaurus not charging' and 'Zaurus won't charge'.

- Bundabrg
Go to the top of the page
+Quote Post
Start new topic
post Aug 19 2006, 07:58 AM
Post #2

Group: Members
Posts: 29
Joined: 15-August 06
From: NYC
Member No.: 10,804

This might get me flamed for being a retard but...

I just got my C1000 yesterday and I noticed the screen flicker problem and when I read this thread, it seemed like it's the solution. So I went to the D+M menu and adjusted the values, but couldn't get out of the menu! I went through the 3 pages and couldn't find any reset or exit button. After awhile I figure what the hey and just hit the power button. It turned off, i hit power button again and I'm in the same menu except it's red this time. I go through the same procedure looking for the reset or exit option but I dont see it and hit power again.. still same menu.. I figured this menu must be like the boot menu on my desktop so I figured I could just pull the plug and it should reset when I put the battery back in.. It doesn't.. I can't power back on anymore! I tried to just plug in the power cord but that doesn't do anything either. I hope I didn't kill the poor thing. Please tell me there's something I can do for it? A way to reset to factory or reset the D+M screen?

As I said, I got it yesterday and am effectively a n00b. Thanks.. I appreciate any help!

I'm running
Cacko QTopia Rom 1.12 1029311005
Kernel 2.4.20
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 26th May 2018 - 03:50 PM