OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> USB Mouse?, keyboard works-mouse howto? pointer app?
saakmotu
post Nov 18 2004, 11:10 AM
Post #1





Group: Members
Posts: 73
Joined: 29-September 04
From: Brooklyn, NY
Member No.: 4,802



I picked up one of the iRiver usb host adapters discussed here
http://www.oesf.org/forums/inde...topic=7922&st=0

It works great, so far.
I've been able to hook up an apple usb keyboard with no issue (except I had to reboot with it plugged in, else the keys weren't mapped properly). Some screwy action from the function keys, but I think it's just a matter of figuring them out.

Now, what we really need is mouse support. I haven't seen anything that accomodates this yet.
Any ideas?
An apple USB mouse is recognized, but there's no pointer (not that I really expected one).

It would really bridge the gap between Z and a laptop.

It looks like it might be possible with X/Qt, or perhaps OZ GPE(?).
http://www.oesf.org/forums/inde...?showtopic=6306

I'm using Sharp ROM (stock)
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
saakmotu
post Jan 13 2005, 11:15 AM
Post #2





Group: Members
Posts: 73
Joined: 29-September 04
From: Brooklyn, NY
Member No.: 4,802



ok.. not so difficult for basic operation

I installed all 3 ipkgs, but I suppose that KeyHelperConf could be optional.

InputHelper "English"
http://yakty.s31.xrea.com/cgi-bin/wiki/lin...HelperApplet#i8

KeyHelper "translated"
http://216.239.37.104/translate_c?hl=en&u=...6lr%3D%26sa%3DG

KeyHelperConf "translated"
http://216.239.37.104/translate_c?hl=en&u=.../keyhelperconf/

I haven't been able to successfully do anything with KeyHelper yet.

Start InputHelper (from the konsole as root) with the following command:
CODE
qcop QPE/InputHelper 'handle()'


Once it's running, I was able to hotplug my usb mouse with no further mods.

I don't like having the spacebar be the "mouse click" for a couple of reasons.
1) Keyboard drawer must be open to get to the spacebar
2) When typing with the applet activated, the spacebar "clicks". To insert a space, you have to use the action button (or whatever it's called.. the button in the middle of the directional pad).

I haven't figured out how to make it use the action button instead... doesn't that make more sense?

Disable/Enable the pointer/clicking with
CODE
khctl disable|enable


or just khctl for a list of options
again as root...

it would probably be helpful to have a taskbar icon to turn it on/off... but I don't know how to do that, yet.
or, if we could figure out how to change the click from the spacebar to the action button, there would be a reduced need to repeatedly disable/enable the pointer.
Go to the top of the page
 
+Quote Post
saakmotu
post Jan 17 2005, 10:59 AM
Post #3





Group: Members
Posts: 73
Joined: 29-September 04
From: Brooklyn, NY
Member No.: 4,802



Solution for starting/stopping the InputHelper pointer.


as root

create a new file in /home/QtPalmtop/bin called "inputhelper" and chmod it 755
inputhelper
CODE
#!/bin/sh
qcop QPE/InputHelper 'handle()'



create a new file in /home/QtPalmtop/apps/Applications called "inputhelper.desktop"
inputhelper.desktop
CODE
[Desktop Entry]
CanFastload = 1
Comment = Enable/Disable Mouse Pointer
Exec = inputhelper
Icon = A_key5
Name = InputHelper
Type = Application
HidePrivilege = 1
Display=640x480/144dpi,480x640/144dpi


restart, I think...

This will give you an "InputHelper" icon in the "Applications" tab that you can click on to start/stop the mouse pointer.
Also, click and hold on that new icon and uncheck the "magnified screen" box.

Since I don't like having the "Record" button start up the voice recorder, I used "Settings/Application Key" to launch "InputHelper". It's a little slow since you have to hold down the Record button for a couple of seconds before it launches... you could use any other button of your choice, like the one with the little dot right above "Cancel", but I like to have that one mapped to "tab".

The pointer starts/stops quickly, but it sorta hangs with the little hourglass in the taskbar, which prevents you from rapidly starting/stopping the pointer in succession. Not sure why, it doesn't do that if you enter the same command from the konsole. Any ideas on how to speed this up?

Also, the documentation states that you can use either of these commands for InputHelper
qcop QPE/InputHelper 'handle()'
qcop QPE/InputHelper 'handle(int)'
where the 2nd option allows you to enter a number which will specify the number of clicks before the pointer will automatically stop, but I can't get it to work. Anyone?

Still haven't figured out how to use the dir. pad button instead of the space bar. sad.gif
Go to the top of the page
 
+Quote Post

Posts in this topic
saakmotu   USB Mouse?   Nov 18 2004, 11:10 AM
cwaig   What you need is Yakty's InputHelper applet - ...   Nov 21 2004, 11:23 AM
data   Can joystick work w/ USB host?   Nov 22 2004, 07:09 PM
neuroshock   cwaig, I am programming illiterate. Please let me...   Nov 22 2004, 10:48 PM
saakmotu   QUOTE(cwaig @ Nov 21 2004, 07:23 PM)Or you ca...   Nov 29 2004, 11:20 AM
cwaig   QUOTE(saakmotu @ Nov 29 2004, 11:20 AM)man, t...   Nov 29 2004, 12:48 PM
saakmotu   QUOTE(cwaig @ Nov 21 2004, 07:23 PM)What you ...   Dec 16 2004, 01:18 PM
saakmotu   Alright, Cwaig... Santa has come and gone.. hopef...   Dec 28 2004, 07:20 AM
cwaig   QUOTE(saakmotu @ Dec 28 2004, 07:20 AM)Alrigh...   Dec 28 2004, 04:29 PM
the_oak   Hey Cwaig, I have no programming skills, but wou...   Dec 29 2004, 05:40 AM
saakmotu   While waiting patiently for cwaig to receive the_o...   Dec 29 2004, 08:13 PM
cosmos7   You'll notice that if you boot the Z with a US...   Dec 30 2004, 11:39 AM
cwaig   Well, I got my SL6000 for Christmas, and Hubcapboy...   Jan 5 2005, 09:57 AM
nilch   Cwaig - you are the king of making all sorts of in...   Jan 5 2005, 11:06 AM
soundwave106   Most PC USB mice that I know of use the PS/2 proto...   Jan 5 2005, 04:32 PM
cwaig   Not had a lot of time to spend on this yet (grrr),...   Jan 7 2005, 02:00 AM
cwaig   Just to follow up my own post here, I've just ...   Jan 7 2005, 05:39 AM
saakmotu   Works for me using a Microsoft Intellimouse Optica...   Jan 7 2005, 09:03 AM
soundwave106   It also worked with a Targus Ultra-Mini Retractabl...   Jan 7 2005, 04:05 PM
nilch   works fine with my Logitech USB mouse (with scroll...   Jan 7 2005, 08:26 PM
cwaig   I've just been out and picked up a little chea...   Jan 8 2005, 09:07 AM
BarryW   Works with the Apple usb keyboard and mouse! ...   Jan 9 2005, 11:27 PM
cwaig   I've updated the USB mouse applet to support t...   Jan 10 2005, 04:21 AM
hubcapboy   Hey craig!!! so cool to see you were ...   Jan 10 2005, 07:43 PM
saakmotu   updated version works great and the ability to cha...   Jan 10 2005, 10:01 PM
hubcapboy   craig you're amazing. this is perfect. peopl...   Jan 10 2005, 10:09 PM
cwaig   QUOTE(saakmotu @ Jan 10 2005, 10:01 PM)At the...   Jan 11 2005, 01:07 AM
Antikx   Thanks for your hard work cwaig. I don't own ...   Jan 11 2005, 07:47 AM
BarryW   I don't see why not. I plugged in my apple ke...   Jan 11 2005, 08:28 AM
hubcapboy   hey craig, just taking a lok at your keyboard setu...   Jan 11 2005, 04:03 PM
vputz   Soundwave, I have to ask--wot the devil is that cr...   Jan 11 2005, 05:48 PM
saakmotu   QUOTE(cwaig @ Jan 11 2005, 09:07 AM)Only prob...   Jan 12 2005, 06:52 AM
soundwave106   Heh -- I think you are talking about the mounting ...   Jan 12 2005, 07:58 AM
Joshp   Cool it works. Am useing a microsoft trackball ....   Jan 12 2005, 10:44 AM
aki   I can only see a link to libusbmouseapplet.so.1.0....   Jan 12 2005, 02:51 PM
vputz   > Heh -- I think you are talking about the mou...   Jan 12 2005, 04:56 PM
ashikase   QUOTENOTE: When Yakty releases the new version of ...   Jan 12 2005, 04:59 PM
saakmotu   QUOTE(saakmotu @ Jan 12 2005, 02:52 PM)Is the...   Jan 12 2005, 07:54 PM
saakmotu   ok.. not so difficult for basic operation I insta...   Jan 13 2005, 11:15 AM
saakmotu   Solution for starting/stopping the InputHelper poi...   Jan 17 2005, 10:59 AM
pieman   Hi folks - looks like a grand forum you have here....   Jan 24 2005, 10:27 AM
gtJormungand   QUOTE(pieman @ Jan 24 2005, 06:27 PM)which I ...   Mar 4 2005, 05:04 AM
adf   Back to the 6000 fast kernel thing. It can be done...   Mar 6 2005, 09:54 PM
xjqian   a newbie question. when i connected my usb mouse, ...   Jan 25 2005, 07:05 PM
xjqian   To articulate my problem: * I installed inputhelp...   Jan 26 2005, 10:06 PM
xjqian   I looked up the source in linux-2.4.18-rmk7-pxa3-c...   Jan 28 2005, 05:07 PM
adf   I could use the modules as well... if they are bei...   Feb 2 2005, 09:23 PM
offroadgeek   This is absolutely amazing! I installed the l...   Feb 5 2005, 06:58 PM
nilch   makes me wish I had bought a USB keyboard with a d...   Feb 7 2005, 02:40 PM
adf   On the fasdt kernel issue: I'm working on a ve...   Feb 9 2005, 10:42 AM
mjb   QUOTE(nilch @ Feb 7 2005, 10:40 PM)makes me w...   Feb 9 2005, 06:56 PM
guylhem   usbmouse w/ fast kernel is viable... and in fact i...   Mar 24 2005, 06:55 AM
mitchrl   Extending the scheme where I am autoloading keyhel...   Mar 26 2005, 03:18 AM
rob_figlabs   I don't think an ipk ever got posted here, so ...   Jun 13 2005, 06:17 AM
rjb   Thanks for posting the link. Just tried it with a...   Jul 13 2005, 12:20 PM
poorman   Oh well, USB mice work like a charm. However I fel...   Jul 24 2005, 01:10 PM
smammon   Ok, this officially rocks! Typing away on my ...   Aug 10 2005, 11:53 AM
inode0   Has anyone else noticed # ll /dev/usbmouse lrwxrw...   Aug 10 2005, 07:26 PM
inode0   Just tested the usb mouse fun under Xqt. Perhaps I...   Aug 10 2005, 09:07 PM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th October 2014 - 05:03 AM