OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> C3000 Issues / Solutions, C3000 Issues / Solutions
post Nov 29 2004, 08:26 AM
Post #1

Group: Members
Posts: 9
Joined: 29-November 04
Member No.: 5,653

AlertUSB when trying to connect:

When the message is received on the screen, do not click yes or no. Unplug the USB cable from the unit and then select No from the error message. You should then be able to plug the cable back into the unit and sync. If not, repeat.

Syncing issues:

We recommend using the C860 drivers for the C3000. We have had reports of the C3000 drivers causing syncing issues. This unit will work with the English sync software. Please make sure to select the Mode Setting of PC Link Setting in PC Link.

Can't read/write to my storage card when using the device as a USB Hard Drive:

In PC Link, you need to select the storage card under Mode Settings before plugging in the USB Cable. It defaults to Internal HDD.

Phone numbers lost in Address Book:

This is a known issue. We recommend placing the phone numbers in another area until we find a solution. This is not due to the English conversion.

Fonts are too small:

Dynamism units are shipped in a Japanese<->English hybrid mode (a.k.a zh_TW) to allow the translation software to work. This also retains the Kanji input methods. If you are not using the translation software, you can type the following in Konsole to switch to pure English mode:


The unit will reboot. All Japanese input methods (except for the default keyboard) will be removed.

Typing the command again will restore the unit back into the hybrid mode and replace all input methods.

Please note that this only works with Dynamism units (Although it is just a simple script).

I need an NAND backup file:

Please email c700support@dynamism.com if you would like to host a restore file. (16MB or 10.5MB Zipped)

I am trying to install an Opie package but ipkg-new isn't working:

ipkg-new installs in /home/root/usr/local/bin and is not in the path. Due to Sharp's partitioning of the internal hard drive, some paths will need to be added to the .profile or the files linked to /usr/local/bin. Alternately, you can run /home/root/usr/local/bin/ipkg-new isntall <package_name>.

System will not boot past Sharp boot screen:

First solution (Will erase all data):
1) Remove the battery cover and press the reset switch.
2) Replace the battery cover.
3) Hold the OK button and power on the unit.
4) Plug in the unit.
5) Select the third option in the menu.
6) Select the first option in the second menu.
7) Wait (May take longer then 5 minutes).
System will then boot in Japanese. Dynamism customers should email c700support@dynamism.com to obtain further instructions for their units.

Second Solution (Will not erase data, but not for a novice):
Dynamism units are shipped with Telnet enabled. If the unit was last set to Sync in PC Link Setting, you may be able to still connect the unit to your PC and connect. You will need a Telnet application (we recommend Putty). You can telnet to the unit at ip and login as zaurus. You can then use the Telnet session to correct the issue.

NOTE: Please note that only Dynamism customers should use the c700support@dynamism.com email for support issues.

DISCLAIMER: Dynamism only warranty’s units purchased from Dynamism. All other users performing actions, suggested in these forums, performs the actions at their own risk and at no fault of Dynamism.
Go to the top of the page
+Quote Post
Start new topic
post Nov 29 2004, 03:30 PM
Post #2

Group: Members
Posts: 2
Joined: 29-November 04
Member No.: 5,669

Hi all,

I bought a SL-C3000 few weeks ago, and it seems that my Hard Drive has a problem.
During the boot process, just right above the red SHARP Logo, I get a small message :
"HDD1 Error!!"
Then the Zaurus SL-C3000 hangs, and I get nothing more.

After a small analysis of the Hard Drive, thanks to a special mode of the M+D Boot process (services 3/3 -> Extra Menu -> HDD Diag Menu, page 2/2 -> HDD File Backup), I discovered that my hard drive had lost the partitions.

By using fdisk, I was then able to reconstruct the partitions tables. Some friends gave me images of hda1 hda2 hda3 (and full hdd also) thanks to the "dd" command. I've tried to recover the HD, but I still get a "HDD1 Error!!" message during the boot process.

According to you, what should I try, is it something known ? By using google, it seems that there is not so much people with this message ; and even if I cannot really read japanese, I've not been able to find valuable help on the Net.

Is there an easy way to recover the Hard Drive of a Zaurus SL-C3000 ? Should I recover the NAND too ? ...

Thanks for your help,

Attached thumbnail(s)
Attached Image
Go to the top of the page
+Quote Post

Posts in this topic
Zaurus_Support   C3000 Issues / Solutions   Nov 29 2004, 08:26 AM
Zaurus_Support   I will continue to add as questions come in.   Nov 29 2004, 03:03 PM
laurent   Hi all, I bought a SL-C3000 few weeks ago, and it...   Nov 29 2004, 03:30 PM
Zaurus_Support   There is a backup for the hard drive in the diagno...   Nov 29 2004, 05:09 PM
danboid   QUOTE(Zaurus_Support @ Nov 30 2004, 01:09 AM)...   Aug 18 2006, 06:44 AM
Zaurus_Support   I stand corrected. The hd backup mode only drops ...   Nov 29 2004, 05:54 PM
laurent   Hi, I've used the +OK Boot mode (didn't k...   Nov 30 2004, 10:37 AM
Zaurus_Support   Glad I could help. I think you are going to love ...   Nov 30 2004, 11:44 AM
Zaurus_Support   UPDATE: Disclaimer added.   Nov 30 2004, 05:32 PM
Zaurus_Support   UPDATE: Added System will not boot past Sharp boot...   Nov 30 2004, 10:01 PM
ThC   I was just wondering : is it possible to do a full...   Dec 24 2004, 03:27 PM
pelon   I've created a HOWTO on restoring a C3000 from...   Dec 29 2004, 11:08 AM
iamasmith   QUOTE(pelon @ Dec 29 2004, 07:08 PM)I've ...   Feb 14 2005, 09:29 AM
Wareazy   QUOTE(pelon @ Dec 29 2004, 03:08 PM)I've ...   May 22 2005, 09:39 PM
AndyTiedye   QUOTE(Wareazy @ May 22 2005, 10:39 PM)QUOTE(p...   May 24 2005, 12:01 AM
pelon   QUOTE(Wareazy @ May 22 2005, 10:39 PM)QUOTE(p...   May 24 2005, 04:49 PM
usunoro   QUOTEYes, The instructions state that you should p...   Jul 20 2005, 10:57 AM
Mersault   QUOTE(pelon @ Dec 29 2004, 09:08 PM)I've ...   Jan 2 2006, 01:53 PM
Mieszko   QUOTE(pelon @ Dec 29 2004, 09:08 PM)I've ...   May 20 2006, 08:22 AM
lowen   QUOTE(Mieszko @ May 20 2006, 12:22 PM)QUOTE(p...   Jun 5 2006, 08:12 PM
maystorm   QUOTEUse the WayBack Machine at Archive.org: http:...   Jul 14 2006, 02:09 AM
Meanie   QUOTE(maystorm @ Jul 14 2006, 08:09 PM)QUOTEU...   Jul 14 2006, 06:25 AM
donaldfr   Fonts are too small: Dynamism units . . . If you ...   Jan 10 2005, 02:49 PM
Zaurus_Support   QUOTE(donaldfr @ Jan 10 2005, 10:49 PM)Fonts ...   Jan 11 2005, 09:22 AM
donaldfr   can't figure out where to put my data files on...   Jan 19 2005, 03:30 PM
devster   QUOTEFirst solution (Will erase all data): 1) Remo...   Jan 30 2005, 12:55 AM
Charlovski   QUOTE(devster @ Jan 30 2005, 10:55 AM)Trying ...   Jan 30 2005, 01:53 AM
devster   QUOTE(Charlovski @ Jan 30 2005, 09:53 AM)QUOT...   Jan 31 2005, 03:36 AM
Charlovski   QUOTE(devster @ Jan 31 2005, 01:36 PM)its jus...   Jan 31 2005, 03:52 AM
devster   ahem... I wont answer on the grounds I may incrimi...   Jan 31 2005, 05:47 AM
bear426   Syncing issues: We recommend using the C860 drive...   May 13 2005, 03:56 PM
TRIsoft   QUOTE(bear426 @ May 14 2005, 12:56 AM)Syncing...   May 14 2005, 04:05 AM
bear426   The drivers don't remain in device manager and...   May 14 2005, 05:20 PM
TRIsoft   Jennifer, we tested the procedure with WinXP (SP2)...   May 15 2005, 02:27 AM
bear426   QUOTE(TRIsoft @ May 15 2005, 03:27 AM)Jennife...   May 15 2005, 10:32 AM
johnwong   " I've created a HOWTO on restoring a C30...   Jun 29 2005, 09:58 PM
cre8nlove   hi, I'm in japan looking at the 3200 (6 gig hd...   Mar 18 2006, 04:43 PM
Meanie   QUOTE(cre8nlove @ Mar 19 2006, 10:43 AM)hi, I...   Mar 18 2006, 06:00 PM
rokugo   QUOTE(cre8nlove @ Mar 19 2006, 08:43 AM)hi, I...   Mar 18 2006, 08:00 PM
cloneofsnake   Hi, I've been doing research on here & the...   Jun 2 2006, 01:53 PM
xamindar   There is no password by default unless you set up ...   Jun 2 2006, 02:08 PM
Jon_J   I zipped up the html page along with the address, ...   Jul 14 2006, 06:56 AM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 21st June 2018 - 07:39 PM