OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Sync sl5500 OpenZaurus 3.3.5 and QtopiaDesktop 1.7
diesel1
post Jan 4 2004, 09:59 AM
Post #1





Group: Members
Posts: 94
Joined: 10-December 03
From: Leeds, West Yorkshire.
Member No.: 759



After following lots of instructions to sync my Z with QtopiaDesktop I finally got it working.

My Z is running OpenZaurus 3.3.5.
I have set up a usb connection with my Mandrake 9.2 box and turned on IP forwarding as described in many howtos. I installed QtopiaDesktop 1.7 from the Redhat rpm.

I started QDesktop but the sync menu was unavailable. I had the Z in the cradle and connected to the Mandrake box.

I opend Settings/Security and then the Sync tab.
The setting appeared correct at 192.168.129.0/24 but I tried the 'Any' setting.

On closing the Security app the Z asked me whether to accept the Sync request from my Mandrake box.

I said yes and have had sync ever since!

Hope this helps someone.

Diesel1.
Go to the top of the page
 
+Quote Post
post Jan 6 2004, 05:10 AM
Post #2





Group:
Posts: 0
Joined: --
Member No.: 0



thx. yep it helped.
Go to the top of the page
 
+Quote Post
post Jan 16 2004, 06:07 PM
Post #3





Group:
Posts: 0
Joined: --
Member No.: 0



Deisel1, you da man!
--Jonathan 8)
Go to the top of the page
 
+Quote Post
Alvis
post Jan 16 2004, 09:55 PM
Post #4





Group: Members
Posts: 13
Joined: 31-December 03
Member No.: 1,325



I think I've got the usb connection turned on per the how-to for Mandrake. Could someone please forward me to a how-to on IP forwarding?
Go to the top of the page
 
+Quote Post
post Jan 17 2004, 05:25 AM
Post #5





Group:
Posts: 0
Joined: --
Member No.: 0



This is a script to turn on IP forwarding, you need iptables installed.
The script is saved as ZConnect.sh and made executable.

ifconfig usb0 192.168.129.1 netmask 255.255.255.255 up
route add -host 192.168.129.201 usb0
iptables -t nat -F
iptables -t nat -A POSTROUTING -j SNAT -o eth0 --to 10.0.0.1
echo 1 > /proc/sys/net/ipv4/ip_forward

Diesel1.

SL5500+OZ3.3.6-pre1+DLinkCFwireless
Go to the top of the page
 
+Quote Post
post Jan 17 2004, 05:29 AM
Post #6





Group:
Posts: 0
Joined: --
Member No.: 0



By the way, 192.168.129.1 is you usb connection to your linux box, 10.0.0.1 is your network connection to the inter/intranet.
I now coonect my Z to a wireless access point on my network rather then through the linux box.

Diesel1.
Go to the top of the page
 
+Quote Post
post Jan 17 2004, 05:33 AM
Post #7





Group:
Posts: 0
Joined: --
Member No.: 0



PS..... again.
You will need to be root/su to run the script.

Diesel1
Go to the top of the page
 
+Quote Post
Alvis
post Jan 17 2004, 06:53 AM
Post #8





Group: Members
Posts: 13
Joined: 31-December 03
Member No.: 1,325



QUOTE
By the way, 192.168.129.1 is you usb connection to your linux box, 10.0.0.1 is your network connection to the inter/intranet.
I now coonect my Z to a wireless access point on my network rather then through the linux box.

Diesel1.


I have a wifi card,also, so I assume I would need to change the script accordingly?

By the way, thanks for all your help.
Go to the top of the page
 
+Quote Post
diesel1
post Jan 17 2004, 02:39 PM
Post #9





Group: Members
Posts: 94
Joined: 10-December 03
From: Leeds, West Yorkshire.
Member No.: 759



If you are connecting to the linux box with wifi then replace usb0 with your wifi network interface and IP address.
If you are not connected to the inter/intranet through an ethernet network card (eth0 if it is the first network card) replace eth0 and the 10.0.0.1 with the correct values.

Diesel1.
Go to the top of the page
 
+Quote Post
Alvis
post Jan 18 2004, 05:28 PM
Post #10





Group: Members
Posts: 13
Joined: 31-December 03
Member No.: 1,325



Diesel1, could you please e-mail me? I think I need just a little more help getting my script written and my Zaurus synced. My e-mail addy is in my profie.

Thanks,

Alvis
Go to the top of the page
 
+Quote Post
Alvis
post Jan 18 2004, 08:39 PM
Post #11





Group: Members
Posts: 13
Joined: 31-December 03
Member No.: 1,325



Nevermind, got it. smile.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th October 2014 - 03:03 PM