OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

6 Pages V  « < 3 4 5 6 >  
Reply to this topicStart new topic
> Hardware problems with pdaXrom..
Dima202
post Dec 3 2005, 07:54 PM
Post #61





Group: Members
Posts: 68
Joined: 6-November 05
Member No.: 8,479



QUOTE(ajnk @ Nov 23 2005, 02:19 AM)
I have just bought a Belkin F8T020 Bluetooth card, I saw reports of it working on OZ, so presumed it would work on pdaxrom.  I did see an earlier post about this card, but no solution.

# cardctl ident
Socket 0:
  product info: "CF CARD", "GENERIC", "", ""
  manfid: 0x0279, 0x950b
  function: 2 (serial)
Socket 1:
  no product info available

# cardctl info
PRODID_1="CF CARD"
PRODID_2="GENERIC"
PRODID_3=""
PRODID_4=""
MANFID=0279,950b
FUNCID=2
PRODID_1=""
PRODID_2=""
PRODID_3=""
PRODID_4=""
MANFID=0000,0000
FUNCID=255

I added an entry to to /etc/pcmcia/config


card "Belkin F8T020 Bluetooth Adapter"
  manfid 0x0279, 0x950b
  bind "serial_cs"

but the card is still seen as GENERIC, I also added the same entry to /etc/pcmcia/bluetooth.conf

and finally :-

# cat /var/lib/pcmcia/stab
Socket 0: Belkin F8T020 Bluetooth Adapter
0      serial  serial_cs      0      ttyS3  4      67
Socket 1: empty

Can anyone out there help ?

I have a C860 running RC12 BTW.
*

Hey I have the same card and the same Z.
Did you by any chance get it to work?
If so please post how. So everyone with this or similiar problem could fix it too.

Thanks smile.gif
Go to the top of the page
 
+Quote Post
Alfinfrance
post Dec 30 2005, 02:14 PM
Post #62





Group: Members
Posts: 18
Joined: 24-October 05
Member No.: 8,389



Hi,

I tried my Holux GPS GM-270 CF card on my SL C3100 running pdaxrom v1.1.0beta1 and... strange thing : it isn't recognized as a GPS card but as "Compaq iPAQ Bluetooth Sleeve"

#cardctl ident
Socket 0:
product info: "CF CARD", "GENERIC", "", ""
manfid: 0x0279, 0x950b
function: 2 (serial)

But it works perfect on my 5500 running Sharp Rom v3.13 ( and also with 3.10 )

Any idea?

Thanks
Go to the top of the page
 
+Quote Post
cmpayc13
post Jan 3 2006, 03:05 AM
Post #63





Group: Members
Posts: 18
Joined: 28-December 05
Member No.: 8,803



Hi,

is there any way to get Linksys WCF54G working with PDAXROM?

any idea?

best regards

cmpayc
Go to the top of the page
 
+Quote Post
anunakin
post Jan 12 2006, 05:21 AM
Post #64





Group: Members
Posts: 340
Joined: 22-August 04
From: Belem, Brasil
Member No.: 4,358



I need some help to put to work my CFVGA adapter, a voyager this has a cirrus logic chipset....
Go to the top of the page
 
+Quote Post
john4
post Jan 12 2006, 07:56 PM
Post #65





Group: Members
Posts: 41
Joined: 9-June 05
Member No.: 7,305



A problem confuse me form R10~Beta 1.My Z is SL-7500C.
My Z cannt be charged by AC/DC adapter,but the orange light is always lighte.
And the machine will use the power from the plugin power,instead of the battery.It means the AC/DC adapter work for the Z.

I wanna know what happen,If there any solution about this.
Or is it something about the hardware inside?
Go to the top of the page
 
+Quote Post
Tom'caT
post Feb 7 2006, 08:55 AM
Post #66





Group: Members
Posts: 1
Joined: 3-February 06
Member No.: 9,070



QUOTE(sigmaX @ Dec 28 2004, 06:08 PM)
CARD: Ambicom CF Bluetooth model BT2000CF

cardctl ident:

Socket 0:
  product info: "AmbiCom BT2000C", "Bluetooth PC/CF Card", "", ""
  manfid: 0x0279, 0x950b
  function: 2 (serial)
Socket 1:
  no product info available

cardctl info:

PRODID_1="AmbiCom BT2000C"
PRODID_2="Bluetooth PC/CF Card"
PRODID_3=""
PRODID_4...=""
MANFID=022d,2000
FUNCID=2
PRODID_1=""
PRODID_2=""
PRODID_3=""
PRODID_4=""
MANFID=0000,0000
FUNCID=255
*

Ok, I have a different problem with that card.
Zaurus SL-C700, PdaXrom 1.1.0beta1. When booting kernel I get this message:"cs: socket c0386800 timed out during reset. Try increasing setup_delay."
and few lines later corgi_bl : change limit contrast 3
corgi_bl : unlimit contrast

'cardctl info 0' gives following output:
PRODID_1="CF CARD"
PRODID_2="GENERIC"
PRODID_3=""
PRODID_4...=""
MANFID=0279,950b
FUNCID=2

'cardctl ident 0' gives this:

Socket 0:
product info: "CF CARD", "GENERIC", "", ""
manfid: 0x0279, 0x950b
function: 2 (serial)

'cardctl status 0' gives
3.3V 16-bit PC Card
function 0: [ready], [bat dead], [bat low].

'hciconfig' doesn't give any output.

I don't know what to do. Is it possible that CF card has a hardware malfunction or is this just a kernel error. Should I recompile the kernel or what?
I really tried everything I could think of.
Oh yes it's a 'yellow-black' revision (the newer one).
Go to the top of the page
 
+Quote Post
cycle_55
post Feb 17 2006, 07:11 AM
Post #67





Group: Members
Posts: 135
Joined: 15-February 06
From: Gabriola Island, BC, Canada
Member No.: 9,143



QUOTE(Laze @ Dec 28 2004, 06:43 AM)
Do you have a piece of hardware thats not working under pdaXrom like a CF network card, USB controller etc?

Please post your cardctl ident and cardctl status and all other info you can find about the card (links to drivers etc.) - then we will try and fix them one at a time and try and make sure that pdaXrom supports as many accessories as possible.

We will probally be holding an IRC meeting with all user who are having problems with hardware but this is meant to be a warm up to see how many problems there are and how much time it will take to fix them.
*


I have a wireless cf card that's not recognized. It is a Planex GW-CF11X. I will have to figure out what other information to send you. I was originally going to just buy another recognized card but have not found a list of supported hardware. I like you site and will use it alot and will be donating to your cause soon. Thanks.
Go to the top of the page
 
+Quote Post
cycle_55
post Feb 24 2006, 03:04 PM
Post #68





Group: Members
Posts: 135
Joined: 15-February 06
From: Gabriola Island, BC, Canada
Member No.: 9,143



QUOTE(cycle_55 @ Feb 17 2006, 07:11 AM)
QUOTE(Laze @ Dec 28 2004, 06:43 AM)
Do you have a piece of hardware thats not working under pdaXrom like a CF network card, USB controller etc?

Please post your cardctl ident and cardctl status and all other info you can find about the card (links to drivers etc.) - then we will try and fix them one at a time and try and make sure that pdaXrom supports as many accessories as possible.

We will probally be holding an IRC meeting with all user who are having problems with hardware but this is meant to be a warm up to see how many problems there are and how much time it will take to fix them.
*


I have a wireless cf card that's not recognized. It is a Planex GW-CF11X. I will have to figure out what other information to send you. I was originally going to just buy another recognized card but have not found a list of supported hardware. I like you site and will use it alot and will be donating to your cause soon. Thanks.
*



The following is what I get:

cardctl ident

product info: "PLANEX COMMUNICXATIONS INC.", PLANEX GW_CF!!X Wireless CF
Card", "", ""
manfid: 0xd601, 0x0010
function: 6 (network)

cardctl status

Socket 0:
3.3V 16-bit PC Card
function 0: [ready]
Socket 1:
3.3V 16-bit PC Card
function 0: [ready], [bat dead], [bat low]

Socket 0 doesnt show up if the planex card is not in its slot. Thanks
Go to the top of the page
 
+Quote Post
dun4n
post Feb 27 2006, 01:30 AM
Post #69





Group: Members
Posts: 2
Joined: 27-February 06
Member No.: 9,239



First, you have to add your card definition to /etc/pcmcia/hostap_cs.conf

Edit this file and add :

CODE
card "PLANEX COMMUNICXATIONS INC."
  manfid 0xd601, 0x0010
  bind "hostap_cs"


It's time to flash your card (credits to gryning).
Download the latest firmware from :
http://www.red-bean.com/~proski/firmware/1.8.4.tar.bz2 (extract rf010804.hex)
http://www.red-bean.com/~proski/firmware/primary.tar.bz2 (extract pm010102.hex)

Then use this script :
CODE
#!/bin/sh
cardctl scheme default
prism2_srec -gs wlan0 <path>/pm010102.hex
prism2_srec -gp wlan0 <path>/pm010102.hex
iwpriv wlan0 reset 1
prism2_srec -rp wlan0 path/rf010804.hex
iwconfig wlan0 mode 2
cardctl scheme planex

Where <path> is the path to the firmware.

Use ifconfig -a and you will see your card interface, now put it up using ifconfig <interface> up and it will works.

If it's doesn't work properly, verify that you have hostap and hostap_cs module loaded (lsmod | grep hostap) and try to plug the card one more time.
Go to the top of the page
 
+Quote Post
cycle_55
post Mar 1 2006, 09:10 PM
Post #70





Group: Members
Posts: 135
Joined: 15-February 06
From: Gabriola Island, BC, Canada
Member No.: 9,143



QUOTE(cycle_55 @ Feb 28 2006, 08:45 AM)
QUOTE(cycle_55 @ Feb 28 2006, 08:42 AM)
QUOTE(dun4n @ Feb 27 2006, 01:30 AM)
First, you have to add your card definition to /etc/pcmcia/hostap_cs.conf

Edit this file and add :

CODE
card "PLANEX COMMUNICXATIONS INC."
  manfid 0xd601, 0x0010
  bind "hostap_cs"


It's time to flash your card (credits to gryning).
Download the latest firmware from :
http://www.red-bean.com/~proski/firmware/1.8.4.tar.bz2 (extract rf010804.hex)
http://www.red-bean.com/~proski/firmware/primary.tar.bz2 (extract pm010102.hex)

Then use this script :
CODE
#!/bin/sh
cardctl scheme default
prism2_srec -gs wlan0 <path>/pm010102.hex
prism2_srec -gp wlan0 <path>/pm010102.hex
iwpriv wlan0 reset 1
prism2_srec -rp wlan0 path/rf010804.hex
iwconfig wlan0 mode 2
cardctl scheme planex

Where <path> is the path to the firmware.

Use ifconfig -a and you will see your card interface, now put it up using ifconfig <interface> up and it will works.

If it's doesn't work properly, verify that you have hostap and hostap_cs module loaded (lsmod | grep hostap) and try to plug the card one more time.
*

*



Thanx, I will try that and let you know how things go. It may take a bit for me to get there as I'm not all that fluent in linux but I eventually always manage to. Thanks again
*

Please bear with me, I need to ask if the above script is put into a certain file such as /etc/pcmcia/wireless or network or?. Thanks.

I just realized I haven't said what hardware I have: C3100 with 1.1.0beta1
Go to the top of the page
 
+Quote Post
dun4n
post Mar 8 2006, 06:40 AM
Post #71





Group: Members
Posts: 2
Joined: 27-February 06
Member No.: 9,239



QUOTE
Please bear with me, I need to ask if the above script is put into a certain file such as /etc/pcmcia/wireless or network or?. Thanks.


Actually this script has to be run manually. But you can modify it to act as an init.d script and / or create an hotplug / hostap config to made it run when you plug your wifi card.
Go to the top of the page
 
+Quote Post
cycle_55
post Mar 8 2006, 08:05 AM
Post #72





Group: Members
Posts: 135
Joined: 15-February 06
From: Gabriola Island, BC, Canada
Member No.: 9,143



QUOTE(dun4n @ Mar 8 2006, 06:40 AM)
QUOTE
Please bear with me, I need to ask if the above script is put into a certain file such as /etc/pcmcia/wireless or network or?. Thanks.


Actually this script has to be run manually. But you can modify it to act as an init.d script and / or create an hotplug / hostap config to made it run when you plug your wifi card.
*



That is what I have been doing and even though Wlan0 is detected when I plug the card in I can not seem to be able to get it to go on line. After I run the script the light goes on but it will not send just receive. When I go to the lan/wifi icon and try to input my info the light goes out and I can't get it to go on again without rerunning the script and the same things happen all over again. It may be time to buy another card. Maybe I could donate this one to the cause. The problem with buying another one is that they're not that easy to find and which one would be better than what I've got. I have read some other posts and think I have some ideas. Thanks for all your help.

Well I thought I would give it one more try and I finally managed to get it to work. What I was doing wrong was that I had not saved a scheme in the lan/wifi setup, once I did that it worked as soon as the script is run. Thanks again for all your help.
Go to the top of the page
 
+Quote Post
Reaper
post Mar 12 2006, 07:45 AM
Post #73





Group: Members
Posts: 126
Joined: 13-December 03
Member No.: 1,174



QUOTE(anunakin @ Jan 12 2006, 05:21 AM)
I need some help to put to work my CFVGA adapter, a voyager this has a cirrus logic chipset....
*


I also have CF VGA adapter, but mine is Pretec PocketPresenter with Epson S1D13806F00A1 chipset. I would like very much to get it working with pdaX, because it works with Cacko (not without a trick - I had to run "cfxgamirror 1" instead of "cfxgamirror 0" by default).
Go to the top of the page
 
+Quote Post
erbrmn
post Apr 5 2006, 10:45 PM
Post #74





Group: Members
Posts: 1
Joined: 5-April 06
Member No.: 9,547



QUOTE(dun4n @ Feb 27 2006, 01:30 AM)
First, you have to add your card definition to /etc/pcmcia/hostap_cs.conf
Edit this file and add :
CODE
card "PLANEX COMMUNICXATIONS INC."
  manfid 0xd601, 0x0010
  bind "hostap_cs"


It's time to flash your card (credits to gryning).
Download the latest firmware from :
http://www.red-bean.com/~proski/firmware/1.8.4.tar.bz2 (extract rf010804.hex)
http://www.red-bean.com/~proski/firmware/primary.tar.bz2 (extract pm010102.hex)

Then use this script :
CODE
#!/bin/sh
cardctl scheme default
prism2_srec -gs wlan0 <path>/pm010102.hex
prism2_srec -gp wlan0 <path>/pm010102.hex
iwpriv wlan0 reset 1
prism2_srec -rp wlan0 path/rf010804.hex
iwconfig wlan0 mode 2
cardctl scheme planex

Where <path> is the path to the firmware.

Use ifconfig -a and you will see your card interface, now put it up using ifconfig <interface> up and it will works.

If it's doesn't work properly, verify that you have hostap and hostap_cs module loaded (lsmod | grep hostap) and try to plug the card one more time.
*


I have Planex wireless card and i have problem that it could not detect on RHEL4.
I tried this tip, and It worked, it was brilliant
But, after restart system or reinsert card, I could not find wireless card.
Now , how can I download new firmware into flash of card. I want to use "-f" parametr.
But, I tried several time, there was some error .
I only changed "g" to "f" on script.





Please advice me, to download firmware into flash of card.
Go to the top of the page
 
+Quote Post
cycle_55
post Apr 6 2006, 06:32 AM
Post #75





Group: Members
Posts: 135
Joined: 15-February 06
From: Gabriola Island, BC, Canada
Member No.: 9,143



QUOTE(erbrmn @ Apr 5 2006, 10:45 PM)
QUOTE(dun4n @ Feb 27 2006, 01:30 AM)
First, you have to add your card definition to /etc/pcmcia/hostap_cs.conf
Edit this file and add :
CODE
card "PLANEX COMMUNICXATIONS INC."
  manfid 0xd601, 0x0010
  bind "hostap_cs"


It's time to flash your card (credits to gryning).
Download the latest firmware from :
http://www.red-bean.com/~proski/firmware/1.8.4.tar.bz2 (extract rf010804.hex)
http://www.red-bean.com/~proski/firmware/primary.tar.bz2 (extract pm010102.hex)

Then use this script :
CODE
#!/bin/sh
cardctl scheme default
prism2_srec -gs wlan0 <path>/pm010102.hex
prism2_srec -gp wlan0 <path>/pm010102.hex
iwpriv wlan0 reset 1
prism2_srec -rp wlan0 path/rf010804.hex
iwconfig wlan0 mode 2
cardctl scheme planex

Where <path> is the path to the firmware.

Use ifconfig -a and you will see your card interface, now put it up using ifconfig <interface> up and it will works.

If it's doesn't work properly, verify that you have hostap and hostap_cs module loaded (lsmod | grep hostap) and try to plug the card one more time.
*


I have Planex wireless card and i have problem that it could not detect on RHEL4.
I tried this tip, and It worked, it was brilliant
But, after restart system or reinsert card, I could not find wireless card.
Now , how can I download new firmware into flash of card. I want to use "-f" parametr.
But, I tried several time, there was some error .
I only changed "g" to "f" on script.





Please advice me, to download firmware into flash of card.

*



i can only tell you that i highlight and paste this script and run it every time i want to use this card. Beyond that i have no idea how to make this automatic.
Go to the top of the page
 
+Quote Post

6 Pages V  « < 3 4 5 6 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st August 2014 - 10:02 AM