OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> C3000 Usb Host: Auto Mount And Umount Usb Hdd
post Jan 4 2005, 05:21 AM
Post #1

Group: Members
Posts: 44
Joined: 3-January 05
From: Austin, TX
Member No.: 6,104

I tested this with C3000 (ROM 1.01 JP). Use a USB mini-A cable to connect C3000 with your USB mass-storage device.

cd /mnt
mkdir usbhdd

2) Create a file /etc/hotplug/usb/usb-storage as follows. chmod it as 755.
. /etc/hotplug/hotplug.functions
if [ ! -L /var/run/usb/%proc%bus%usb%* ]; then
 mesg Try to Mount
 mount /mnt/usbhdd
 if [ $? = 0 ]; then
   ln -s /etc/hotplug/usb/usb-storage.off $REMOVER
   mesg make REMOVER in $REMOVER

3) Create a file /etc/hotplug/usb/usb-storage.off as follows. chmod it as 755.
. /etc/hotplug/hotplug.functions
mesg Removing /mnt/usbhdd
umount /mnt/usbhdd
rmmod usb-storage

4) Add the following one line to /etc/fstab
/dev/sda1       /mnt/usbhdd     vfat    noauto,umask=000,noatime,iocharset=utf8,codepage=932    0  0

5) Connect your USB mass-storage device, you should be able to see it at /mnt/usbmem in a second you pluged the device. This is also visible from Sharp's qtopia GUI File manager.
Go to the top of the page
+Quote Post
Start new topic
post Jan 15 2005, 04:51 PM
Post #2

Group: Members
Posts: 44
Joined: 3-January 05
From: Austin, TX
Member No.: 6,104


Those scripts above are only for automatic mount/umount. Device driver should be loaded automatically without those scripts.
So, when you plug in your iPod, try lsmod command to see if usb-storage module is really loaded. If it doesn't show usb-storage, it means iPod is not Linux usb-storage compliant. Sorry, I don't have iPod myself, so don't know the detail.

If you can see usb-storage, then try the below to see what it shows. Note that Linux treats USB mass storage as SCSI device.
# fdisk -l /dev/sda

If you can see the disk, then you may be able to manually mount it.
mount -t vfat -o umask=000,noatime,iocharset=utf8,codepage=932 /dev/sda1 /mnt/usbhdd
Go to the top of the page
+Quote Post

Posts in this topic
DreamTheater   C3000 Usb Host: Auto Mount And Umount Usb Hdd   Jan 4 2005, 05:21 AM
orange   hi DreamTheater thx for your instructions but i c...   Jan 4 2005, 08:48 AM
DreamTheater   Oops sorry. just corrected.   Jan 4 2005, 09:12 AM
orange   had a typo in one of the files it now works great...   Jan 6 2005, 04:52 PM
pierro78   sorry if I am a little off topic but can the C3000...   Jan 6 2005, 07:01 PM
DreamTheater   I once tried my friend's 2.5inch bus-power typ...   Jan 8 2005, 12:03 AM
spartan   I followed the scripts as-written. However, they d...   Jan 15 2005, 09:53 AM
tcv   What have you tried to mount an iPod? Does this o...   Jan 15 2005, 03:35 PM
DreamTheater   spartan, Those scripts above are only for automat...   Jan 15 2005, 04:51 PM
spartan   Thanks a lot for the help and links. Evidently, th...   Jan 16 2005, 10:55 AM
daXd   I have two following problems with mounting SL-C30...   Jan 20 2005, 09:22 AM
papercrane   Thanks much, DreamTheater, works like a charm. Now...   Feb 7 2005, 11:02 AM
papercrane   Hmmm, one caveat, though. The Music player won...   Feb 9 2005, 10:18 AM
papercrane   Quick update, symlinking the USB HD mount point to...   Feb 16 2005, 01:26 PM
benplaut   sorry to sound like such a n00b here (i'm used...   Jun 13 2005, 08:12 PM
bam   cant seem to get it to automount....I followed wor...   Jul 20 2005, 10:29 PM
Meanie   QUOTE(bam @ Jul 21 2005, 04:29 PM)cant seem t...   Jul 20 2005, 11:14 PM
bam   QUOTE(Meanie @ Jul 20 2005, 11:14 PM)QUOTE(ba...   Jul 20 2005, 11:38 PM
Meanie   QUOTE(bam @ Jul 21 2005, 05:38 PM)QUOTE(Meani...   Jul 22 2005, 10:45 PM
Cagilaba   I just got a 4GB Sitecom Mini Memory Drive (MD-202...   Oct 10 2005, 01:17 PM
Mac   Hi Meanie, I installed your app automounter-c30...   Oct 13 2005, 07:09 AM
bkudria   I am unfortunately having the same problem on my 3...   Oct 15 2005, 09:43 AM
bkudria   I emailed Meanie, and he recommends installing the...   Oct 21 2005, 04:27 PM
Mac   I installed the 0.4.2 ipk, and for my C3000 the si...   Oct 22 2005, 12:44 AM
glennfoster   Does this page help? Cant Mount iPod Error G   Feb 21 2006, 02:37 AM
Mac   Nice try Glennfoster, but your link has nothing to...   Feb 21 2006, 10:42 AM
glennfoster   QUOTE(Mac @ Feb 21 2006, 10:42 AM)Nice try Gl...   Mar 4 2006, 06:34 AM
Mac   this is solved for me by installing the automounte...   Feb 24 2006, 04:14 AM
Mac   if you read the thread you'll notice that it h...   Mar 4 2006, 08:42 AM
mikew   Can anyone tell me how I gain access to a storage ...   Apr 27 2006, 06:54 AM
kurochka   Meanie, Your site indicates that there is a 0.50 ...   Nov 8 2006, 06:54 PM

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 19th June 2018 - 02:22 PM