OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> X/qt-2 On Opie, Has anyone been able to compile it?
hatchetman
post Jan 5 2005, 09:20 PM
Post #1





Group: Members
Posts: 60
Joined: 3-November 04
Member No.: 5,332



Has anyone run the latest X/Qt on the Opie/OZ ROM? The X/Qt server that can be built through OE runs okay, but it's version 0.9 and trying to get fonts to work correctly is a nightmare. I can run the latest X/Qt server using the compat libs, but it won't detect the Qt server and so needs to be started as a server itself. That just leaves me with a flickering opie and an X server that doesn't accept any input.

I've tried to compile X/Qt-2 myself, but I can't get by the ./build DevWorld step. Has anyone compiled this successfully (for anything, not specifically Opie), and can maybe outline a few steps needed to get started?
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
adf
post Jan 11 2005, 08:10 AM
Post #2





Group: Members
Posts: 2,821
Joined: 13-September 04
From: Wasilla Ak.
Member No.: 4,572



At the moment I'm playing with sharprom and gulhelm's softloat kernel/libsdl
But my usual thing has been opie/Xqt2 from the feed-testing feed using compat on my 6000

I haven't explicitly tested it, but I don't remeber any crashing when I used the virtual keyboard.

However, since you mention it, I was checking out gpe the other day. noticed I had no understrike, and used the virtual keyboard for it. Every time I fired up the virtual keyboard, rxvt crashed immediately, though it would work fine if loaded after the vkeyboard. This must be either an oz x thing, or an oz rxvt thing. Were you crashing out of rxvt, and bringing things down that way? If so would it be too much trouble to let us know if the same thing happens in xterm?
adf

btw thanks for the xqt2 for opie... will use as soon as I switch back
have you had any luck running firefox in your config?
Go to the top of the page
 
+Quote Post
enodr
post May 9 2006, 07:02 AM
Post #3





Group: Members
Posts: 133
Joined: 5-April 06
Member No.: 9,537



Working native Xqt2 binary for OZ3.5.4.1RC2 here (no compat lib needed):
http://www.oesf.org/forums/index.php?showtopic=19048&st=15

Espect more enhancements soon.
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd December 2014 - 01:53 AM