OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> X/qt-2 On Opie, Has anyone been able to compile it?
hatchetman
post Jan 5 2005, 09:20 PM
Post #1





Group: Members
Posts: 60
Joined: 3-November 04
Member No.: 5,332



Has anyone run the latest X/Qt on the Opie/OZ ROM? The X/Qt server that can be built through OE runs okay, but it's version 0.9 and trying to get fonts to work correctly is a nightmare. I can run the latest X/Qt server using the compat libs, but it won't detect the Qt server and so needs to be started as a server itself. That just leaves me with a flickering opie and an X server that doesn't accept any input.

I've tried to compile X/Qt-2 myself, but I can't get by the ./build DevWorld step. Has anyone compiled this successfully (for anything, not specifically Opie), and can maybe outline a few steps needed to get started?
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
hatchetman
post Jan 10 2005, 05:41 AM
Post #2





Group: Members
Posts: 60
Joined: 3-November 04
Member No.: 5,332



I fixed my OE issues, and it seems to be compiling pretty clean. No annoying oz-compat dependencies anymore. I've also modified the keymap, so I don't need to use xmodmap anymore.

To anyone that wants to try X/Qt-2 on Opie: If you have a 6000 you are in good shape, if not you'll have to write up a new xmodmap file since the ones on the net now are for JP106 codes. I've attached the KeyMap.h file that I modified so you can take a look at how they are mapped out in the binary. This is JUST the binary, so no startup scripts or xbase apps. I think you need the misc fonts package, I haven't tried it without. Put the fonts anywhere you want and link them to /usr/lib/X11/fonts/misc.

If you already have a working X/Qt going, hopefully it'll just drop into place. This is ONLY for Opie!

Another Note: I've compiled this against some newer packages then are probably in the 3.5.2 feed. I don't know what kind of issues this might cause, but I'd like to know if it works for other people. If it doesn't I can try to compile it against 3.5.2 packages.

Problems I've noticed:
  • No Right Shift
  • No Caps Lock
  • No Num Lock
  • Application (Dot) key is a - and ! sign (useless?)
  • Underscore doesn't work. Also it doesn't seem to be set right in qkeyboard_qws.h for tosa keyboards.
  • X/Qt crashes when you try to use the Opie on-screen keyboard
I think I've read about these problems before and they are caused by Opie or the kernel, and not X/Qt.

Could someone that's using oz-compat and X/Qt let me know if it crashes for them too when used with the onscreen keyboard? I never had a problem on Sharp ROM, like to know if it's my build or the change in environment.

Try'd to upload the package right to the forum but it failed time and time again, so here it is in a gzip'd fashion. Make sure you gunzip before trying to install it.
http://www.geocities.com/hatchetman1618/60...0-r2_arm.ipk.gz

This post has been edited by hatchetman: Jan 10 2005, 05:49 AM
Attached File(s)
Attached File  KeyMap.h.txt ( 8.18K ) Number of downloads: 42
 
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 9th July 2014 - 09:05 PM