OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> New Bluetooth Drivers, For Sharp ROMs using 2.4.18 kernel
post Jan 9 2005, 05:28 PM
Post #1

Group: Members
Posts: 1,176
Joined: 3-October 03
From: UK
Member No.: 547

I've finally got around to updating the Bluetooth BlueZ driver ipk.

This is only for Sharp ROMs and variants of Sharp ROMs, excluding Cacko ROMs, that use the 2.4.18 kernel. So for example this includes Sharp ROMs on SL-5500, SL-5600, SL-6000, SL-C850, but NOT SL-3000.

Here's some of the improvements:
  • Ambicom BT2000C Support. Thanks to tetron for spotting this had been included in the latest drivers. EDIT: Actually it doesn't look like this is working sad.gif
  • Socket Card Rev G Support without requiring the extra bluez-csr-serial ipk. Thanks to maslovsky for sorting this out
  • Hopefully Dlink, Mavin, Billionton, BrainBoxes, and Dell cards should all be supported 'out of the box'
  • Should work 'out of the box' on the SL-6000. (It moves /etc/pcmcia.bm3.conf out of the way on installation and back again on removal) Thanks to DrWowe for spotting what was wrong previously
  • EDIT: Included hci_usb driver would should allow SL-6000L owners to use USB Bluetooth dongles with the appropriate USB cable.
EDIT: The PAN profile should be working now as I resolved a kernel module problem.

Before installing the new ipk, backup your files under /etc/bluetooth and /etc/pcmcia/peers. Then you can easily restore them after installing the new ipk. (You will need to run '/etc/rc.d/init.d/bluetooth restart' after restoring rfcomm.conf and hcid.conf)

Also uninstall all bluez packages before installing this one, including the bluez-csr-serial, which is no longer required with the new package.

So here is the new ipk (Note: the 1st, 3rd and 4th underscores [_] in the filename need to be changed to dashes [-] after downloading):

This post has been edited by tumnus: Feb 28 2005, 08:26 AM
Attached File(s)
Attached File  bluez_zaurus_2.13_2.4.18_alpha3_arm.ipk ( 310.9K ) Number of downloads: 3157
Go to the top of the page
+Quote Post
Start new topic
post Jan 15 2005, 10:32 AM
Post #2

Group: Members
Posts: 1,176
Joined: 3-October 03
From: UK
Member No.: 547

OK, here's a challenge to anyone with a serial based Bluetooth card (such as the Socket Rev G/H):

- Get the latest ipk working with your card without hacking any default ROM files (i.e. /etc/pcmcia/serial) or at least tell me why using the same serial commands in /etc/pcmcia/bluetooth won't work

No one has reported whether the new susp-resume-bluez ipk works better either...
Go to the top of the page
+Quote Post
post Jan 31 2005, 09:48 AM
Post #3

Group: Members
Posts: 53
Joined: 8-March 04
From: UK
Member No.: 2,204

QUOTE(tumnus @ Jan 15 2005, 06:32 PM)
OK, here's a challenge to anyone with a serial based Bluetooth card (such as the Socket Rev G/H):

- Get the latest ipk working with your card without hacking any default ROM files (i.e. /etc/pcmcia/serial) or at least tell me why using the same serial commands in /etc/pcmcia/bluetooth won't work

No one has reported whether the new susp-resume-bluez ipk works better either...

Hi, I'm back.

I'm going to try the new drivers soon (I'll probably have time to play over the weekend). I've just been looking over some of the old forum posts about this. For me, the show-stopper is described at https://www.oesf.org/forums/index.php?showt...402&#entry13402 i.e. it is not that the commands don't work when invoked from /etc/pcmcia/bluetooth, but that /etc/pcmcia/bluetooth isn't run at all when the card description is in /etc/pcmcia/bluetooth.conf . The only way around this that I found was to remove the card description from bluetooth.conf, so my Z falls back on /etc/pcmcia/serial. I never managed to find out how to investigate this beyond the obvious/trivial (file permissions, etc.), so if anyone could give me any pointers I would be very grateful.

By the way, just unpacking the IPK and eyeballing your files, I found the following syntax error in /etc/pcmcia/bluetooth:

case "$1" in

should be

case "$1" in

But I don't think that is the problem from the past - the current version of this file on my Z (which would have been the last one I tried) is syntactially OK

Go to the top of the page
+Quote Post

Posts in this topic
tumnus   New Bluetooth Drivers   Jan 9 2005, 05:28 PM
tumnus   I have also improved the susp-resume-bluez package...   Jan 9 2005, 05:30 PM
tumnus   Please test the ipks above and let me know whether...   Jan 10 2005, 12:48 AM
tumnus   I think I might have made a mistake for the serial...   Jan 10 2005, 03:12 AM
tumnus   No one tested these ipks yet?   Jan 10 2005, 09:35 AM
Pyrates   Sorry, I don't have anything bluetooth to test...   Jan 10 2005, 11:35 AM
tumnus   I've fixed the unresolved symbols problem in t...   Jan 10 2005, 11:41 AM
maslovsky   Here are some results: Zaurus 5500, Sharp ROM 3.1...   Jan 11 2005, 04:45 AM
EdbO   To get the Billionton Bluetoothcard working you mu...   Jan 11 2005, 07:28 AM
maslovsky   QUOTE(EdbO @ Jan 11 2005, 06:28 PM)To get the...   Jan 11 2005, 08:52 AM
tumnus   I know I need to add some scripting options for th...   Jan 11 2005, 09:30 AM
maslovsky   QUOTE(tumnus @ Jan 11 2005, 08:30 PM)I know I...   Jan 14 2005, 08:20 AM
spectrum   Hi folks, I have the SL5000D and cacko rom. I rec...   Jan 14 2005, 08:27 AM
nexxusone   I've just installed the drivers on my Zaurus c...   Jan 15 2005, 09:22 AM
tumnus   OK, here's a challenge to anyone with a serial...   Jan 15 2005, 10:32 AM
pakman   QUOTE(tumnus @ Jan 15 2005, 06:32 PM)OK, here...   Jan 31 2005, 09:48 AM
tumnus   QUOTE(pakman @ Jan 31 2005, 05:48 PM)/etc/pcm...   Jan 31 2005, 03:34 PM
Dave L.   Tumnus, You are the man I've been tearing...   Jan 22 2005, 10:02 AM
mimsmall   Using BT2000E on 6000L. Downloaded the driver and...   Jan 22 2005, 04:25 PM
tumnus   I've corrected the applet links in the Bluetoo...   Jan 22 2005, 06:15 PM
tumnus   I've corrected the syntax error spotted by pak...   Jan 31 2005, 03:45 PM
tumnus   No one with a serial based Bluetooth card tried th...   Feb 4 2005, 07:27 PM
mimsmall   I'm in the process. Making the Irda connection...   Feb 5 2005, 07:07 AM
lwong   Tumnus, Thanks for your effort to bring Bluetooth...   Feb 13 2005, 06:28 PM
lwong   Ok, it's working now. All I did was eject the ...   Feb 14 2005, 08:30 AM
sornette   hey tumnus, Here's another input. I tried the ...   Feb 21 2005, 09:03 AM
tumnus   Does the card automatically eject and reappear whe...   Feb 21 2005, 11:56 AM
sornette   QUOTE(tumnus @ Feb 21 2005, 03:56 PM)Does the...   Feb 22 2005, 09:58 AM
pakman   Hi Tumnus, Finally got around to trying the new b...   Feb 22 2005, 04:38 AM
tumnus   sornette, thanks for pinpointing that. maslovsky j...   Feb 22 2005, 10:44 AM
OttoAcuna   Tumnus, Thanks for the effort!!! I n...   Feb 26 2005, 10:46 PM
tumnus   I'm afraid the latest Ambicom BT CF card still...   Feb 27 2005, 03:43 PM
lgurevich   QUOTE(tumnus @ Feb 27 2005, 06:43 PM)I'm ...   Feb 28 2005, 10:51 PM
tumnus   QUOTE(lgurevich @ Mar 1 2005, 06:51 AM)I have...   Mar 1 2005, 12:25 AM
lgurevich   QUOTE(tumnus @ Mar 1 2005, 03:25 AM)QUOTE(lgu...   Mar 1 2005, 05:46 PM
tumnus   I've uploaded a new version of the susp-resume...   Feb 28 2005, 08:28 AM
polito   *sigh* yep, can definitely confirm the ambicom bt2...   Feb 28 2005, 09:55 PM
xjqian   6k, stock rom, adf's fast kernel Socket BT rev...   Apr 17 2005, 07:39 PM
xjqian   i got it figured out. i'm typing using the bt ...   Apr 24 2005, 04:48 AM
xjqian   more updates about suspend-resume bluez-zaurus_2....   Apr 24 2005, 10:32 PM
steliosx   will those nice drivers work with a c1000 used wit...   Apr 27 2005, 07:45 AM
tumnus   QUOTE(steliosx @ Apr 27 2005, 03:45 PM)will t...   Apr 27 2005, 07:53 AM
adrian   QUOTE(tumnus @ Apr 27 2005, 05:53 PM)https://...   May 4 2005, 05:52 AM
tumnus   QUOTE(adrian @ May 4 2005, 01:52 PM)QUOTE(tum...   May 4 2005, 01:49 PM
steliosx   thanks for your reply and continuous support tumnu...   Apr 27 2005, 10:18 AM
Ragnorok   - All is well, essentially. So, if I only had a b...   May 14 2005, 07:31 PM
Omicron   DELETED   May 16 2005, 08:45 PM
egg8178   can some one confirm that bt2000c is working as st...   Jun 3 2005, 07:19 AM
OttoAcuna   QUOTE(egg8178 @ Jun 3 2005, 03:19 PM)can some...   Nov 22 2005, 06:23 PM
g33k   Will this stuff work with pdaXrom? Will this stuf...   Jun 20 2005, 09:35 AM
grog   Could somebody please do me a favour & comment...   Jul 28 2005, 08:55 AM
mike456   QUOTE(grog @ Jul 28 2005, 09:55 AM)Could some...   Jul 28 2005, 04:58 PM
Cresho   Here is a list of places you can by the one i use....   Sep 1 2005, 06:53 PM
tfulcher   OK, I got to jump in here with a request for assis...   Sep 8 2005, 05:51 AM
Cresho   QUOTE(tfulcher @ Sep 8 2005, 05:51 AM)I don...   Sep 8 2005, 03:53 PM
blinkblob   so What's new with everybody? Still waiting ...   Sep 10 2005, 03:28 PM
BissigerPinguin   I had some trouble to get the Billionton CFBT02-B2...   Sep 17 2005, 10:16 AM
speculatrix   might be worth looking at OpenTom and TomTom's...   Jan 1 2006, 09:17 AM
xjqian   QUOTE(tumnus @ Jan 9 2005, 08:28 PM)This is o...   Feb 28 2006, 09:39 PM
jstracke   I just bought an AIRNET ABT201 USB dongle, and I h...   Mar 16 2006, 08:24 AM
jstracke   QUOTE(jstracke @ Mar 16 2006, 11:24 AM)I just...   Mar 23 2006, 07:45 PM
dinorex   I really don't know why.... I've just got...   Oct 12 2006, 10:09 AM
Cresho   QUOTE(dinorex @ Oct 12 2006, 10:09 AM)I reall...   Oct 12 2006, 01:22 PM
Meanie   QUOTE(Cresho @ Oct 13 2006, 07:22 AM)QUOTE(di...   Oct 12 2006, 02:01 PM
Cresho   installed qshdlg. finds phone but wont connect th...   Oct 12 2006, 08:37 PM
D_odik   Who kept this driver, please answer! I can not...   Jul 16 2009, 11:40 AM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 26th May 2018 - 09:44 AM