OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
ernestus doesn't have a personal statement currently.
Personal Info
ernestus
46 years old
Gender Not Set
Cambridge (UK)
Born May-25-1968
Interests
No Information
Statistics
Joined: 21-July 06
Profile Views: 1,056*
Last Seen: 26th March 2008 - 04:42 PM
Local Time: Nov 24 2014, 04:16 PM
49 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

ernestus

Members


Topics
Posts
Comments
Friends
My Content
4 Sep 2007
Well, who is doing what in pdaXrom?

I am glad to contribute, but my spare time comes in bursts, so I have to be careful choosing what subject can I work on so I can finish it before the burst is gone. That makes difficult for me to start a whole new project, I prefer to do small contributions I can finish spending some evenings along one week (like the toolchain I ported but that looks like no one is using, I don't have any bug report laugh.gif ).

I will be very pleased if the developers say something about their problems and share a little the problems they are facing.

Cheers
E
28 Aug 2007
I've been searching in the forums but I cannot make a clear idea, so I ask here.

pdaXrom builder:
I've tried to download it from the links I've found, but all of them look down. Is there any place I can download it from?

pdaXrom milestones:
Do you keep a place with the desired milestones for the project?

Which XScale features don't have support in the kernel yet?

/dev/bvdd aka bulverde:
I downloaded the XScale programming manual from the old intel website, an I think this device refers to the YUV overlay it has, is this point right?.
I understand it can accelerate video (it's not necessary to make any YUV->RGB conversion), but how can it accelerate the SDL? are the people talking about something else? Is it ported to the 2.6 kernel? Is the potatoes price going to raise?

Although I have a zaurus since more than one year ago, it was not more than a brick on my desk for all that time... sad.gif

Thanks in advance to all you who put your effort on such a fine piece of software.
22 Aug 2007
[Updated, see next message in thread, old thread title was "Gcc 4.2.1 + Glibc 2.5 Cross Toolchain Available"]

Hi people.

I've just come back from my holidays (3 weeks in Japan, what a marvellous country, what marvellous people!) and I've retaken this personal project of having Qt4 in pdaXrom, see:
http://www.oesf.org/forums/index.php?showtopic=24389

Well, I've built a new toolchain based on gcc 4.2.1 (the latest one) and glibc 2.5 (not so current, 2.6.1, the latest, gives a lot of problems due to linuxthreads being deprecated in glibc 2.6).

I ended up with a 250Mb monster in my /opt directory smile.gif. Hopefully the tar.gz package is about 70Mb.

The major drawbacks is that glibc didn't compile with kernel 2.4.x headers (at least I didn't manage to find any way to do that). I am afraid this thing is going to run on the new 2.6 kernel only (there are some more restrictions, like I had to use the headers from the kernel 2.6.16 to achieve a complete build).

Anyway, can somebody tell me where to put a tar.gz of this? I would like the people test it.

The package content::
binutils-2.17
gdb-6.6
glibc-2.5 (bootstrapped in gcc-4.1.2, not in a 3.x series as is usual in arm architectures)
gcc-4.2.1 (c and c++ support, planned fortran and pascal)
libstdc++ v3

and the other misc thing to keep all those programs running.

I didn't have too much idea about the correct parameters for the architecture, so these are the configure command lines, just I leave them here so someone can tell me if I should drop or add something:

gcc configure command line: \"'--cache-file=./config.cache' '--build=i686-host_pc-linux-gnu' '--host=i686-host_pc-linux-gnu' '--target=arm-softfloat-linux-gnueabi' '--prefix=/opt/cross/arm/gcc-4.2.1-glibc-2.5/arm-softfloat-linux-gnueabi' '--with-float=soft' '--with-headers=/opt/cross/arm/gcc-4.2.1-glibc-2.5/arm-softfloat-linux-gnueabi/arm-softfloat-linux-gnueabi/include' '--with-local-prefix=/opt/cross/arm/gcc-4.2.1-glibc-2.5/arm-softfloat-linux-gnueabi/arm-softfloat-linux-gnueabi' '--disable-nls' '--enable-threads=posix' '--enable-symvers=gnu' '--enable-__cxa_atexit' '--enable-shared' '--enable-c99' '--enable-long-long' '--enable-languages=c,c++' '--program-transform-name=s,^,arm-softfloat-linux-gnueabi-,; ' '--srcdir=/srv/sources/z/src/crosstool-0.43/build/arm-softfloat-linux-gnueabi/gcc-4.2.1-glibc-2.5/gcc-4.2.1/gcc' 'CC=gcc' 'CFLAGS=-g -O2' 'GMPINC=' 'GMPLIBS=-lmpfr -lgmp' 'LDFLAGS=' 'build_alias=i686-host_pc-linux-gnu' 'host_alias=i686-host_pc-linux-gnu' 'target_alias=arm-softfloat-linux-gnueabi'\"

glibc:
\"'--prefix=/usr' '--build=i686-pc-linux-gnu' '--host=arm-softfloat-linux-gnueabi' '--without-fp' '--with-tls' '--with-__thread' '--enable-kernel=2.6.0' '--enable-kernel=2.6.4' '--without-cvs' '--disable-profile' '--disable-debug' '--without-gd' '--enable-shared' '--enable-add-ons=yes' '--with-headers=/opt/cross/arm/gcc-4.2.1-glibc-2.5/arm-softfloat-linux-gnueabi/arm-softfloat-linux-gnueabi/include' '--cache-file=config.cache' 'CC=arm-softfloat-linux-gnueabi-gcc ' 'CFLAGS=-O ' 'build_alias=i686-pc-linux-gnu' 'host_alias=arm-softfloat-linux-gnueabi'\"

Any comments on those parameters?

Do the kernel people think this thingy is useful for them?

Any hints what to do next to have Qt4 running?

Btw, completing Qt4 would close the feature request described in case number 200-40:
http://www.pdaxrom.org/?q=node/220

Cheers
E
16 Jul 2007
Hi
My original idea was porting some old Qtopia apps to Qt4, and building other google-found Qt utilities. The memory resources used by Qt4 and its speed compared to old versions impressed me. Porting the old Qtopia apps would make the Z a kinda Super X PDA Mini Laptop... yes, I know, sometimes I am like a teenager rolleyes.gif

Well, I needed Qt4 but it wasn't in the repositories, so...

I've been trying to build the latest Qt4 for pdaXrom for the last two or three weeks. Something that I thought that was going to be a simple cross compiling turned out to be very tricky.

The first problem was Qt itself, it builds a series of tools that are used later in the build process itself , that makes cross compiling really hairy (I would have to tweak their build process, so no way...)

So I went to on Zaurus compiling... The Z is very slow (I have a SL-C3200 and it's speed is that of a 200 Mhz Pentium) And the build takes ages. I launch the build, and I get an error several hours later (Civil says the whole process should take about 50 hours).

A byproduct of this attempt is I've assembled together several parts and "constructed" (not written) a kind of SL-C3200 toy emulator based on qemu that goes well ONLY if you want to do native builds (thanks guys, I took most of my tools from you). The only not so good news are it is not much quicker than the Z running in my laptop (an Intel core duo @ 2Ghz ). BTW the emulated RAM can be as much as 256M, so this speeds the build a little bit, and I don't wear my Z microdrive.

The errors I had in this native build are:
-- Related to the precompiled headers. I think is related to the old version of GCC I am using (gcc 3.4.6). I disabled them when invoking the configure script., and solved that problem.

-- Some errors related to include files and symbol definitions. I've been tweaking one by one, you have to think I launch the build and I have the errors back many hours later, so it goes very slowly. I thought it was related to the qmake spec file I was using to build Qt, but Civil remarked that the glic version included in pdaXrom it's very old (glibc 2.2.5). But more important, he pointed out that, even after succeeding he's found several errors that makes the library unusable (thanks man, you've saved me many hours of trial and error)

And now my questions:
-- Does anybody know if there is any plan to introduce an newer compiler in pdaxrom? (I've seen a bug report about this)
-- Is it possible to build a newer glibc? mind that this point may need a rebuild of the repositories.

Before I finish a remark:
In my crappy-good-for-nothing-but-at-least-it-compiles emulator I am mixing some pdaxrom and some openzaurus, and they work very well together. Won't make sense to make pdaxrom a kinda usability-oriented angstrom flavour? those guys have a really slick distro (technically speaking), but not as friendly as pdaxrom.

Of course, thanks again.

E
25 Jun 2007
Hi all.

Finally I have chosen pdaXrom as my rom (it has taken a whole year... I tried everything under the Sun). So the first thing to do was setting up a development environment in my Z (thanks all of you that make such a nice collection of squashed images) and tried to compile my "must have" programs.

Currently I am trying to compile Qt 4.3.0, but there is a lot of things to fix to compile it (I am using the images Meanie has made available in his web site). And now it's taking more than one week of micro-drive 24/7 hard work (I make a fix, launch the compiler, and errors appear many hours later sad.gif). I am afraid the micro-drive it's not designed for this kind of work... Is this correct?

There is an emulator out there, QEMU, able to emulate several ARM systems, has anyone tried to compile "natively" with it, I mean having an emulated ARM system to compile quasi-natively...?

I am seriously thinking about cross compiling, the rom I tried just before (OpenZaurus) has a very well defined set of tools for this, even a virtual machine you can download to do the job... I am a little bit confused about pdaXrom, which tools do you use to develop and compile, guys?

I apologise if I overlook the posts that made those subjects clear...

Thanks.
E
Last Visitors


14 Jul 2008 - 4:20


7 May 2008 - 12:33


14 Nov 2007 - 2:04

Comments
Other users have left no comments for ernestus.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 24th November 2014 - 08:16 AM