OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
SiduS doesn't have a personal statement currently.
Personal Info
SiduS
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 4-August 06
Profile Views: 271*
Last Seen: 26th December 2007 - 03:43 PM
Local Time: Apr 20 2014, 10:03 PM
52 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

SiduS

Members


Topics
Posts
Comments
Friends
My Content
18 Dec 2007
Hi,

Ok I know there are a lot of threads about getting bluetooth DUN to work. And I'v read through most of them. I was able to get to this point.


I have configured my /etc/bluetooth/givepin to echo PIN:1234

and I can do rfcomm connect hci0 <MAC ADDRESS> 1

The phone prompts for pairing. I submit the pin and its successfull.

But when trying to use the pdaxii13 ppp dialer it fails with teh following error:

Failed to open /dev/rfcomm0: No such device

I used the system PPP configuration tool to specify all the correct information for my username / pass and number to dial.

I know its just some simple configuration that I'm missing but I don't know what else to do.
15 May 2007
So I tried to use a U-Boot / Emergency install and now my Z (3200) is Fsck'd up.

Here is what I did to get back to pdaxii13.

I think this should be expanded, verified and made sticky. Also should be added to the documentation.

These instructions cover Restoring Nand Flash, Partitioning and creating microdrive file structure.

I also had to use pdaxii13's rom to boot into the OK (flash utility) menu to get to a console. Explained after step 9. So you will also need to download pdaxii13's rom for step 1 if B+D boot does not work like mine.

1. Download the following:
http://www.trisoft.de/download/SYSTC320.zip
http://www.trisoft.de/download/SLC3200SYSPART.zip
http://www.trisoft.de/download/C3200-2006-04-05-13-00.zip

2. Format your SD/CF to Fat16 (Fat32 does not work) and extract the contents of SYSTC320.zip to the root of your SD/CF

3. Take battery out and unplug power

4. Hold fn+D+M

5. Plug power in (Battery not required)

6. Diagnostic Menu should boot.

7. Pagedown and go into the Backup Restore Menu (3/3)

8. Press OK button for Execute Restore and Delete all flash data. A green bar should start progressing at the bottom shortly after. It will take about 5 minutes to restore. You should see "OK" after Restore ... when completed.

9. Use the x (escape) key to back out. Then use the on/off to power off.

***NOTE***

When trying to use the Hold B+D and power on option it failed with an error about hdd2. This is just a console boot menu. You can get a console boot menu with pdaxii13's rom. You will need to download the pdaxii13 rom files and copy them to the root of you SD/CF card as well before continueing.

10. Extract the contents of SLC3200SYSPART.zip to the root of your SD/CF

11. Make sure the batter is in. Put power cable in.

12. Hold OK and power on. Chose Option 4 then SD or CF and Yes.

13. You should be in the Nand Flash Utility Menu. Select Console Command option.

14. fdisk /dev/hda (note you need to hold shift in this console to get the / )

15. Delete all partitions

16. Create 3 (n)ew partitions:
Partition 1: Primary: Block 1 - 20
Partition 2: Primary: Block 21 - 40
Partition 3: Primary: Block 41 - end (11905)

***NOTE***
I found that after the partitions were created the display showed that the first partition was 10079+ where as the documentation (in SLC3200SYSPART.zip) indicated it should be 10048+. This, however, did not cause any problems for me.

17. Toggle partitions 1 and 2 to be type 83 (if not already). Toggle partition 3 to be type Win95 Fat32 (LBA). Verify in (p)rint menu that the disk is 16 heads / 63 sectors/track / 11905 cylinders. (w)rite the partition tables.

18. Format the partitions
mke2fs -j /dev/hda1
mke2fs -j /dev/hda2
mkfs.vfat -F 32 /dev/hda3

19. Reboot. Repeat steps 11-13 to get back to a console.

20. Mount partitions and copy over .sys files.
mount /dev/hda1 /hdd1
mount /dev/hda2 /hdd2

***NOTE***
I found that there was no .sys directory in hdd1 or hdd2. However, there was a lost+found directory as required. I manually created the directories and set permissions:
mkdir /hdd1/.sys
mkdir /hdd2/.sys
chmod 700 /hdd1/.sys
chmod 700 /hdd2/.sys

21. Copy the contents of SLC3200SYSPART.zip/hdd1sys to /hdd1/.sys and
SLC3200SYSPART.zip/hdd2sys to /hdd2/.sys

22. Make sure you are not in /hdd1 or /hdd2 and unmount the partitions:
umount /hdd1
umount /hdd2

23. reboot

24. Repeat steps 11-12 to get into Flash Utility Menu.

25. At this point you may or may not be able to install the default Sharp Rom (I don't know). I did not. I chose to install pdaxii13. So thats what these instructions cover.

26. Resize the flash drive to 121mb and install new rom. Please refer to the pdaxii13 documentations on how to do this.
14 May 2007
Hi all,

Here I am just messing shit up like always.. Now I need help sad.gif

I have a 3200.

So long story short.. I have done the following with pdax r198..

I downloaded the emergency boot files..
I did fn+c+d and instructions said it would light up for 20 secs and then go off.. well it didnt.. it just went on for like 5 seconds and then just kept blinking.. So I powered it off..

Then I just did a power+OK and it booted into and loaded r198..

Now I want to go back to beta3 or pdaxii13.

Instructions say to use the fn+d+m menu to nand flash erase, then nand flash restore with orig sharp rom.. then power+ok to load rom.


I got it to flash erase. but I can't find sharp rom to use. I tried cacko and it said something about systc3200.dbx missing..

So I'm not sure what to do now.

Can someoen either point me to correct instrustions.. Or if the above is correct direct me to the correct rom to use for this step.

Thanks in advance.
6 May 2007
Hey,

Man I have nothing but problems doing anything.

So I got pdaxii13 full for my sl-c3200. Stupidity on my part.

So I'm hoping this is just more stupidity on my part and a simple fix.

I have a TRENDnet TEW-222CF wifi card.

It worked just fine in Beta3 and loaded as a Orinoco Prism2

Now when I plug it in it shows in the Card Monitor as:

Agere Systems Hermes-I based PCMCIA Wireless Adapter

I look at dmesg and all it shows is:

pxa_pcmcia_init(0)
: Wireless, HCF failure: "Error code 64"

I try

cardctl status and it shows

Socket 0:
5V 16-bit PC Card
function 0: [ready]

Socket1:
3.3V 16-bit PC Card
function 0: [ready], [bat dead], [bat low]

I don't remember having to do anything in beta3 to get it to work.

Any suggestions?
5 May 2007
I have a sl-c3200.

I use to have beta3 and I just wanted to try out Cacko 1.23. But that was a disaster. So I figured I'll go with pdaxii13.

So I followed the instructions listed on:

http://www.tyrannozaurus.com/feed/pdaXii13/akita/

I put the following on my SD root:

updater.sh
updater-tools.bin
initrd.bin
hdimage-full.tgz

I do a partition of my hda. I do install new rom. Just to get it up and running to see how it is. Looks fine. Then I boot back into NAND to do the full image install.

All the instructions say is:

"...You can upgrade pdaXii13 base to pdaXii13 full on a SL-C3100/SL-C3200 by formatting the MicroDrive and extracting the hdimage-full.tgz onto the MicroDrive. You can use the pdaXii13 Akita installer to partition your MicroDrive and extract the hdimage. ..."

So I have the hdimage-full.tgz on my SD card. I boot into the NAND and I partition the drive using recommended partition option. Reboot back into NAND, select option 5. "Install hdimage"

It goes all blue and then comes back to the same screen. No errors. No confirmation. So no news is good news.. right?

I chose reboot. And nothing. Same base install.

Anyone have any suggestions? Am I not following the instructions right?
Last Visitors


5 Jun 2008 - 4:33


13 Apr 2008 - 6:49


7 Mar 2008 - 3:14


19 Feb 2008 - 10:44


7 Dec 2007 - 15:01

Comments
Other users have left no comments for SiduS.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 20th April 2014 - 06:03 PM