OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
Pcghost doesn't have a personal statement currently.
Personal Info
Pcghost
40 years old
Gender Not Set
Cheney, Washington USA
Born July-7-1974
Interests
Linux, 4x4's, Networking and Network Security,
Statistics
Joined: 18-December 03
Profile Views: 1,059*
Last Seen: 9th February 2007 - 10:43 PM
Local Time: Dec 20 2014, 05:07 AM
70 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

Pcghost

Members


Topics
Posts
Comments
Friends
My Content
16 May 2005
EDIT: I reflashed using the Hentges version of the OZ 3.5.3 rom and now have the apps below working fine. I don't understand why there are such strange dependency problems with the default install of OZ, but I figure it is because of little known tricks and tips that have yet to be documented.

I tried to free up space on root by moving the Opie-PIM apps (big mistake, didn't gain anything on root), and now when I try to install Opie-addressbook I get the following.

root@collie:~# ipkg install --force-depends -d sd opie-addressbook
Installing opie-addressbook (1.2.0-r0) to sd...
Downloading http://oz.hentges.net/mirror/oz3.5.3/feed/....2.0-r0_arm.ipk
Not downgrading package opie-pics on root from 1.2.0-r1 to 1.1.8+cvs-20050202-r0.
Nothing to be done
An error ocurred, return value: 1.
Collected errors:
Warning: Cannot satisfy the following dependencies for opie-addressbook:
libqpe1 (>= 1.2.0) libqte2 (>= 2.3.10)
root@collie:~#

Now, I know force depends will override the constant libqte/libqpe error, but it fails due to opie-pics????

Ideas? Must I reflash yet again?
30 Apr 2005
I added the machine feed, as indicated by the bugs post above. I tried upgrading the libqpe and libqte2 packages from that feed. It simply says they are the latest version and will not upgrade them even with force. This is getting frustrating.

I go to install konqueror (Opera 6 is horribly buggy with the sharp-libs-compat). Here is the output from the command line.

root@titan:~# ipkg -force-depends -d ram install konqueror-embedded
Installing konqueror-embedded (20030705-r3) to sd...
Downloading http://openzaurus.org/official/unstable/3....0705-r3_arm.ipk
Not downgrading package libqpe1 on root from 1.2.0-r2 to 1.1.8+cvs-20050202-r1.
Nothing to be done
An error ocurred, return value: 1.
Collected errors:
Warning: Cannot satisfy the following dependencies for konqueror-embedded:
libqte2 (>= 2.3.10-snapshot-20050131) libqte2 (>= 2.3.10-snapshot-20050131)

What do I have to do to make these damn library errors go away?
28 Apr 2005
I just installed OZ 3.5.3 with the opie-40-24 image and it looks slick. I am having a few problems that I have not found answers to yet.

I have the common errors about libqte and libqpe (is there an explaination of what exactly is wrong with the installed versions?) and another strange problem.

When I install apps, the package manager occasionally crashes (hangs). I reset the device and when it boots it says bus error and opie will never start again, causing a reflash.

Is there a "Install these first list" for new installations of 3.5.3?

3.5.2 worked great, but I have yet to sucessfully install a single app in this new version. Mostly massive errors about symlinking failing on my SD card (ext2) and of course lib errors for libs that are installed.

EDIT: I got the SD problem worked out. I had formatted the card on my Debian Sid box instead of the Z. I reformatted it on the Z and now I can install to it.

I also found the renamed sharp-lib-compat and installed it, although it squawked about failed simlinks again. It appears in the launcher but clicking on it gives an hourglass for a few seconds then nothing. ????? I got Opera and the Handcom stuff installed, but none of it is much good without OZcompat.


On a side note, Openzaurus and its developers kick *ss. Just thought it needed to be said again.
1 Jan 2005
I have some webspace lying around that I would like to donate by becoming an official mirror for OZ. Is it just a simple copy and rsync or is there a way the OZ developers prefer for setting up a mirror? The feed at OZ tends to be really slow (too many users) and I figure every mirror helps. If you could point me in the right direction I am happy to help.
8 Dec 2004
First let me say thanks to those who developed the KO/Pi, KA/Pi, OM/Pi, and Pi-sync applications because they rule. I happily synced my zaurus with my SuSE 9.2 machine today. Calendar and address book synced great to my sheer amazement. The zaurus has always been a standalone device for me because of the complete FAILURE of Sharp to support their product on the Linux side of things.

Here is my only remaining problem with this machine. OM/Pi, the opie-mail/pi-sync app I got from the website was difficult to get installed (ipkg said something is wrong) and once installed, will not launch on the Z. I installed the kde-micro library from the site and all the other */Pi apps are working flawlessly. I have opie-libs and opie-libs1 installed, is there anything else I am missing? These are the only Pim apps I have installed on my Z.

My zaurus is a 5500 running the Alpha3 version of thekompany rom. Thanks..
Last Visitors


4 Aug 2009 - 1:22

Comments
Other users have left no comments for Pcghost.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 19th December 2014 - 09:07 PM