OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
fpp doesn't have a personal statement currently.
Personal Info
fpp
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 1-February 04
Profile Views: 2,734*
Last Seen: 29th July 2012 - 12:55 PM
Local Time: May 26 2015, 05:56 AM
188 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

fpp

Members


Topics
Posts
Comments
Friends
My Content
10 Apr 2010
A surprise move from Sharp: the long-awaited (by some) successor to the Zaurus, a new clamshell "MID" running Android, with a beautiful 5" 960x480 screen, a Snapdragon CPU and plenty of goodies:

http://www.engadget.com/2010/03/30/sharp-i...-au-to-android/

Engadget goes "meh", which is a pretty good omen in my book :-)

Also there will be a "developer-friendly" version dubbed DK01 where the OS is replaceable. Maybe we will see Maemo, Mer and/or Meego on it ?

--edit--url fixed by admin--
10 Jun 2006
As promised by Nokia, the long awaited update is showing up. A beta is available for developers to port their apps before the end-user version is released.

From early reports the ground covered with this new version sounds incredible. What a difference it makes when the manufacturer of a Linux-powered widget actually groks open source and plays by the rules...
18 Mar 2005
Well, thanks to the help of all here my problem with zlib is finally solved... so I get to see entirely new exceptions when I launch TreeLine, yay :-)

First, I found that the "locale" subsystem on the Z (Cacko 1.21) does not seem to like the standard python idiom :

import locale
locale.setlocale(locale.LC_ALL, '')

(dies with: "locale.Error: unsupported locale setting")

The only syntax I could get to run was locale.setlocale(locale.LC_ALL) (no locale parameter). This required changes to the app's code but also in locale.py.

After that the app finally got around to importing some stuff from the qt package... and stopped right there on the first line, with :

ImportError: unable to import name QColorDialog
(and also QInputDialog, and probably others)

What I'm wondering here is whether this is just a naming issue (like the QApplication vs QPEApplication thing) or a deeper mismatch between the versions of Qt/PyQT used by the app's author and those available on the Z. His app works with the old freeware version of Qt for Windows though, so it's not *that* sensitive...

In other words : is it hopeless to want to port an existing, non-trivial PyQt app to the Zaurus, and is the Z's (Py)Qt only useful for developing from scratch on itself ?
13 Mar 2005
Kopsis,

I just tried out a nice PyQt app ( http://www.bellz.org/treeline/ ) that looks just right for running on a Z ! The windows version works fine on my PC, but I have a problem with the Linux version :

The installer says all dependencies are OK, but when I try to run it fails when the gzip module tries to "import zlib" (I can't import it manually from the interpreter either).

Is there anything I can do about this ?

TIA,
fp
Last Visitors


16 Mar 2009 - 6:20


2 Mar 2009 - 15:11

Comments
Other users have left no comments for fpp.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 26th May 2015 - 05:56 AM