OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
d2a doesn't have a personal statement currently.
Personal Info
d2a
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 9-August 08
Profile Views: 489*
Last Seen: 28th August 2008 - 01:50 AM
Local Time: Dec 19 2014, 04:09 PM
13 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

d2a

Members


Topics
Posts
Comments
Friends
My Content
12 Aug 2008
So i'd like to try adding space via the SD/MMC mod. having read the various wiki entries and forum posts, if i understand correctly, I need:
  1. SD card
  2. cheap SD -> USB adapter (optional?)
  3. ribbon cable 0.5mm pitch 20 pin ?
  4. adapter - this? or this?
  5. wire and assorted soldering bits and bobs

I'm happy dismantling the Simpad, and am competent at soldering small components. Is this all I need, or am I missing something?

Secondly, does anyone know a UK firm that has the ribbon cable components? alternatively, would someone be wiling to order the parts on my behalf, and then post them to the uk? the lc-design site did not seem to offer international sales.

Thirdly, what is the most recent recommended bluetooth module? I am less interested initially in this mod, but would probably try it if there was a cheap module.

Thanks in advance for any help
11 Aug 2008
So - after a minor glitch with a strange serial port problem, I had no problem installing the HH.org bootloader. I then downloaded the X11 image and copied it onto a compact flash card. Following the instructions I renamed the jffs2 file, inserted it into the simpad, connected a terminal via serial and reset the simpad.

however, reading the final page of the HH.org bootloader instructions, and watching the output of the terminal, it seems the bootloader is looking for a differently named image, and would automatically install without the need for the terminal, if it was correctly named.

i then continued as instructed, i.e. "copy hda1:/rootfs.jffs2 root" and the install completed. i then booted into angstrom.

impressions:
  • the touch screen seems slightly inaccurate, especially noticeable within the virtual keyboard. recalibration improved this slightly
  • virtual keyboard (ol' good keyboard - qwertyGB geometry layout) seems to misbehave - various keys sometimes behave as if the enter key had been pressed - d especially. this happens within terminal.
  • virtual keyboard size - would be nice if the keyboard width was parametric, so something like original small CE keyboard could be displayed
  • Keys and Buttons setup - no button configuration available for this device - would be good to have the hardware buttons mappable, to enable the keyboard button, right click, and change the behaviour of the 4 way switch.
  • Battery monitor - does not seem to reflect battery status when on battery - if charging (connected to mains) battery juice is accurately shown as 64% for instance, but once unplugged, battery status jumps to 100%, and never drops until device goes flat and powers down
  • WiFi - tried three wlan pcmcia cards - only one worked. three cards are
    • siemens i-gate 11m - works natively under CE but fails to init "cs: pcmcia_socket0: time out after reset."
    • Xircom CWE1100 - fails to init "cs: pcmcia_socket0: time out after reset."
    • Linksys WPC11 ver.3 - plug and play
  • Wireless monitor panel utility - does not reflect status of wifi card

All in all, not too bad. Only other issue thus far is the lack of space - really cramped, so not been able to install anything laugh.gif
9 Aug 2008
in the past i've managed to install previous versions of the bootloader, but always reverted to the siemens one because of the instability of early linux builds. wanted to try the new build, so followed instructions: erased flash memory via terminal. then closed terminal and ran serload blupdater.img. prompted to reset, but no response from serload when i do. tried all combinations of reset plus button and nothing seems to register. now just get the tartan screen obviously.

simpad connected to windows xp machine, bootloader is siemens 2.5.3, old OS was CE 4.1

any ideas?
Last Visitors


21 Sep 2008 - 8:24

Comments
Other users have left no comments for d2a.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 19th December 2014 - 07:09 AM