OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
henrysviper doesn't have a personal statement currently.
Personal Info
henrysviper
39 years old
Male
Athens, Greece
Born June-24-1975
Interests
No Information
Statistics
Joined: 4-May 04
Profile Views: 810*
Last Seen: 21st January 2010 - 03:05 AM
Local Time: Nov 24 2014, 02:08 AM
76 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

henrysviper

Members


Topics
Posts
Comments
Friends
My Content
19 Jan 2007
I finally found the time today to install OZ 3.5.4.1 (GPE) on my C750. I am very impressed with the result. It is evident that a lot of work has been put in this version.

I have however a problem that renders my installation almost unusable.
My SD card, a Toshiba 512 MB, is extremely slow: read speed is around 300 KB/sec and write speed is around 20 KB/sec. The card was working perfectly on older versions of OZ (and pdaxrom).
The card has one partition with the ext2 fs. I tried recreating the partition and the filesystem but I didn't see any improvement.

The card seems to be working (tested in a cardreader and also I don't see any relevant messages in dmesg output). Is there a way to improve its speed in OZ?
11 Dec 2005
Hello everybody

I recently purchased a phone (sharp GX17) having an infrared port and GPRS capability. I can use it as a modem (through infrared) in WindowsXP to connect to the Internet without problems.

However, I get strange behaviour when I try to use it with my C750 (with pdaxrom).
I have set-up ppp correctly (using instructions from this forum and from other sites).
(I attached below the related files).

The problem is this:

- If I switch on my mobile and try to use it with the zaurus (calling pppd from the commandline), pppd first reports
CODE
Serial connection established.
Connect: ppp0 <--> /dev/ircomm0


but then disconnects with:
CODE
LCP: timeout sending Config-Requests

(this happens after sending a series of
CODE
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x81147463> <pcomp> <accomp>]

and receiving nothing)

It 's frustrating, because if I issue the commands that are used in the chat-script by hand through minicom, I get the familiar stream of "garbage-like" characters that is ppp traffic.


- If i use the phone with windows, and then try to use it with the zaurus, ppp *works* perfectly!
(and it works again and again as long as I don't switch the mobile off).

I examined the modem log from the windows box and I use the same commands in my chat-script,
but with no luck. I cannot understand what may be the problem (some strange setting in the windows driver? a flow-control problem?...)


This is the modem log from windows:

CODE
12-11-2005 22:35:10.093 - File: C:\WINDOWS\system32\tapisrv.dll, Version 5.1.2600 12-11-2005 22:35:10.093 - File: C:\WINDOWS\system32\unimdm.tsp, Version 5.1.2600
12-11-2005 22:35:10.093 - File: C:\WINDOWS\system32\unimdmat.dll, Version 5.1.2600
12-11-2005 22:35:10.093 - File: C:\WINDOWS\system32\uniplat.dll, Version 5.1.2600
12-11-2005 22:35:10.093 - File: C:\WINDOWS\system32\drivers\modem.sys, Version 5.1.2600
12-11-2005 22:35:10.093 - File: C:\WINDOWS\system32\modemui.dll, Version 5.1.2600
12-11-2005 22:35:10.093 - File: C:\WINDOWS\system32\mdminst.dll, Version 5.1.2600
12-11-2005 22:35:10.093 - Modem type: GXmdm4_Ir
12-11-2005 22:35:10.093 - Modem inf path: mdmgx4_i.inf
12-11-2005 22:35:10.093 - Modem inf section: MDMGX
12-11-2005 22:35:10.093 - Matching hardware ID: irenum\shp6103
12-11-2005 22:35:15.892 - 115200,8,N,1, ctsfl=1, rtsctl=2
12-11-2005 22:35:15.892 - Initializing modem.
12-11-2005 22:35:15.902 - Send: AT<cr>
12-11-2005 22:35:16.002 - Recv: AT<cr>
12-11-2005 22:35:16.012 - Recv: <cr><lf>OK<cr><lf>
12-11-2005 22:35:16.012 - Interpreted response: OK
12-11-2005 22:35:16.032 - Send: AT V1 E0 &D2 &C1 S0=0<cr>
12-11-2005 22:35:16.172 - Recv: AT V1 E0 &D2 &C1 S0=0<cr>
12-11-2005 22:35:16.172 - Command Echo
12-11-2005 22:35:16.242 - Recv: <cr><lf>OK<cr><lf>
12-11-2005 22:35:16.242 - Interpreted response: OK
12-11-2005 22:35:16.252 - Send: ATS7=60 +DS=3,0,512,20 +IFC=2,2<cr>
12-11-2005 22:35:16.412 - Recv: <cr><lf>OK<cr><lf>
12-11-2005 22:35:16.412 - Interpreted response: OK
12-11-2005 22:35:16.412 - Setting Digital Link Protocol.
12-11-2005 22:35:16.422 - Send: AT+CGDCONT=1,,"internet"<cr>
12-11-2005 22:35:16.613 - Recv: <cr><lf>OK<cr><lf>
12-11-2005 22:35:16.613 - Interpreted response: OK
12-11-2005 22:35:16.623 - Send: AT+CBST=7,0,1;+CGQREQ=1,,,,,;+CGQMIN=1,,,,,<cr>
12-11-2005 22:35:16.833 - Recv: <cr><lf>OK<cr><lf>
12-11-2005 22:35:16.833 - Interpreted response: OK
12-11-2005 22:35:16.833 - Waiting for a call.
12-11-2005 22:35:16.843 - Send: ATS0=0<cr>
12-11-2005 22:35:17.023 - Recv: <cr><lf>OK<cr><lf>
12-11-2005 22:35:17.023 - Interpreted response: OK
12-11-2005 22:35:17.023 - Initializing modem.
12-11-2005 22:35:17.033 - Send: AT<cr>
12-11-2005 22:35:17.194 - Recv: <cr><lf>OK<cr><lf>
12-11-2005 22:35:17.194 - Interpreted response: OK
12-11-2005 22:35:17.204 - Send: AT V1 E0 &D2 &C1 S0=0<cr>
12-11-2005 22:35:17.444 - Recv: <cr><lf>OK<cr><lf>
12-11-2005 22:35:17.444 - Interpreted response: OK
12-11-2005 22:35:17.454 - Send: ATS7=60 +DS=0,0,512,20 +IFC=0,0<cr>
12-11-2005 22:35:17.654 - Recv: <cr><lf>OK<cr><lf>
12-11-2005 22:35:17.654 - Interpreted response: OK
12-11-2005 22:35:17.654 - Setting Digital Link Protocol.
12-11-2005 22:35:17.664 - Send: AT+CGDCONT=1,,"internet"<cr>
12-11-2005 22:35:17.804 - Recv: <cr><lf>OK<cr><lf>
12-11-2005 22:35:17.804 - Interpreted response: OK
12-11-2005 22:35:17.814 - Send: AT+CBST=7,0,1;+CGQREQ=1,,,,,;+CGQMIN=1,,,,,<cr>
12-11-2005 22:35:18.025 - Recv: <cr><lf>OK<cr><lf>
12-11-2005 22:35:18.025 - Interpreted response: OK
12-11-2005 22:35:18.025 - Dialing.
12-11-2005 22:35:18.035 - Send: ATD*###<cr>
12-11-2005 22:35:18.245 - Recv: <cr><lf>CONNECT<cr><lf>
12-11-2005 22:35:18.245 - Interpreted response: Connect
12-11-2005 22:35:18.245 - Receive Connect but CD was low, Waiting for signal to
go high
12-11-2005 22:35:18.265 - CD has been raised
12-11-2005 22:35:18.265 - Connection established at 115200bps.
12-11-2005 22:35:18.265 - Error-control off or unknown.
12-11-2005 22:35:18.265 - Data compression off or unknown.
12-11-2005 22:35:48.268 - Read: Total: 670, Per/Sec: 20, Written: Total: 4470, Per/Sec: 144
12-11-2005 22:35:50.181 - Hanging up the modem.
12-11-2005 22:35:50.191 - Hardware hangup by lowering DTR.
12-11-2005 22:35:51.733 - Detected CD dropped from lowering DTR
12-11-2005 22:35:51.733 - Recv: <cr><lf>NO CARRIER<cr><lf>
12-11-2005 22:35:51.733 - Interpreted response: No Carrier
12-11-2005 22:35:51.743 - Send: ATH<cr>



This is /etc/ppp/peers/cosmote (cosmote is my cellphone carrier):
CODE
/dev/ircomm0
115200
nocrtscts
local
connect '/usr/sbin/chat -s -v -f /etc/ppp/chat-cosmote'
noipdefault
user "user"
usepeerdns
defaultroute
remotename cosmote
nodetach
lcp-echo-failure 10000
lcp-echo-interval 1000
lcp-max-configure 3
novj
novjccomp
noauth


and this is my chat script:

CODE
TIMEOUT 15
ABORT 'BUSY'
ABORT 'NO ANSWER'
ABORT 'RING'
ABORT 'NO CARRIER'
'' 'AT'
OK 'AT V1 E0 &D2 &C1 S0=0'
OK 'AT+CGDCONT=1,"IP","internet"'
OK 'ATS0=0'
#OK 'at+crlp=61,61,48,6,0,3'
OK 'AT'
OK 'ATS7=60 +DS=0,0,512,20 +IFC=0,0'
OK 'ATD*99#'
CONNECT ''


I have tried variations that I found on the net but the result is the same. In any case the scripts must be good, because ppp works (although as I said earlier only after using the phone once with my windows laptop).

Any ideas on what may the problem be?

I would be grateful for any answers/pointers (it's driving me crazy!).
5 Oct 2005
Hello everybody

I've posted this problem already on another thread, but I think it was probably the wrong one
(and it was too old) so I post again.

I tried to compile Stellarium, an application that needs opengl and sdl.
I used the cross-compiling sdk for rc11 and the program compiled fine.

However, when I try to run it on the my C750 I get the message:

sdl: Couldn't set 640x480 video mode (X11 driver not configured with OpenGL), retrying with stencil size 0
sdl: Couldn't set 640x480 video mode: X11 driver not configured with OpenGL!

(the message is the same for resolution 320x240).

glxinfo however reports that openGL is enabled and glxgears runs (although at a mere 17 fps).
I have also the "mesa3d" package installed.

You can find the ipk I made at stellarium_0.7.1_armv5tel.ipk if you want to have a try at it (it is a little heavy, 16MB, i didn't strip the constellation art and stuff...)

I would be really grateful for any help. Stellarium is a really cool "desktop planetarium" app, with a very beautiful rendition of the night sky (as seen from any point on earth).

Thanks for any pointers,
-grigoris
28 Jun 2005
Hello

Is there a package for offlineimap? It is not in the feeds but maybe someone has managed to use it under pdaxrom. For those who don't know, offlineimap [1] is a tool for synchronizing local email folders ("Maildir") with an IMAP server. It is great for reading mail offline with mutt.
If offlineimap is not possible do you know of any other such tool that is available under pdaXrom?

Thanks.

[1] http://gopher.quux.org:70/devel/offlineimap/
26 Apr 2005
Hello everybody

I would like to be able to read / write texts in greek (and also french/german) while using rxvt.
Is there a document describing the necessary steps to accomplish this?
E.g., installing fonts, changing locale settings, installing an applet for changing the keyboard layout etc.
(the bitstream vera fonts included with OZ include greek glyphs but still greek characters show up in rxvt as question marks).
I am using OZ 3.5.3 / GPE.

I would be grateful for any pointers.
Last Visitors


7 Jun 2009 - 16:52


16 Feb 2008 - 8:23

Comments
Other users have left no comments for henrysviper.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 23rd November 2014 - 04:08 PM