OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
Ashitaka doesn't have a personal statement currently.
Personal Info
Ashitaka
32 years old
Gender Not Set
Tokyo
Born Dec-27-1981
Interests
Geek things :P
Statistics
Joined: 7-June 04
Profile Views: 344*
Last Seen: 17th April 2005 - 01:44 PM
Local Time: Nov 1 2014, 11:42 AM
58 posts (0 per day)
Contact Information
AIM Francois LEIBER
Yahoo No Information
ICQ 137433448
MSN fleiber@hotmail.com
Contact Private
* Profile views updated each hour

Ashitaka

Members


Topics
Posts
Comments
Friends
My Content
21 Dec 2004
As some may remember, I was working on porting the streaming application MPEG4IP (mpeg4ip.sf.net) on Zaurus, but I had a few problems. Most of them are now solved, partly because I am using pdaXrom so I could get rid of the 2.95 toolchain.
But the sound problem remains, and I just discovered it was only because of heavy floating point usage inside the MP3 decoder, which makes it horribly slow (85 ms to decode a 36 ms frame, with only a 16kHz / 1 channel / 16 kbits MP3 file). To have an idea of the source you can look at filter.cpp

The first thing is that I am quite surprised I did not see much speed difference when switching to pdaXrom, which should have this Vector Floating Point stuff to make things faster. Am I missing something?

The second is, does someone have any recommendations about integrating another decoder, if ever I have to do it? Or someone who is willing to help?
8 Dec 2004
Is there somewhere a status update about kernel 2.6 for Zaurus?
I know some people in OpenZaurus are working on it, it still seems active since patches continue to be applied, but after spending some time looking for information I have no clue what is the current status.
If I remember correctly there was problems with some binary-only drivers, for SD card amongst others, has it been solved?
The project in which I work (http://www.nautilus6.org) is very interested by what we could do with 2.6 on Zaurus, that's why I ask smile.gif


I also have contacts with people working in Sharp, on the Zaurus or not, and I just asked them if there was a chance Sharp was working on it or not, waiting for their answers...
19 Aug 2004
For those who don't know, it is a streaming solution, only based on open standards, namely MP4, RTP and RTSP, etc. It is presently the standard for people investigating streaming solutions or deploying free solutions. More info on mpeg4ip.sf.net.

I just succeeded into cross-compiling this application for the Zaurus :
- RTP/RTSP streaming works perfectly.
- the video of the demonstration video from Darwin Streaming Server works fine.
- sound is half-working.

But some problems still remain:
- I don't know what is the modifier corresponding to the "Fn" key on the Zaurus (sadly it is not KMOD_CTRL). This is only a minor problem.
- The sound "jumps back in time constantly", which means every second is played several times before moving to the next. According to the developper of MPEG4IP:
QUOTE
as to why it's not working, I'd be looking at the SDL code. It could be a number of things, from not supporting that frequency or not supporting that channel combination, or not supporting that buffer size.

I know some persons had the same sound problems, and that some modification has been done to SDL_audio or SDL_mixer, I would be very (but really very) grateful if you could help me on that point, it is really the most annoying problem sad.gif
- My home-made videos do not work, or only the mixed-up sound.

So, if anybody is interested in this program or has any clue about my problems, please smile.gif
30 Jul 2004
As it seemed to solve many problems, I installed dev_img-1.5 on my Zaurus.
But as you can see on the 7th line of the autogen.sh log, probably due to the fact that all this is mounted, m4 called by aclocal throws an error about "no space left on device".
Does anyone know how to get round this problem ? Thanks !

QUOTE
$ ./autogen.sh
Generating build information using aclocal, automake and autoconf
This may take a while ...
acinclude.m4:5: warning: underquoted definition of COPY_ARCH_SRC
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automak...nding%20aclocal
acinclude.m4:34: warning: underquoted definition of AM_PATH_ESD
configure.in:49: /mnt/dev/bin/m4: ERROR: Copying inserted file: No space left on device
autom4te: /mnt/dev/bin/m4 failed with exit status: 1
aclocal: autom4te failed with exit status: 1
configure.in: no proper invocation of AM_INIT_AUTOMAKE was found.
configure.in: You should verify that configure.in invokes AM_INIT_AUTOMAKE,
configure.in: that aclocal.m4 is present in the top-level directory,
configure.in: and that aclocal.m4 was recently regenerated (using aclocal).
src/Makefile.am:19: Libtool library used but `LIBTOOL' is undefined
src/Makefile.am:19:
src/Makefile.am:19: The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
src/Makefile.am:19: to `configure.in' and run `aclocal' and `autoconf' again.
/home/zaurus/automake/share/automake-1.8/am/depend2.am: am__fastdepCC does not appear in AM_CONDITIONAL
/home/zaurus/automake/share/automake-1.8/am/depend2.am: AMDEP does not appear in AM_CONDITIONAL
...
...
...


By the way, the 49th line of the configure.in file is :
QUOTE
AM_PROG_LIBTOOL
2 Jul 2004
Whooo, I finally finished gathering everything needed for a complete cross-compilation environment for the Zaurus, including a set of useful libraries, and writing the scripts to get everything turning.

Just get it on http://www.nautilus6.org/operation/zaurus.html (the second link).

QUOTE
This script will install a complete cross-compiling environment for ARM/Qtopia PDAs.
I use it for Zaurus C750/C760/C860, but it should also work for SL-5xxx and SL-6xxx.
The cross_install-2.95.3.sh script will install:

  - GCC 2.95.3 cross-compilation toolchain
  - libz, precompiled libuuid and libjpeg, X11 development files
  - Qt/X11 2.3.2, Qt/Embedded 2.3.7, Qtopia 1.6.2 and tmake 1.11

The libraries_install.sh script will install:

  - libpng, libogg, libvorbis
  - SDL 1.2.6 for Zaurus by zports.sf.net
  - SDL_image 1.2.3 and SDL_mixer 1.2.5

The Examples/examples-zaurus.sh will install

  - "Hello World!" classic
  - SDL demo
  - Qtopia official example


I would be very happy to have some feedback if ever you use it!
Last Visitors


19 Feb 2009 - 5:51


9 Oct 2008 - 4:39

Comments
Other users have left no comments for Ashitaka.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 31st October 2014 - 06:42 PM