OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
fsjws4 doesn't have a personal statement currently.
Personal Info
fsjws4
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 21-July 04
Profile Views: 69*
Last Seen: 15th November 2004 - 10:38 AM
Local Time: Nov 25 2014, 08:56 PM
17 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

fsjws4

Members


Topics
Posts
Comments
Friends
My Content
26 Oct 2004
I'm about to order one of these, thought I'd pass along the deal:

http://www.buy.com/retail/product.asp?sku=...0495&dcaid=1688
26 Oct 2004
As I mentioned in another thread, I'm trying to get Frotz (and some of my other favorite apps) working in OZ. I don't have a linux box, so I have to cross-compile from a Cygwin environment on Windows. I haven't done this before, so I'm trying to get to a state where I know everything's set up right and works properly, then figure out what I need to do to get the new apps working.

I'm sure there's someone out there who could easily compile this for me, but I'm using this as a learning experience as much as anything else. I want some fishing lessons, so to speak.

So far, I've followed the instructions here: http://takahr.dhis.portside.net/cgi-bin/rw...+on+Cygwin%3Aen

Before I try to compile something that doesn't necessarily work, I want to compile something that should already work. This way I can verify that my setup is correct. So I got source for a random app from the software index. I chose "zuc", a unit converter. (for those playing along at home: http://prdownloads.sourceforge.net/zuc/zuc-1.1.tar.gz)

Here's where I'm stuck. I ran the environment setup script from the cross-compile page. I did a 'make' from the zuc directory, and it gave a few warnings, but seemed to work. I'm left with a 'zuc' file, among other compilation results. I put the binary on the Z and tried running it from the shell. I get this error:

./zuc: symbol lookup error: ./zuc: undefined symbol: _7QString.shared_null

So I must have missed something. I'm thinking:
* There's some other library that I need to install on the Z
* There's a support file that I need to copy along with just 'zuc'
* Some of those compile warnings were serious enough to break the app
* Something isn't set up right in my build environment

Could someone give me a push in the right direction?

Incidentally, I think a HOWTO on cross-compiling would be of great help. Especially if it used an existing app and walked through step-by-step how to set up the environment, build, and package it. I'd be happy to write something like this, once I get to that point...
21 Oct 2004
I'm trying to get Frotz to work on OZ 3.5.1. The existing package installs OK if I ignore the dependency on "terminal", but won't run because I don't have libncurses.so.4.

I poked around and saw that there was a libncurses.so.5. I thought I'd be clever and copy this as version 4. Surely the new version does everything the old one did, and more.

That got me closer -- I can see the usage screen now, but opening a .z5 file gives me an error like this:

CODE
root@collie:/mnt/ram/home/QtPalmtop/bin# ./frotz /mnt/cf/if/slouch.z5
./frotz: symbol lookup error: ./frotz: undefined symbol: __divsi3


So I figure I have two options -- recompile Frotz to use the newer ncurses, or get a real copy of the older ncurses. What should I do?
19 Oct 2004
Install 3.5.1, they told me. It's better, they said...

Finally got SSH working on OZ 3.3.5, so I decided to upgrade to 3.5.1. Got all the bits and pieces and flashed it. Indeed, it's much nicer-looking. But when I plugged into the cradle, I didn't get the familiar boo-beep from XP.

ifconfig on the Z didn't show any IP address, and ipconfig on XP didn't show the connection as being up. So I went to Network on the Z, saw that DHCP was on, and manually entered the IP info I was using successfully before (the standard .201 IP address, etc). Pulled out and back in the cradle. Nothing. Tried the "Start" button: "Starting interface failed". Rebooted the Z while in the cradle. Still nothing. Tried enabling the connection from the XP side. Nope.

I searched the forums, and found some messages advising to use "ifup usbd0". Tried that, and got a few lines of "No such device":

CODE
SIOCSIFADDR: No such device
SIOCSIFNETMASK: No such device
SIOCGIFFLAGS: No such device
route: SIOC[ADD|DEL]RT: No such device


Also saw mention of just "usb0", and tried that too:

CODE
ifup: Ignoring unknown interface usb0


So I must be missing something -- what do I do to get the USB network enabled again?
14 Oct 2004
I recently installed OZ 3.3.5 on my 5500 (because I couldn't find 3.5.1). I'm trying to FTP into it now. I can ping it when it's in the cradle, but FTP connections fail:

Connected to 192.168.129.201.
Connection closed by remote host.

I assume there's some config change I need to make somewhere, but I don't know where/what that might be. What do I do?
Last Visitors
fsjws4 has no visitors to display.

Comments
Other users have left no comments for fsjws4.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 25th November 2014 - 12:56 PM