OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
Zar2Cool doesn't have a personal statement currently.
Personal Info
Zar2Cool
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 29-September 04
Profile Views: 333*
Last Seen: 15th December 2004 - 09:55 AM
Local Time: Oct 1 2014, 04:00 AM
11 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

Zar2Cool

Members


Topics
Posts
Comments
Friends
My Content
29 Sep 2004
Hello to everyone.

I am trying to install Apache/Perl/Mysql on my Zaurus. I write a lot of perl scripts that work with mysql and it would be handly to test stuff on the Zaurus. Speaking of, it's a 5600 with 1GB SD and Sharp 3.00 rom (I really should upgrade the rom, but I don't want to blast everything away.)

Ya, I know it's going to be slow and all that, but I am doing this more to just see if I can.

Apache, mySQL, and Perl 5.8 installed fine. It's the Perl DBI module that I am having problems with.
In order to build it, I need make. I downloaded dev_img and tried to install it, but I got this error.

CODE
# ./image_setup.sh /mnt/card/devel/dev_img-1.5 /mnt/dev
Setting mount point /mnt/dev...
Mounting image /mnt/card/devel/dev_img-1.5...
Failed to mount image /mnt/card/devel/dev_img-1.5 on /mnt/dev
#

It does mount the image fine, but seems to fail seting up the symlinks.
I tried to set them up by hand and I think it's right. Least the config script is happy.

I downloaded the Perl DBI source and did.
Perl Makefile.pl

and it was happy. I edited the makefile to point to the correct location of gcc and ran make, but I get this error.

CODE
cp lib/DBI/DBD.pm blib/lib/DBI/DBD.pm
cp lib/DBI/ProxyServer.pm blib/lib/DBI/ProxyServer.pm
cp lib/Win32/DBIODBC.pm blib/lib/Win32/DBIODBC.pm
cp dbi_sql.h blib/arch/auto/DBI/dbi_sql.h
cp lib/DBD/ExampleP.pm blib/lib/DBD/ExampleP.pm
cp lib/DBI/PurePerl.pm blib/lib/DBI/PurePerl.pm
cp lib/DBI/ProfileData.pm blib/lib/DBI/ProfileData.pm
/home/system/var/mnt/dev/usr/bin/perl5.8.0 -p -e "s/~DRIVER~/Perl/g" ./Driver.xst > Perl.xsi
/home/system/var/mnt/dev/usr/bin/perl5.8.0 /mnt/pkgs/perl/perl5.8.0/lib/5.8.0/ExtUtils/xsubpp  -typemap /mnt/pkgs/perl/perl5.8.0/lib/5.8.0/ExtUtils/typemap -typemap typemap  Perl.xs > Perl.xsc && mv Perl.xsc Perl.c
/mnt/dev/bin/gcc -c   -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O3   -DVERSION=\"1.43\" -DXS_VERSION=\"1.43\" -fpic "-I/mnt/pkgs/perl/perl5.8.0/lib/5.8.0/linux/CORE"  -Wall -Wno-comment -DDBI_NO_THREADS Perl.c
gcc: installation problem, cannot exec `as': No such file or directory
make: *** [Perl.o] Error 1


I have not had this problem when installing on X86 systems, so I am assuming that it is something that I need to change for arm CPU support.

Can anyone offer any tips or pointers on how to debug this?

Thank you
-Eddie
Last Visitors


24 Nov 2007 - 14:41

Comments
Other users have left no comments for Zar2Cool.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 30th September 2014 - 08:00 PM