OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
hatchetman doesn't have a personal statement currently.
Personal Info
hatchetman
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 3-November 04
Profile Views: 809*
Last Seen: 10th February 2011 - 02:43 AM
Local Time: Nov 23 2014, 11:01 AM
60 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

hatchetman

Members


Topics
Posts
Comments
Friends
My Content
15 May 2006
I've installed OZ GPE image 3.5.4, build 2006-03-14. I've installed all the relevent python packages for the program I am trying to run.
CODE
matt@tosa:/media/cf/Downloads/straw-0.26/src$ ipkg list_installed | grep python
libpython2.4-1.0 - 2.4.2-ml4 -
python-codecs - 2.4.2-ml2 -
python-core - 2.4.2-ml2 -
python-crypt - 2.4.2-ml1 -
python-datetime - 2.4.2-ml1 -
python-distutils - 2.4.2-ml2 -
python-io - 2.4.2-ml2 -
python-lang - 2.4.2-ml1 -
python-logging - 2.4.2-ml1 -
python-math - 2.4.2-ml1 -
python-mime - 2.4.2-ml2 -
python-netclient - 2.4.2-ml2 -
python-pygtk2 - 2.6.2-r2 -
python-pysqlite2 - 2.0.2-ml0 -
python-pyxml - 0.8.3-r0 -
python-re - 2.4.2-ml2 -
python-shell - 2.4.2-ml1 -
python-stringold - 2.4.2-ml2 -
python-textutils - 2.4.2-ml1 -
python-xml - 2.4.2-ml1 -


I have tried several python gtk programs with no success. The one I most desire is straw, an RSS reader. I can run python setup.py build, and it succeeds. When I try to straw I get:
CODE
matt@tosa:/media/cf/Downloads/straw-0.26/src$ ./straw
Traceback (most recent call last):
 File "./straw", line 150, in ?
   main()
 File "./straw", line 137, in main
   run(options)
 File "./straw", line 107, in run
   from straw import Application, Config
ImportError: No module named straw

and on line 107 you see:
CODE
   if ENV_IN_SOURCE:
       from lib import Application, Config
   else:
       from straw import Application, Config


Now I'm pretty certain my immediate problem is that my evironment paths are all wrong. To get this far I had to set PYTHONHOME=/usr/ and I sometimes need to sys.path.append("/folder/"); to add libraries to the search path. This all seems very hackish, and I'm hoping theirs a more appropriate way to fix things so that the imports work.

Can someone help me get my environment set up correctly, and does anyone have any success stories with other PyGTK applications?
14 Jan 2005
Would there be any benefit to 6000 users to merge the patch for the 6000 (found on ezaurus.com) to the linux kernel, instead of the C860 patch?
10 Jan 2005
Most of my attempts to upload to the forums come back with 'That document contains no data' errors. I'm wondering if the problem is it contains too much data, I had no problem with a small text documents or pictures. I couldn't upload a tar.gz or .png that were >500k, maybe it's me? Anyone else have trouble?
10 Jan 2005
Hoorah New England. We had some kick ass northern lights in the area a month or two ago. Found a nice picture taken from the area online and I use it for my background on the Zaurus.
Attached File(s)
Attached File  Hore.jpg ( 74.4K ) Number of downloads: 2
 
5 Jan 2005
Has anyone run the latest X/Qt on the Opie/OZ ROM? The X/Qt server that can be built through OE runs okay, but it's version 0.9 and trying to get fonts to work correctly is a nightmare. I can run the latest X/Qt server using the compat libs, but it won't detect the Qt server and so needs to be started as a server itself. That just leaves me with a flickering opie and an X server that doesn't accept any input.

I've tried to compile X/Qt-2 myself, but I can't get by the ./build DevWorld step. Has anyone compiled this successfully (for anything, not specifically Opie), and can maybe outline a few steps needed to get started?
Last Visitors


19 May 2008 - 0:30

Comments
Other users have left no comments for hatchetman.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 23rd November 2014 - 03:01 AM