OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
jeffbarish doesn't have a personal statement currently.
Personal Info
jeffbarish
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 24-November 04
Profile Views: 288*
Last Seen: 14th September 2005 - 03:03 PM
Local Time: Oct 26 2014, 01:04 AM
25 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

jeffbarish

Members


Topics
Posts
Comments
Friends
My Content
8 Apr 2005
I found some information here about how to install an application in Qtopia, but I can't get it to work. It's possible that I misinterpreted some of the directions that I found, so I thought that perhaps someone could point to my error if I carefully describe what I did.

1. I put my app (myapp.py) in /home/QtPalmtop/bin (which is in my path).

2. I made myapp.py executable. The first line is

#! /usr/bin/env python

The line that calls QPEApplication is:

app = QPEApplication(['myapp.py'])

I do:

from qtpe import QPEApplication

3. I created a file in /home/QtPalmtop/apps/Applications called myapp.desktop. It contains the lines

[Desktop Entry]
Comment=What my program does
Exec=myapp.py
Type=Application
Name=MyApp

4. I rebooted

An icon appears on the Applications page. When I click on it, it changes to the clicked icon and I see an hourglass. Then the hourglass disappears and my app does not run. I presume that it crashed. When I run it from a command prompt (by typing myapp.py), it runs fine. I hope that someone can see what I did wrong -- or can at least suggest a diagnostic procedure. For example, does Qtopia log error messages somewhere? Is there a way to capture error messages emitted during program startup? Thanks.
7 Apr 2005
The version of Qt included in the kopsis package is 2.3.2. The current version is 3. I am trying to get a multithreaded PyQt application to work, but it seems that support in 2.3.2 for what I need to do (involving custom events) is deficient. Would it be possible for kopsis to release a new python image with a current version of Qt? Would it work for me simply to replace the Qt libraries (qt.so, qtcanvas.so, qtnetwork.so, qtpe.so, qttable.so) and perhaps also pyqtconfig.py in the ext2 image? If so, where do I find the necessary files?

Another approach might be to switch to the Python for arm feed, but people seem to be having trouble getting it to work on the Sharp ROM. In any case, I don't know that it includes a current version of Qt.
21 Mar 2005
What program are people using for screen capture? I found ScreenShotApplet, but the link takes me to a web page that does not exist.
19 Mar 2005
I would like to mount my Zaurus on my linux desktop. I use the command

mount -t smbfs //192.168.129.201/home/zaurus /mnt/zaurus

and get the message

Error connecting to 192.168.129.201 (Connection refused)
6225: Connection to 192.168.129.201 failed
SMB connection failed

I suspect that I have to modify a file on the Zaurus identifying my linux desktop so that the smb server knows to permit the mount, but I can't find such a file. I found /home/root/usr/lib/samba/smb.conf, but I don't see anything relevant in there.
13 Mar 2005
I developed a Python application on my Linux desktop that I would now like to move to my Zaurus SL-6000L. I have almost no experience using the Zaurus, so I'm having very basic troubles. I have a copy of what I believe was the Riverbank Computing Python package (called python_2.3.3-1.0_arm.ipk). I move it from my Linux machine onto a CF and then insert the CF in my Zaurus. Under files, I select the CF. The ipk appears on the list. Selecting it launches Package Installer. I hit the Install button at the bottom and exit the app when told to. I'm pretty sure that it's installed because when I select Uninstall packages, it shows up there. So now what? There's no icon for running Python. To convince myself that I was using the right procedure for installing packages, I tried downloading another application. An icon appeared that launches the application. Another posting here mentions a Python image from kopsis, but I find nothing at their web site. If that's a better package to use, how do I get a copy?
Last Visitors
jeffbarish has no visitors to display.

Comments
Other users have left no comments for jeffbarish.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 25th October 2014 - 05:04 PM