OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
RobbH doesn't have a personal statement currently.
Personal Info
RobbH
Age Unknown
Gender Not Set
Georgia, USA
Birthday Unknown
Interests
No Information
Statistics
Joined: 11-January 05
Profile Views: 348*
Last Seen: 8th May 2007 - 06:55 PM
Local Time: Nov 26 2014, 10:09 AM
38 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

RobbH

Members


Topics
Posts
Comments
Friends
My Content
27 Jun 2006
Not sure if this is the right place to ask this. It has to do with Meanie's pdaXqtrom package, but not when using its X server. It might be C1000 specific, or it might be general. But I think it's more likely to be specific to the Sharp roms and descendants, like Cacko.

It doesn't help that I'm a Linux neophyte, and I don't necessarily know the right language to use in describing the problem. So I hope you will be patient with me.

I use a program that requires some libraries that are part of the pdaXqtrom, but it does not require the X server to be running. The program is Blassic, a BASIC interpreter, which runs from the console. Until recently, I simply ran it from within Midnight Commander, but as of today, I can no longer do so.

I find that the problem is that the interpreter can no longer be run by root. As installed in Cacko, mc is started by a sudo command. Attempting to start the interpreter from mc produces the following error:

"error while loading shared libraries: libSM.so.6: cannot load shared object file: No such file or directory"

This is the same error that was displayed when I first tried to use the interpreter, without the pdaXqtrom packages installed.

However, if I run the interpreter from a QKonsole session, without sudo or su, it runs without complaint.

I find the library in question (as well as some other pdaXqtrom files) is owned by Zaurus, and while execute and read permissions are universal, only the owner has write permission. Giving write permission to group and others did not seem to change anything, though.

I see how to get around the problem, but I do not understand what might have happened to cause it. Can anyone offer any suggestions or shed any light? I would like to have a better understanding of what's happening.

(By the way, I realize that some may find the use of a BASIC interpreter on the Zaurus at least undesirable and maybe even offensive. I bow to you and beg your indulgence. I have no illusion of being a "real programmer" in BASIC. But I do find it useful for certain things I want to do.)

Edit: updated description.
7 Jun 2006
I had the less than brilliant idea of installing the old, minimal Terminal on my C1000 with Cacko. I thought it might be nice to have a lightweight console handy. Wrong!

I knew I had made a mistake, as soon as I saw that the Konsole icon had gone missing. When Midnight Commader wouldn't start, I knew it was a serious mistake.

I've tried QKonsole and Embedded Konsole, but so far neither is an adequate replacement for the version of Konsole that came with Cacko. Neither fonts nor keymappings are right, especially in Midnight Commander.

I see there have been some problems reported that Japanese language support may interfere with Konsole and MC. I don't think that's my problem, unless Japenese fonts were installed with Terminal, and not removed by the uninstallation process.

Just when I was beginning to feel good about my success in stumbling around with Linux, I find I'm completely stymied. Short of reflashing Cacko, or going to a Nand backup, is there anyway to restore the Cacko konsole?

Any suggestions appreciated!
24 Jan 2005
I've searched the forums, I've read the how-to doc, and I've tried to make sense of online Japanese-English translations of the author's site and a detailed tutorial. I'm still lost! If anyone can offer any guidance with Keyhelper, it would be appreciated.

A relatively simple question first. The specifications for the "modifiers" section of the keyhelper.xml fille include a "release key" tag. What is this? Do these keys generate a keyup code that's different from the keydown code? Or am I overlooking some other, obvious meaning?

Now for my tough question: does Keyhelper have the capability to respond to a sequence of keypresses by sending a different sequence of codes to the target application? In case that's as unclear as I think it is, I'll try to explain.

What I have in mind is some form of intelligent capitalization. Enter a space followed by a doublet of a given letter, and the result would be a space followed by a single instance of the same letter in upper case. (It is possible to do this with the Custom Input applet, fwiw.) Period-space-letter would yield period-space-capitol letter. Return-letter would produce return-capitol.

I don't see indication that Keyhelper can process or produce sequences of keys, but I hope I've just overlooked or misinterpreted the docs. Can anyone enlighten me?

Edit: As you may have guessed, "Nepbie" is supposed to be "Newbie". I wish I could blame Keyhelper for that, but I don't think anyone would believe it.
Last Visitors


23 Jul 2009 - 7:48


22 Sep 2008 - 3:45

Comments
Other users have left no comments for RobbH.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 26th November 2014 - 02:09 AM