OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
sojourner doesn't have a personal statement currently.
Personal Info
sojourner
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 30-March 05
Profile Views: 156*
Last Seen: 24th September 2006 - 02:33 PM
Local Time: Sep 17 2014, 03:33 AM
13 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

sojourner

Members


Topics
Posts
Comments
Friends
My Content
4 Apr 2006
Just flashed to Opie 3.5.4 using the 32-32 zImage on my collie and everything looks great with the exception of WPA-PSK CCMP on my Ambicom WL1100C.

I'm using the same wpa_supplicant.conf I used under 3.5.3 with no problems. I wrestled with it for a few hours and flashed back to 3.5.3 just to see if I missed something but after flashing and immediately starting up the wpa_supplicant in debug mode (hostap) it connected up with no issues. I did not need to make any changes under 3.5.3.

Flashed back to 3.5.4 and still no go. Disabling encryption works fine on 3.5.4 with this card but that isn't an option.

Any ideas out there? I've searched high and low to no avail.

Here is what i get from running "wpa_supplicant -Dhostap -iwlan0 -c/etc/wpa_supplicant.conf -dd":

CODE
Priority group 1
  id=0 ssid='lamessid'
wpa_driver_hostap_set_wpa: enabled=1
wpa_driver_hostap_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_hostap_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_hostap_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_hostap_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_hostap_set_countermeasures: enabled=0
wpa_driver_hostap_set_drop_unencrypted: enabled=1

Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b19 len=12
Received 233 bytes of scan results (1 BSSes)
Scan results: 1
Selecting BSS from priority group 1
0: 00:00:00:00:06:22 ssid='lamessid' wpa_ie_len=0 rsn_ie_len=0
  skip - no WPA/RSN IE
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b19 len=12
Received 233 bytes of scan results (1 BSSes)
Scan results: 1
Selecting BSS from priority group 1
0: 00:00:00:00:06:22 ssid='lamessid' wpa_ie_len=0 rsn_ie_len=0
  skip - no WPA/RSN IE
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b19 len=12
Received 233 bytes of scan results (1 BSSes)
Scan results: 1
Selecting BSS from priority group 1
0: 00:00:00:00:06:22 ssid='lamessid' wpa_ie_len=0 rsn_ie_len=0
  skip - no WPA/RSN IE
No suitable AP found.
Setting scan request: 5 sec 0 usec
Signal 2 received - terminating
wpa_driver_hostap_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_hostap_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_hostap_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_hostap_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_hostap_set_wpa: enabled=0
wpa_driver_hostap_set_drop_unencrypted: enabled=0
wpa_driver_hostap_set_countermeasures: enabled=0


Same command and config works under 3.5.3

wpa_supplicant.conf looks like this:

CODE
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
network={
  ssid="lamessid"
  proto=WPA
  psk="somelamepassphrase"
  key_mgmt=WPA-PSK
  pairwise=CCMP
  group=CCMP
  priority=1
}


Regards,

-sojourner
14 Apr 2005
With OZ 3.5.3 (opie) on collie (SL5500) I am seeing a problem similar to this one with Wellenreiter:
wellenreiter II - opie 1.1.4 - oz 3.3.6-pre1

Only it is complaining about WE V16 (for the interface driver) and WE V17 (for Wellenreiter II). I am using the 32-32 zImage and my wireless card is an AmbiCom WL100C-CF (hostap), if that is of any help.

* Wellenreiter from the OpenZaurus 3.5.3 feed: opie-wellenreiter_1.2.0-r0_arm.ipk
* Wellenreiter version number when running: V1.0.3 (unofficial)

Wellenreiter was working rather nicely with 3.5.2; same WiFi, same SL5500. Is this the same problem as the linked post or the same symptom/different problem?

-- sojourner
Last Visitors


8 Mar 2008 - 15:03

Comments
Other users have left no comments for sojourner.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 17th September 2014 - 01:33 AM