OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
Leinadmx doesn't have a personal statement currently.
Personal Info
Leinadmx
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 7-April 05
Profile Views: 336*
Last Seen: 31st July 2007 - 02:53 PM
Local Time: Oct 21 2014, 02:46 AM
52 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

Leinadmx

Members


Topics
Posts
Comments
Friends
My Content
26 Jul 2007
Hi, good day.

Recently I updated my Z to pdaXii13, I have installed the Zkbdd (driver for IR keyboards).

The drivers works in test mode, but when I launch it in normal mode it does not do anything.
I thought that perhaps it was a problem with the Palm driver config file but I tried with the other drivers and I got the same result. Besides I searched on the forums and I found that another user got the same problem with other IR model keyboard.

http://www.oesf.org/forums/index.php?showt...=18662&hl=zkbdd

I will really appreciate any advice about this, I do not know what could be wrong.

Best Regards,
Daniel.

Console output:
CODE
# zkbdd -t palm_3169ww -d
driver_setting_num(description) = Palm 3169WW Universal Wireless Keyboard Driver
driver_setting_num(version) = 0.3
Zkbdd using driver: Palm 3169WW Universal Wireless Keyboard Driver, version 0.3
driver_setting_num(scancode_fn) = 101
driver_setting_num(scancode_punc) = 0
driver_setting_num(scancode_num) = 0
driver_setting_num(scancode_shiftl) = 117
driver_setting_num(scancode_shiftr) = 62
driver_setting_num(scancode_caps) = 63
driver_setting_num(has_num_lock) = 0
driver_setting_num(has_punc_lock) = 0
driver_setting_num(has_fn_lock) = 0
opening /dev/ttyS1
lookup_scancode(map_normal, 0x7b)
keycode: 0x01
press 01
0x00000002
0x00000000
0x00000000
0x00000000
0x00000000
0x00000000
0x00000000
0x00000000
lookup_scancode(map_normal, 0x7b)
keycode: 0x01
release 01
0x00000000
0x00000000
0x00000000
0x00000000
0x00000000
0x00000000
0x00000000
0x00000000
zkbdd shutting down
#
16 Apr 2007
Hi, good day wink.gif

It seems that Sharp still remembers the Zaurus, they release new models of their "e-dictionnaries", but just for Korea:

http://www.akihabaranews.com/en/news-13642...s+by+Sharp.html

I would like to know the specs of this producs, maybe Sharp backs to Zaurus someday.

Best Regards.

By the way someone knows where I could find information about how to build a motherboard, last night I was thinking "mmm Why should we wait till some corporation release a real Zaurus succesor??, I know, build one by oneself must be expensive, but could be possible", so what do you think??
9 Apr 2007
Hi, good day.

A "few" weeks ago I tried to compile POSE (Palm OS Emulator) for Zaurus (using pdaXrom Beta3).
Old posts:
http://www.oesf.org/forums/index.php?showtopic=23251&hl=

I did the best I could, the binary works, but when I try to load the Palm ROM I get a error message. I have attached a screenshot.

I do not know what I could do to fix it, any adivice will be appreciated.

By the way, to compile POSE, it must be done on the Zaurus because it requieres FLUID which is compiled and used on the fly when you compile POSE.

I apply a couple of patches to make it works, if anybody want try I can upload the patches.

Thanks a lot.
Best Regards.
Attached File(s)
Attached File  pose_bug.png ( 175.26K ) Number of downloads: 242
 
14 Feb 2007
Hi, good Day.

A few weeks ago I wrote a post here about compile Palm OS Emulator (POSE) for Z, I got an answer by "plcg", thanks!:
http://www.oesf.org/forums/index.php?showtopic=22899

Well, the second part of the history is that I could not compile it, there are different ways to do it, but no one works, summary reasons:

1) POSE needs FLTK, it works on Z, but the problem is that POSE also needs the FLTK's UI builder, called FLUID, without it there is no way to compile it.

2) The FLTK version as .ipk (1.1.4) do not include FLUID, so it is necessary to compile from source, the problem here is that just one version of FLTK compile with FLUID on Zaurus, it is the fltk-1.1.7 version, I tried with the other version and fail, mainly due to FLUID.

3) Besides There is no way (well I do not know a way to do it) to use a cross compiler to create the .ipk on a PC, mainly because FLUID needs to be executed when you run "make", but if you do that on a PC the binary cannnot be executed sad.gif so the package "must be compiled on Z".
(I tried it using the /opt/cross/arm/3.4.6-xscale-softvfp-akita/ cross compiler method)

4) Well, once I got the FLTK working with FLUID on Z(version 1.1.7), next step si compile POSE, ups! the problem is the memory (I think), if you run "make" running X, you will got a compiler error, but if you close the X session and run "make" from console mode the compiler works better but finally it falls, it describes a gcc error, so I think that it needs more memory to compile it.

Well those are my conclusion, maybe I am doing something wrong, Any advice of you will be really apreciated, I would like to build a POSE package to share, because I think that there are really useful Palm's apps that could be used on Z.

Thanks a lot.
Best Regards.
17 Jan 2007
Hi, good day.

I am trying to compile POSE (PalmOS Emulator) for pdaXrom, I download the source of pose and install the FLTK from this feed: http://www.pdaxrom.org/contrib/2or0/

When I try to configure it to make it, I got this:
#pwd
/mn/linux/src/Emulator_src_3.5/BuildUnix
#./configure --prefix /mnt/linux
...
checking for 'int fl_height (void)' in -lfltk ... no
configure: error: *** FLTK *must* be installed before running configure. ***
#

But I already installed FLTK, I do not know if I am missing something, any advice?
I am doing this because I could not find any IPK of POSE.
By the way, I am doing that on a C3100 running pdaxrom 1.3

Thanks a lot for your help.
Best Regards.
Last Visitors


16 Jun 2009 - 23:43


31 Oct 2007 - 17:07

Comments
Other users have left no comments for Leinadmx.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 21st October 2014 - 12:46 AM