OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
Zal42 doesn't have a personal statement currently.
Personal Info
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
No Information
Joined: 7-June 05
Profile Views: 409*
Last Seen: 31st January 2006 - 09:49 AM
Local Time: Jun 22 2018, 03:31 PM
15 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour



My Content
23 Dec 2005
I was having strange intermittent problems when using my Zarus with 802.11. It would mostly work, but sometimes communications apps would hang when trying to talk.

The nastiest problem was that I couldn't use TLS with my mailserver -- when I tried, opiemail would hang during the TLS handshake.

The problem turned out to be my access point (I use a Linksys BEF-W11). The access point would sometimes send frames that were too large to fit into the frame size the Z was expecting (1504 bytes, when they should have been 1500). I discovered this when I ran the "dmesg" command on the Z after opiemail hung, so if you suspect something similar is happening, take a look there.

My solution was to add a line to the /etc/network/interfaces file, in the iface wlan0 stanza:

iface wlan0 inet dhcp
       # blah blah blah configuration stuff here

       up ifconfig wlan0 mtu 1508   # This is the line I added

This changes the size of the frame the Z expects to 1508. Shouldn't have to do it. It's not the Z's fault. But it makes everything work.
21 Dec 2005
I think this has been the behavior in prior OZ releases as well, but I've forgotten.

When I have the power cord plugged in and the Zaurus is suspended, the battry light stays on even after the battery is fully charged. With other ROMs, the battery light will turn off when the battery is done charging in this circumstance.

I'm worried that perhaps the battery really is continuing to charge for too long in this situation. Does anyone know if this is a valid concern? Should I take the Z out of the cradle when I've gone to bed for the night?

I'm running OZ3.5.4-RC1 on an SL-6000.
20 Dec 2005
Since I can't do without connection profiles for my wifi networking, I came up with a stopgap solution for use while waiting until Opie's Network app does the right thing. Perhaps other people will find it useful too. Here it is.

I'm running OZ3.5.4-RC1 on tosa, but this should work regardless of the platform. It uses opie-sh to provide the GUI, so if you haven't installed it (and why haven't you? It's an excellent tool to slap quickie GUIs onto your shell scripts), then do an "ipkg install opie-sh" before you start.

Step One

Create a file in /opt/QtPalmtop/bin named "wlanchooser.sh", and make it executable:

touch /opt/QtPalmtop/bin/wlanchooser.sh
chmod +x /opt/QtPalmtop/bin/wlanchooser.sh

Edit the file and paste in this script:



# ---- Code begins

wlanstat=`ifconfig wlan0 2> /dev/null`
if [ "x$wlanstat" = "x" ]; then
  command=`echo "$WLANLIST" | $OPIE_SH -g -i -t "Activate which profile?" -l 2>/dev/null`
  if [ "x$command" != "x" ]; then
     cp $DBASEDIR/$command $NETDIR/interfaces
     ifup wlan0 | $OPIE_SH -t "${OURNAME} Results" -f
  $OPIE_SH -m -t "$OURNAME" -M "Shall I disconnect the WLAN?" -g
  if [ "$command" = "0" ]; then
     ifdown wlan0

rm -f /tmp/qcop-msg-wlanchooser.sh

Step Two

Create a file in /opt/QtPalmtop/apps/Opie-SH/ named "wlanchooser.desktop":

touch /opt/QtPalmtop/apps/Opie-SH/wlanchooser.desktop

Edit the file and paste this in:

[Desktop Entry]
Name=WLAN Chooser
Comment=Choose between wlan configurations

Step Three

Make a new subdirectory:

mkdir /etc/network/wlanlib

Step Four

Copy your existing interface script to the directory, with a new name, such as:

cp /etc/network/interfaces /etc/network/wlanlib/Roaming

That's about it. When you run the chooser, you'll get a list of all the files in /etc/network/wlanlib/ and when you pick one, it will get copied over the top of /etc/network/interfaces. So, create a whole new interfaces file for each different "profile" you want, and save it to /etc/network/wlanlib/ with some descriptive name.

If you run the Chooser when your wlan0 interface is active, you'll get a confirmation box. Confirm and the wlan0 interface will be brought down. (Cancel by tapping on the little 'x'. I really should add a proper button, I guess.)

It's crude, but it works well enough for me. I have three files in wlanlib, named "Roaming", "Home", and "Office".
Last Visitors

4 Dec 2007 - 14:09

Other users have left no comments for Zal42.

There are no friends to display.
RSS Lo-Fi Version Time is now: 22nd June 2018 - 02:31 PM