OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
Raybot doesn't have a personal statement currently.
Personal Info
Raybot
Age Unknown
Gender Not Set
Sydney
Birthday Unknown
Interests
No Information
Statistics
Joined: 25-July 05
Profile Views: 101*
Last Seen: 18th July 2006 - 06:10 AM
Local Time: Aug 28 2014, 09:18 AM
21 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

Raybot

Members


Topics
Posts
Comments
Friends
My Content
13 Oct 2005
Hi all!

It looks like my Zaurus will start doing double duty as a robot controller pretty soon (especially since I stumbled across Jonathan's USB serial drivers so I can actually talk to the robot's MCU now)!

The problem is the webcam. I've read various posts about webcams working/not working on this forum and getting horribly confused (you need to compile V4L, drivers don't exist, etc).

The strongest lead I have so far is Meanie's website, http://www.users.on.net/~hluc/myZaurus/custom.html#webcam and his usb-modules ipkg. I'm especially keen on this as the webcam in question (AFAIK) works with the standard PWC driver, a version of which is present in that package but when I install it then run "depmod -a", I get the following errors:

CODE
# depmod -a
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/dsbr100.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/ibmcam.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/ov511.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/pwc.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/se401.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/stv680.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/ultracam.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/vicam.o


I suspect this has something to do with me missing "videodev.o" especially as it seems to be the webcam drivers that have failed but I can't find it on my filesystem anywhere and I can't find this file anywhere on "official" websites (certainly none of the bigger Zaurus websites and forums that I've tried) ... the only reference I can find to this file through google that seems vaguely zaurus'y is http://www.paipai.org/~humorum/zaurus/modu...rs/media/video/ ... but I'm a little wary of trying it out as all the documentation for that website is in Japanese so I've got no idea if it's for a specific kernel or the like (and Bablefish doesn't seem to like it).

Anyone got any ideas? Meanie, got a moment to shed some light on this perhaps please? biggrin.gif


- Raymond
30 Jul 2005
Hi all!

My headlong rush into insanity driven by this deceptively innocent looking piece of electronic hardware continues unabated.

I'm trying to get networking working. I'm running the default Sharp ROM with the c3000-custom-jaen_0.1_arm.ipk English addon. I've got a Planex GW-CF11X. It all works fine and dandy. As long as the wireless network I'm connected to can get out to the Internet. If it can't it works for maybe 20 seconds (pings work, SSH works, etc.) but then some little watchdog in the Network Setup application realizes it can't ping some host out there on the Internet (haven't figured out which host yet) and, thinking something is wrong, cuts the internet connection.

I've been able to test this very easily - I just set up a network connection on an isolated wireless LAN but set my laptop to share its internet connection across the wireless LAN. When sharing is enabled, the network app is happy and the connection works (blue/green square connection icon). The moment I drop the uplink (but remember, both the Zaurus and laptop are still connected to the wireless LAN) and disconnect then reconnect the Zaurus, the connection stays up for a few seconds (the time it normally takes for the connection icon to turn from a world to a square PDA symbol) for it to fall apart.

Anyone got any ideas as to how to stop the Network application trying to ping out (and/or cutting the network if it finds it can't)? All I want to be able to do is connect via wireless LAN to an internal network (and *sometimes* to the Internet). I guess finding out which host it's trying to get a response from would be a start (at least that way I might be able to spoof it in the hosts file so it looks back at itself) ...


- Raybot
27 Jul 2005
Hi all!

I sense I'm hitting my head against walls that others have hit before ... I find references here and there on this list (and other sites) but I'm not able to find much in the way of answers. One of the big reasons I had for getting the Zaurus was the belief that I could take my email on the road (without having to boot up my laptop - a huge Dell Inspiron 9300). Unfortunately, everywhere I look I get headaches ... can anyone shed any light on any of these?

QTMail (default mailer):
Tried using this initially ... until I realized it doesn't do SSL (the servers I connect to use IMAP over SSL and SMTP over SSL). Rules this one out straight away unfortunately.

Thunderbird:
My first preference - I use this on my full sized laptop for my IMAP accounts (alongside Eudora for my POP accounts) ... jumped through various hoops to get it working, finally got it working ... only to find that it's too darn slow. I can handle it taking a minute or 2 to start up (I just won't shut it down) but taking ages to change views between emails, from recieve to send and so-on (because of X/Qt) just makes it too hard to use (the time taken to check and reply to email is about the same as it takes for me to take out my big laptop, find somewhere to put it and do the same thing!).

OM/Pi:
Looked promising but it still seems to take ages to do anything (and doesn't actually tell you if it's doing something or if it's just crashed). Also doesn't seem to be able to (easily) just go online, grab all new mail then pop offline again for perusal later (like you can with Thunderbird). I could be wrong - can someone more familiar with this point me in the right direction (preferrably to some documentation on how to use it - I still haven't found any yet!)?

Pine:
An old favorite of mine ... managed to get it working (lost about half an hour fighting a corrupt version of libncurses though). Until I realized that the Zaurus doesn't have sendmail. Or does it? I haven't been able to find anything but then again I hear people on the list using Pine and Mutt (see below) ... has anyone gotten SendMail working?

Mutt:
A friend's favorite ... I figure I can't be a well rounded Linux person if I wasn't familiar with both Pine and Mutt ... but same problem - it seems to rely on SendMail.


So there we go. Just a simple task - the ability to log into an SSL-IMAP server, grab email, go offline, read/reply to mails, pop back online then send them (via SSL-SMTP). You'd think it'd be dead easy ... but I've had no luck so far.

Anyone got any hints or pointers? Or is it really this hard?


- Raybot
26 Jul 2005
OK looks like I'm not having much luck getting anything semi-complicated working on my Zaurus :-(

This time I tried Pocket Workstation. I downloaded http://www.chuckster.org/zaurus/zaurus-deb...-v18-b01.tar.gz and http://www.chuckster.org/zaurus/xqt-debian-install.zip and ran the install script. It all seemed to go OK except for the following errors:

===============
/bin/ln: `/home/root/.icewm': File exists
Debian files extracted.
ln: /etc/rc5.d/S50mnt: No such file or directory
ln: /etc/rc6.d/K50mnt: No such file or directory
===============

I notice that rc5.d and rc6.d are in fact in /etc/rc.d/rc[5|6].d so I manually made the symlinks to /etc/rc.d/init.d/mntloop .

However, wherever I look the debian executable doesn't exist! When I try to execute startd, it can't find icewm-session (and can't unmount /proc - operation not permitted, that's probably a side effect of something else). Anyone got any ideas?

Given all these problems I've been having getting pre-packaged things working (which I presume are pretty standard things), what are the chances my original install is a bit weird? (This IS a secondhand Zaurus - purchased from Sofmap, I presume they already did the factory reset though.) What might be the most painless way of returning the whole lot (ROM and HDD) to the factory-shipped state so I can start fresh (before I've got too much stuff installed)?


- Raybot
25 Jul 2005
Hi all!

I've just brought home a shiny new C3000 ... and have been fighting Debian ever since :-(

The first thing I wanted to do was get Thunderbird working ... I installed the jumbo GTK-X11 pack as per http://www.users.on.net/~hluc/myZaurus/jumbo/xqtjumbo.html and things seemed OK ... I installed Gimp and it worked (although editing 5 megapixel images didn't really work very well in the limited 64MB RAM!), xterms worked, Firefox worked, things looked groovy.

Then I installed Thunderbird. And whenever I try to run it, it gives me the error:

CODE
/usr/lib/thunderbird-0.6/thunderbird-bin: error while loading shared libraries: libstdc++.so.5: cannot load shared object file: No such file or directory


I'm running the default, stock Sharp ROM. I've tried all sorts of things, from installing versions of libstdc++ from the various OpenZaurus feeds (doing the "ar -x <package>" then re-tar.gz'ing as necessary) to uninstalling and reinstalling all sorts of things to no avail. Except every now and again, it gives me another bizzare error, instead of missing libstdc++.so.5, it complains about a missing libgtk-x11-2.0.so.0 (which I've checked does actually exist in /opt/QtPalmtop/lib). Generally this happens when I try to run thunderbird as root (but even THEN not always).

I'm tearing my hair out (and hence adding to the headache)! I've been trawling these forums (and a pile of other websites) for the last 4 hours with no success (on that note, is it just me or does highlighting in this forum break if you have more than 1 search term?). Can anyone shed any light on this? DOES Thunderbird work with the standard ROM?


I've also been trying to get SSL working (to open the possibility of using ompi) but that opens yet another can of worms relating to, for instance, the fact that /lib is read-only (and various dependancies seem to want to write new versions there). Anyone got any hints for that one?


- Raybot
Last Visitors
Raybot has no visitors to display.

Comments
Other users have left no comments for Raybot.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 27th August 2014 - 05:18 PM