OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
gregarican doesn't have a personal statement currently.
Personal Info
gregarican
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 4-August 05
Profile Views: 444*
Last Seen: 14th July 2006 - 09:44 AM
Local Time: Jul 22 2014, 05:17 AM
24 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

gregarican

Members


Topics
Posts
Comments
Friends
My Content
3 Jan 2006
Happy New Year everyone! After trying out Ruby and Squeak Smalltalk with varying success on the Zaurus I am looking to try some Python coding. I have installed Python 2.2.2 on my SL-5500 along with various Python modules and the Python 0.8 IDE. All of these were installed from IPK files.

I was looking to try some XMLRPC calls and noticed that the Python implementation is missing xmlrpclib. Is there an IPK floating around out there somewhere that I could install? I do have zgcc 2.95 on a CF card and could try to compile one myself. But if there was an IPK file I could definitely save some time.

Anyone know of such a thing?
1 Nov 2005
I run Sharp 3.10 ROM on my SL-5500. My old Linksys WCF12 wifi card works okay but now I tried a new Linksys WCF54G wifi card. The Sharp ROM doesn't recognize it. There are a couple of apps I developed that are standardized to run on the Sharp 3.10 ROM. Does anyone know of a patch I can apply or some tweak I can perform to get the ROM to recognize my new wifi card?
3 Oct 2005
I have a QPEApplication object created as a Ruby script. The object and its various children's objects, methods, etc. work fine. There is a suspect area. I have a series of push buttons that launch various documents various using Hancom Word. The code that I have to accomplish the actual launching is similar to:
CODE
system("qcop QPE/Application/HancomMobileWord 'setDocument(QString)' '/path/to/myDocument.doc'")

The Ruby system() method that wraps the qcop call simply launches a sub-shell that loads up Hancom Word set to a particular document. The problem is when I close Hancom Word the QPEApplication object disappears. When I check the active processes I see that my Ruby script is running but I can't seem to recover the GUI app I created. If I try to issue something like:
CODE
qcop QPE/Application/myGUIApp 'setDocument()'

there is a brand new instance of the GUI app I have. The original one still doesn't appear. Or if I try:
CODE
qcop QPE/Application/myGUIApp 'raise()'

nothing happens.

Since my Ruby script doesn't have anything displayed on the task bar I can't figure out a way to bring it back after exiting Hancom Word. Any suggestions?
30 Sep 2005
I have an SL-5500 running Sharp ROM 3.10 and am looking for a way to run a script as root when the PDA finshes loading Qtopia. Here's the basic idea of the script:

#!/bin/sh

/usr/sbin/smbd -D
/usr/sbin/nmbd -D
/usr/bin/smbmount //server_box/share1 /mnt/share1 -o username=user%pass
/usr/bin/smbmount //server_box/share2 /mnt/share2 -o username=user%pass

I tried symlinking /etc/rc.d/rc.local to /etc/rc.d/rc5.d/S49local but this didn't get the job done. Since the Zaurus runs as the zaurus user and not the root use I am having problems running the script unless I connect in and su as the root user.

Figuring sudo would be a thing to try I installed the ipk for it but before I could even verify and configure the /etc/sudoers file the root user account got messed up.

So here I am back at a restore point where I am trying to get this script to launch as Qtopia is loaded up. What's the easiest way to do this?
26 Aug 2005
I am not looking for an IM client that would connect to things like Yahoo!, AOL, etc. What I am wondering if there is an IPK available for something that would allow me to send LAN text messages between PC and Zaurus clients. Something similar to Windows Messenger. Nothing fancy like a continuous IM interface. Just quick pop-up text boxes.

Anyone know if such a thing is available? If not then I will look to whip up something using my basic Ruby/Qt skillset rolleyes.gif
Last Visitors
gregarican has no visitors to display.

Comments
Other users have left no comments for gregarican.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 22nd July 2014 - 01:17 AM