OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
elessar doesn't have a personal statement currently.
Personal Info
elessar
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 19-September 05
Profile Views: 203*
Last Seen: 23rd November 2005 - 08:04 PM
Local Time: Oct 25 2014, 10:16 AM
13 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

elessar

Members


Topics
Posts
Comments
Friends
My Content
5 Oct 2005
I have a Planex GW-CF11X card which is apparantly a prism card and so it should work. I found a linux driver for it, but I am unsure how to proceed with openbsd. Init fails in reading the hardware address.

I have two SD cards, one is a Canon SDC-16M and the other is Panasonic RP-SD0646. Plugging both of these in has no effect. No message, no dmesg, no nothing.

I bought a Netgear MA111 v1 because OpenBSD specifically listed it as being supported. This seems to be detected correctly by the kernel. However, running ifconfig causes a kernel panic and drops me into the kernel debugger.

The kernel debugger is very useful and I ran trace and ps like instructed. Capturing the debug output can be done as described here [1]. I read the FAQ[2] and this[3] document. It seemed to me that copying the output by hand would be a faster more reliable method. It occurs to me now that using the infrared serial device this could be done with the Zaurus.

I finally have OpenBSD installed, however this PDA is useless without the internet...I would very much appreciate some help. I am thinking of sending my dmesg output to the developers. But I am not sure I have a problem here that isn't simply my own fault or ignorance of OpenBSD.

My dmesg (attached) reflects where I plugged and unplugged the Ipod and the Netgear. I tried using script to capture the panic...but that didn't work.

I typed out the output of the panic, and the output of trace by hand and attached that as well.
I also attached a list of programs that were running (minmized output of the PS command).

I am running OpenBSD 3.8 GENERIC and have taken no other action on this system.

Any help or comments would be greatly appreciated. Should I go to the developers? Please don't suggest that I go and buy something else...that is not a good solution to my mind and it is an obvious last resort. Please DO point out my own errors if you see them.

Thank you.

[1]http://www.netbsd.org/Documentation/kernel/kgdb.html
[2]http://www.openbsd.org/faq/faq7.html#SerCon
[3]http://www.netbsd.org/Documentation/kernel/#debugging_a_kernel_crash_dump

Attached File  dmesg.txt ( 3.06K ) Number of downloads: 33

Attached File  trace.txt ( 909bytes ) Number of downloads: 31

Attached File  ps.txt ( 152bytes ) Number of downloads: 30
22 Sep 2005
I have a Zaurus 3000 and after investigating the different options I decided to go with OpenBSD. I like trying new Operating Systems and learning new things and I like reading good documentation. I have had a lot of good experience with FreeBSD in this way.

Installing OpenBSD allows you to easily dual boot between Linux and OpenBSD. When you see the boot> console I either just press <enter> or <r + enter> depending on which one I need.

I installed OpenBSD 3.7 and came across the following problems. I have been lurking around the forums for a few days now looking to see if anyone else has had these problems and I thought it strange that I would be the only one. To be thorough I am including the problems I had which I have already read about here in the OpenBSD forum (namely 1 and 4).

1.) The install document, while accurate, takes a few reads to get through. I think it would be no problem for someone well versed in OpenBSD, but for me I had the impression it was a doc copied from the generic instruction with some info added about the Zaurus. I plan to write my own install doc at some point, and will post it here when I do. Anyway, installing was no problem.

2.) During the install process and every time I boot, the console is stuck in vertical mode. This is not only annoying by a bit of a pain in the neck (literally). I am a fan of the console, especially when I want to read man pages and administer my system properly after setting things up.

3.) I have a CF wireless card which was not supported. It gets detected, and I have a driver in .ipk format which I unzipped. I think my lack of knowledge would the reason for this one. However the lack of an internet connection is a major handicap and I feel castrated and unable to progress any further. I barely even use BSD on the Zaurus and probably won't till I get networking setup.

4.) I bought a USB cable and keyboard. This works just fine but after unplugging the keyboard the Zaurus won't sleep unless I take out the battery. It just automatically keeps coming on. In addition, as soon as I try to make it sleep the USB host is no longer detected making me reboot if I want to plug in a different device. This does not happen with Lineo.

5.) Bought a Netgear MA111 version 1 wireless adapter. This has the effect of either not being detect at all, or when I run ifconfig it freezes and drops me into a strange prompt telling me to run trace and ps. I am currently investigating this problem and reading the appropriate man pages.

Notes:
I am impressed with OpenBSD (even if I don't sound like it smile.gif) and from what I've read it will really make the Zaurus a fully functional machine which I am excited about. However, the way I want to use my PDA is quickly and efficiently. I don't want to edit a config file every time I rotate the screen. I don't want to reboot every time I unplug my keyboard and want an internet connection. These issues quickly overshadow the coolness of having a PDA that fits in your pocket. I am strong believer that if you do your homework, invest some time and some patience, the thing should just work exactly as you configured it to. My goal is to be able to whip it out, look up a Japanese word, type my notes, surf the web, check my email and pop it back into my pocket during the 10 minute break I get everyday.

I've gotten quite frustrated and the other day I went back to look at the options for the 3000 - the Cacko, OpenZaurus or keeping the Sharp and upgrading the kernel. But I'm convinced that a lot of my problems are simply due to my not being familiar with OpenBSD yet. As such, I plan to install the beta 3.8 version. Perusing Barry G's site has also been very helpful and I plan to read it in more detail. What does Mabuhay mean by the way? Is it Phillipino for "Good Day!”

Been a Linux user for a long time, and I'm ready for a change. Reading the forums here it seems that the USB problems and sleep problem are fixed in 3.8. The rest should be fine once I learn a bit more about OpenBSD. Just wanted to add my experience to the fray.
Last Visitors
elessar has no visitors to display.

Comments
Other users have left no comments for elessar.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 25th October 2014 - 10:16 AM