OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
sam3k doesn't have a personal statement currently.
Personal Info
sam3k
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 7-March 06
Profile Views: 237*
Last Seen: 2nd March 2008 - 10:29 AM
Local Time: Sep 20 2014, 02:03 PM
1 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

sam3k

Members


Topics
Posts
Comments
Friends
My Content
8 Mar 2006
Not really sure what forum this belongs on, but I do know that a lot of people want to use Zaurus for Japanese study, but also want to use it as an English PDA. There are numerous methods for getting both English and Japanese applications running on the same PDA, but here (I think) is a new one.

Normally you have to set your language in locale.conf, and that's system wide. However you can also set it per application.

For example:

If you have a Zaurus set to 'en' language (but have the Japanese fonts installed) you can type
CODE
LANG=ja textedit
in Konsole / Terminal and have the text edit application load up in Japanese.

Conversely if you have your system language set to ja, you can type
CODE
LANG=en textedit
to start textedit in English.

Now, the only drawback is that input methods take their language from the system setting, this isn't a problem for the Japanese keyboards they work with both 'en' or 'ja'. Unfortunately CRIM requires the system language to be set to 'ja'.

In order to get the Launcher to start an application with a different language it is necessary to create a shell script (does anyone know of a better way to do this), for example:

textedit-en.sh in /home/QtPalmtop/bin
CODE
#!/bin/sh
LANG=en textedit

(don't forget to chmod +x it)

Now duplicate /home/QtPalmtop/apps/Pim/textedit.desktop to textedit-en.desktop (or wherever your textedit.desktop file is) and change the exec line to textedit-en.sh and the name to something appropriate (e.g. Textedit-en). Don't forget to reboot Qtopia.

So there you have it, per application language settings. Hope this is of use.

Any questions?
Last Visitors
sam3k has no visitors to display.

Comments
Other users have left no comments for sam3k.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 20th September 2014 - 06:03 AM