OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
VT-Zuser doesn't have a personal statement currently.
Personal Info
VT-Zuser
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 1-May 06
Profile Views: 377*
Last Seen: 11th August 2006 - 10:03 PM
Local Time: Sep 22 2014, 05:16 AM
4 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

VT-Zuser

Members


Topics
Posts
Comments
Friends
My Content
1 May 2006
Help! My C750 went toes-up today, and I'm suffering information overload after spending the past evening scouring the net to figure out if it's recoverable.

I have a ~3-year-old SL-C750, purchased through dynamism.com, still running the original Sharp ROM. I know, loading a better ROM was on my list of things to do, but having kids threw off my plans.

Anyway, it's worked great so far. For the past several months, the scroll-wheel has been acting up. It acts like the spring on the top has come loose--there's no resistance to keep the wheel from moving up towards the power button. Moving it down still encounters a push-back that returns it to center. It wouldn't boot if the wheel wasn't centered, so I simply got in the habit of lightly holding the wheel in the right position when turning it on. Oddly enough, the problem was somewhat intermittent. Occasionally, for no apparent reason, the top 'spring' (or whatever is in there) would work again for some period of time.

For the past several days, the email light has been blinking, even when there was no calendar alarm up. After puzzling over that, I just ignored it.

Battery charging seems to have been working fine. I usually plug the PDA into the (original) charger each evening when I come home, but it's usually good for several days even if I don't. This weekend it wasn't plugged in, but last night it was.

When I got to work this morning and opened it up, there was a calendar alert for a morning workout as expected. However, the display didn't switch from landscape to portrait as expected when I folded the screen back. Flipping the display up and back down also didn't change the display. At this point, I tried cancelling the alert--no effect. Likewise, I couldn't pull up the menu or any other application, even though several were running.

After waiting several minutes in hopes it would 'wake up' and getting no response, I resorted to my usual solution when the Zaurus is obstinate: pull the battery and let it sit for a few minutes. This time, however, it wouldn't boot back up when I restored the battery.

I've tried just about everything I could think of--holding ON while pressing power to get the ROM menu elicited not a flicker. The D+M service menu wouldn't come up. After quite a while of surfing, I found reference to the Fn+D+M menu, which DID come up. I've run through the various diagnostic test items there, most of which come up fine. Two areas that problems are reported include NAND and battery.

On page 2/3, item 5, "Low Battery" reports the Main Battery Status as "L" and shows 4.1V. Since the battery is labelled 3.7V, that doesn't seem low. However, selecting "6. Batt Voltage Adjust" and then choosing "2. Battery Voltage Check" tells me it's 2.8V, which would be low.

The NAND Flash (Full) check shows no errors. "NAND Flash (SUM) Checksum reports "Can not read sum area". "NAND Bad Count" reports no bad blocks, but then says "ERROR No Partition Info code=(610)"

Trying to set "Normal Diagnostic Mode" says
Flag = Diag Mode
Writing ...fail!!!

I've taken the opportunity to do a NAND Flash Back Up, and I have found what appear to be Virgin C760 NAND image.

At this point, I have three questions:

1. Is there anything else I can do to diagnose and/or repair without the drastic step of reflashing the NAND image?

2. Will reflashing the NAND image even help? At least one of the many threads I read implied there may be something wrong with the internal power circuitry now, which won't allow anything BUT the Fn-D-M service menu to even load.

3. Is there any way I can get in to extract a file (my master password file) from the current image before I wipe this?

HELP, PLEASE!
Last Visitors
VT-Zuser has no visitors to display.

Comments
Other users have left no comments for VT-Zuser.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 22nd September 2014 - 04:16 AM