OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
ian.finder doesn't have a personal statement currently.
Personal Info
ian.finder
24 years old
Gender Not Set
Chicago, IL
Born June-4-1990
Interests
Photography, IT & Computer Science, Politics (leftist, mostly), Nature, Math, Science.
Statistics
Joined: 18-May 06
Profile Views: 548*
Last Seen: 13th August 2008 - 10:33 PM
Local Time: Dec 20 2014, 02:50 PM
14 posts (0 per day)
Contact Information
AIM toxiclemon90
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

ian.finder

Members


Topics
Posts
Comments
Friends
My Content
29 Aug 2006
So, here I am, trying to get anything from ettercap-ng to tcpdump working. Tried the libpcap in the feed, no luck. Built libpcap and related packages from source on the Z (C1k), still no luck. When I build ettercap-ng from the source, it doesn't run properly. TCPdump can't sniff promisc. regardless of whether I use the libpcap from the feed, or my own build. (I have a fairly robust native build environment on the Z-- at least I hope) The ettercap from the feed is also fairly useless when it comes to actually sniffing. This problem occurs regardless of whether I'm using my wifi card (prism2.5, hostap) or USB ethernet adapter (asix). Manually running ifconfig <interface> promisc has no noticeable effect either.

I was hoping to equip this Z as an all-out network audit toolkit (nmap, tcpdump, aircrack, void11, kismet, ettercap-ng, metasploit, nessus, dsniff, tcpick, ethereal, etc.) but at this point I can't even get the basics running.

Am I an idiot or is there something up here-- I'm not new to Linux, (or other *NIX-like OSes) but I haven't looked too far into these tools before, so maybe I'm pointing fingers at the wrong library...

Anyone have ideas?
(could this be an issue with libnet? I've tried the feed version and my own builds as well)

Thanks--

Ian

UPDATE: tcpdump seems to work correctly now [just tested it with the wifi, is it possible the asix drivers still won't do promiscuious-- I haven't tested it yet], but ettercap from the feed is still 95% ineffective, as is the version I built. I guess this means the problem lies in a different library... I'm just confused now wink.gif
1 Jul 2006
So, my akita hangs every time I run oz GPE or OPIE from my SD card(s), regardless of whether the install is direct or an image file. The last thing it gets to is Starting PCMCIA, then it hangs. I tried a complete flash erase, restore of factory image, and reinstall of OZ and the ROOTFS images to no avail. When I disable the PCMCIA script in init, it hangs on something else.

I'm starting to wonder if this isn't a hardware issue with my Akita mad.gif

Anyone got ideas?

Thanks.

P.S.: Already searched the forums, google, and the OZ wikis to no avail.

EDIT: It was some wacky SD card issue. Switched to an old 1gb, had to re-do the home flash partition stuff too, but now all's good hopefully.
22 May 2006
So, I was playing around in the D+M menu on my "new" used "less than 10 hours" sl-c1000 from ebay (yes, I have my doubts-- for other reasons as well) mad.gif
and I ran the NAND Bad Count from the sum menu. I got the result you see attached (that line of interest is "8 4 0 4" if you can't see-- block 8, 4 init, 0 after, 4 total bad blocks)

Anyhow, the ominous large, red ascii "NG!" is concerning me-- should it be?

Thanks in advance--

[ EDIT - I just realized I should have put this in the hardware section. Sorry! huh.gif ]

Ian

P.S.: As a new member, and someone who's beginning to love these Sharps (replaced my debian-powered libretto 50ct), I hope to more active on these forums in the future, and once I get familiar with the platform, I hope to contribute to development. (Installing the cross-compilers now on my desktop). Either way, I was very happy to find this site, as it seems to be an invaluable resource!
Attached File(s)
Attached File  Picture_12.png ( 73.57K ) Number of downloads: 100
 
Last Visitors


27 Dec 2007 - 22:41

Comments
Other users have left no comments for ian.finder.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 20th December 2014 - 12:50 PM