Help - Search - Members - Calendar
Full Version: Irk-zaurus
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
Mahoro
My targus keyboard just arrived......
But it won't work in my OZ 3.5.2, the option only have Belkin and Pockettop only...
The Targus is eliminated.
I tried the IRK in the http://angela1.data-uncertain.co.uk/~zaurus/download.php
It said it had Targus support, but it won't work in OZ 3.5.2... mad.gif
sad.gif
Is there any way to solve the problem...I don't want to change back to 3.3.5 sad.gif
Can someone compile one for me ohmy.gif

blink.gif

Mahoro
hatchetman
I don't even know what IRK is, but here's the ipk from the OpenZaurus 3.5.2 feed

http://www.openzaurus.org/official/unstabl...11.1-r1_arm.ipk

If you're ever looking for some package, try the feeds first and you might get lucky. Hope it works!
Mahoro
Yeap, I tried that...but it only had Berlkin and Pocketop keyboard....
They eliminated the Targus keyboard in the option...it used to be in the option in 0.11 version, but they changed to Berlkin in 0.11.1r1 sad.gif
MrSquishy
Have you tried Craigs IRK 0.11?
Not the 0.11.1.

0.11 should have Targus support.
0.11.1 was modified for Pocketop/Belkin.

http://angela1.data-uncertain.co.uk/~zaurus/


No clue if this works in 3.5.2.
Wish I could help more.
Mahoro
Yeap I tried, I even used the ozcompat library for that....but got no luck... sad.gif
MrSquishy
Have you tried bitbaking the old sources, or begging one of the people who can actually make packages to roll it for you?

I for one still dont know how to compile something with BitBake that isnt already setup as a bb file.
Mahoro
Hummmmm.....I better should... unsure.gif
You mean ask somebody compile it for me?
Yeap, the source are in the website http://angela1.data-uncertain.co.uk/~zaurus/download.php
Too bad I am using Win Xp, which couldn't compile anything...
(Beside, I don't know how to use Linux...except Zaurus I guess... ph34r.gif )
acpkendo
I don't think recompiling is necessary- this sounds like a keymap issue (not as in "proper" keymaps, but as in how irk maps infrared signals to key presses)--you'll notice that if you select Belkin or Pocketop, some key presses show up, but as the wrong letter. This means IRK itself is working, but it is translating the keypresses wrong. I think if you were to put the Targus settings file (I don't remember which it is offhand), that it would work for you. I'll look at the settings in my Z (I'm back to the Sharp ROM right now) if I have a chance today and post the settings.
MrSquishy
So, it is possible that a simple IRK.conf swap would do it?

Or does the libirk.so.1.0.0 need to be replaced as well?

If Im not mistaken (a rarity), all the keymaps are handled by IRK.conf.
Mickeyl
QUOTE(MrSquishy @ Jan 9 2005, 09:51 PM)
0.11 should have Targus support.
0.11.1 was modified for Pocketop/Belkin.

It was modified ??? Bummer dry.gif I thought it had added support for Pocketop/Belkin. I don't think we want to build two irk packages in OpenEmbedded, so I'd welcome a patch that makes both types of keyboards working.
Mahoro
I tried to change the IRK.config file,
Changing it/ copying it from the 0.11 IRK file...but don't work..:/
Seems recompile the 0.11 source is needed :/
cwaig
What's this 0.11.1 version then? Who's released that?
MrSquishy
http://www.oesf.org/forums/inde...?showtopic=8121

Kopsis released 0.11.1 as an alternative for people who have Belkin keyboards.
It replaced the Targus support with Belkin support.

I was suprised to see that it was the version that got picked up for the official 3.5.2 IRK.

Where do we send money/cars/food to to support IRK 2.0?
cwaig
QUOTE(MrSquishy @ Jan 10 2005, 01:10 PM)
Where do we send money/cars/food to to support IRK 2.0?

Sorry, got side tracked doing USB mouse stuff for my shiney new SL6000....
acpkendo
QUOTE(Mahoro @ Jan 10 2005, 12:06 PM)
I tried to change the IRK.config file,
Changing it/ copying it from the 0.11 IRK file...but don't work..:/
Seems recompile the 0.11 source is needed :/

Does the new IRK.conf file have the following lines in it?

CODE
[Targus]
C[0] = 22:#4096
C[1] = 23:#4177
C[2] = 24:#4176
C[3] = 25:#4154
C[4] = 26:#4181
C[5] = 27:*calculator
C[6] = 98:*qtmail
C[7] = 118:#4178
F[0] = 25:*datebook
F[1] = 26:*addressbook
F[2] = 27:*todolist
F[3] = 28:*textedit
Mode = TARGUS
N[0] = 44:2
N[10] = 111:9
N[11] = 112:0
N[12] = 113:1
N[13] = 114:4
N[14] = 116:5
N[15] = 117:7
N[16] = 119:2
N[17] = 121:6
N[1] = 45:/
N[2] = 46:3
N[3] = 59:*
N[4] = 101:3
N[5] = 105:8
N[6] = 106:4
N[7] = 107:5
N[8] = 108:6
N[9] = 109:1
NumCmd = 8
NumFast = 4
NumNum = 18
NumPunct = 22
NumShifted = 21
P[0] = 39:=
P[10] = 106:{
P[11] = 107:}
P[12] = 108:\
P[13] = 111:(
P[14] = 112:)
P[15] = 113:!
P[16] = 114:$
P[17] = 115:~
P[18] = 116:%
P[19] = 117:&
P[1] = 45:+
P[20] = 119:@
P[21] = 121:^
P[2] = 59:|
P[3] = 97:`
P[4] = 100:/
P[5] = 101:#
P[6] = 102:?
P[7] = 103:[
P[8] = 104:]
P[9] = 105:*
S[0] = 39:"
S[10] = 53:%
S[11] = 54:^
S[12] = 55:&
S[13] = 56:*
S[14] = 57:(
S[15] = 59::
S[16] = 61:+
S[17] = 91:{
S[18] = 92:|
S[19] = 93:}
S[1] = 44:<
S[20] = 96:~
S[2] = 45:_
S[3] = 46:>
S[4] = 47:?
S[5] = 48:)
S[6] = 49:!
S[7] = 50:@
S[8] = 51:#
S[9] = 52:$


If not, maybe try cut-and-pasting these into IRK.conf, followed by re-starting Opie.
Mahoro
QUOTE(acpkendo @ Jan 10 2005, 02:55 PM)
QUOTE(Mahoro @ Jan 10 2005, 12:06 PM)
I tried to change the IRK.config file,
Changing it/ copying it from the 0.11 IRK file...but don't work..:/
Seems recompile the 0.11 source is needed :/

Does the new IRK.conf file have the following lines in it?



If not, maybe try cut-and-pasting these into IRK.conf, followed by re-starting Opie.

I copied those into IRK.config
But the keyboard option does not show "Targus":blink:

Even I replace the whole Berkin code w/ targus, is still not working dry.gif
ownnn
Did you try this one?
http://www.openzaurus.org/official/unstabl...11.0-r1_arm.ipk
Mahoro
QUOTE(ownnn @ Jan 11 2005, 02:04 PM)

That's what I am refering to....
It modifcated the package so that it support Berklin and Pocketop IR keyboard, but not Targus anymore. ph34r.gif
MrSquishy
I thought that it was 3.5.2 version as well. But the link is to 3.5.1.

You may want to try the 3.5.1 version as it is the 0.11 version which is Pocketop and Targus.
Mahoro
But what I installed seems to be Pocketop +Targus combo sad.gif
Even @ 0.11.0-r1 unsure.gif
MrSquishy
I take it you mean Pocketop and Belkin @ 0.11

Did you remove the 0.11.1 version as well as /root/Settings/IRK.conf before you installed the 0.11 from 3.5.1?
Mahoro
I had unistalled it and already made sure the files were deleted...
And once again, tried the 0.11.
It still only have the choice of PocketTop+Berklin...sad.gif
I guess I only have 2 solution left:
1. switch back to 3.3.5 which I really don't want to
2. Someone compile it for me......smile.gif
MrSquishy
I just double checked, and 0.11 from the 3.5.1 feed has Pocketop and Targus as the two options.

Something is probably hiding out from the 3.5.2 installation of 0.11.1.

Belkin should NOT be showing up for you if you have 0.11 (correctly) installed.

I could try compiling the old 0.11, but Im sure it is just going to end up an ugly mess and even if I did it right, the one in the 3.5.1 feed seems it would be "pure"er.
Mahoro
I am still havin' problem on it even I got it from 3.5.1 feed...
Might as well you can upload it(the workin' one) to here, rename the extension as .jpg. upload it as jpg smile.gif
and let me download it and try cool.gif
Thanks biggrin.gif
Mahoro
I've checked the IRK.config file in 0.11.0-r, it is Targus...
Wonder why I still have the berkin instead...:/

I guess I try to re-flash the rom and see....... blink.gif
Zaurus really is TIME-Killer mad.gif
Mahoro
Alight, that package won't install in my 3.5.2 ROM...
I flash abt 10 times, and after I install that package, I can't start my OZ!!!!!!!
It just CAN"T GET IT INSTALL !!! sad.gifsad.gif
(No matter in package manager or Command line...) I just end up installed it, reboot, and can't start my OZ AGAIN sad.gif
MrSquishy
I completely spaced that out.
I appologize (a lot) for pushing you towards that.

I do remember hearing about broken IRK on 3.5.1. Didnt come to mind, because I just got a keyboard a couple days ago and hadnt needed it in 3.5.1.

Have you tried the ipk off of http://angela1.data-uncertain.co.uk/~zaurus/ ?
Mahoro
Tried that already, seems itsn't working dry.gif
Guess because the 3.5.2 changed the directory (suppost put in /home, but the changed to /opt) and it uses the old 2.X.X library instead of the new 3.X.X library which the 3.5.2 is using unsure.gif
Mahoro
Finally, PROBLEM SOLVED!!!
THANKS GOD smile.gif

Answer lies here:
http://www.oesf.org/forums/inde...#092;.5\.1
acpkendo
QUOTE
Finally, PROBLEM SOLVED!!!


Mahoro,

How, exactly, was it solved? The thread you posted says to copy /etc/IRK.conf to /root/Settings/IRK.conf. After installing the 3.5.2 package, I already have a /root/settings/IRK.conf. What did you do to make it work, please? And to confirm, this is for the Targus model, right?
Mahoro
I really got it work...
For the installation:
1. terminate the opie (You can do that by going to the shutdown)
2. install the ipkg thr command line ( I use putty thr SSH)
ipkg install -d root /mnt/cf/irk* <- your package
3. ln -s /etc/IRK.conf $HOME/Settings/IRK.conf
4. reboot your Zi.
5. Finish biggrin.gif
acpkendo
Hmmm. . . this is not working for me. I uninstalled and purged all of the old installation, and it went as follows:

1) Terminated Opie
2) ipkg remove irk
3) deleted /etc/IRK.conf, /root/Settings/IRK.conf, /opt/QtPalmtop.compat/bin/libirk.so.1.0.0, and /opt/QtPalmtop/plugins/inputmethods/libirk* (its now as if I never installed it)
4) ipkg install irk (went fine)
5) ln -s /etc/IRK.conf /root/Settings/IRK.conf (also fine)
6) reboot

At this point, IRK/Targus shows up as its supposed to, but won't accept any input. Does lircd need to be running? Also, I recall that irk needs to use oz-compat?

Thanks for you help. . .
Mahoro
So it show up? unsure.gif
Hum.....did you turn the targus to the "on"

Weird....
I just get it work after installation.... happy.gif
acpkendo
Yes, I did turn it to "on." Can you confirm that you did NOT use the oz-compat libs? installation of irk depends on oz-compat, I find it strange that it would work without using them. In any case, I started from a fresh flashing of OZ, but still no luck.
Mahoro
Yeap I didn't use compact library.
Are you sure you downloaded the 3.5.1 feed's IRK one...
I am just a noob anyway...:/
(Zaurus is my first and only linux machine I ever have...probably in the future.)
acpkendo
Hmmm. . . that's very odd that mine doesn't work. Oh well, I guess I'll have to wait and hope that when IRK 2.0 comes out that someone will compile it specifically for OZ. I'm glad it works for you, anyway. Thanks again. . .
Srono
Does anyone have irk version that supports PalmOne IR keyboard?
When i used sharp rom, this bakkeo's package worked perfectly: http://www.geocities.jp/bakkeo2004/irk-zau....1f_arm.ipk.bin. Now i am using OpenZaurus (3.5.3) but i cannot use the bakkeo package anymore. I installed the irk package from OZ feed (latest) but it has support for Targus and PocketTop only. I tried to copy the IRK.conf from bakkeo package, it shows PalmOne keyboard on the keyboard list but i cannot type anything. I don't know why.
Can anyone here enlighten me? I do not want to flash back to Sharp Rom because of this keyboard sad.gif
Thank you very much!
Hrw
those IRK variants suxx...

someone took upstream version, removed something and added something instead, then someone_else did the same with other keyboard..

so we have:
IRK upstream
IRK umbaumba
IRK bumcyk
IRK tymtyrymtym
IRK acobytymrazem

etc... each one incompatible with other, each one cannot be installed with other version but noone fixed segfault when there is not $HOME/Settings/IRK.conf

screw you irk modders

and small info for users - look at kbdd and add your wireless keyboard into it - so it will work in ANY enviroment (not only under OPIE).

And one more thing - that variant of IRK is probably easy to build using OE but don't ask me to do it.
Srono
Thank you, Hrw smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.