Help - Search - Members - Calendar
Full Version: Sl-5500 And Kingmax 1gb 60x Secure Digital (sd)
OESF Forums > General Forums > General Discussion
Droopdude
I recently purchased a KingMax 1GB 60X Secure Digital (SD) Card for my SL-5500.
I can partition, format, read and write this card in my card reader with no problems, but I am unable to use this card with my SL-5500.

I have partitioned and formated the card as:

Type 04 + DOS
Type 06 + DOS
Type 0B + VFAT -F 32
Type 83 + E2FS

I have tried each of these with the Sharp V3 rom, tkcRom, and OZ3.5.2 with mixed results.

Generally speaking the card can me mounted, after a long pause, when it is formated as some form of FAT, but a directory of the card shows garbage, and is unusable. E2FS will not even mount with tcROM or Sharp, but will with OZ. Again it is full of garbage and unusable.

Dmesg show a pile of errors when trying to mount the sd card.

Is this a problem with the 5500 unable to support the newer 60X cards, an incompatiblity with the Kingmax card, or a driver issue?

Short of buying another new card dry.gif, does anyone have any suggestions?

Jim
kahm
I've got a Kingmax Platinum 1gb high speed SD card (purple, only as thick as an MMC card)

I haven't bothered to reformat it - it still has the default single partition, probably fat16

I popped it into my 5000 running OZ - recognizes it and works just fine.
Droopdude
QUOTE(kahm @ Jan 15 2005, 09:23 PM)
I've got a Kingmax Platinum 1gb high speed SD card (purple,  only as thick as an MMC card)

I haven't bothered to reformat it - it still has the default single partition, probably fat16

I popped it into my 5000 running OZ - recognizes it and works just fine.
*



I have the non Platinum version.

I have notice that if I try to create a Linux partition using fdisk on my desktop machine (Gentoo Linux) then it lists 1100 sectors (I am at work) and fdisk with either tckROM or OZ3.5.2, the Z wants to create the partition with 980 sectors. Almost reminds me of the days of win95 and hard drives larger than 528Mb.

If I use no partions on the card, and format it e2fs or fat32, then I can mount it on my desktop, but again not in the Z.

I think this card is completely incompatible with the Z. I have read on another Z forum of other people having similar problems with Kingmax.

Well, time to sell it and go buy a lexar. Too bad these things come sealed in plastic. I can't return it now, as it is not like it is defective. mad.gif

Jim
h4rdc0d3
I haven't tried using any Kingmax cards on my 5600, but Sandisk 1gb SD and CF haven't worked for me. Perhaps the Z has a size limit for expansion cards at 512 MB?
Droopdude
QUOTE(h4rdc0d3 @ Jan 27 2005, 01:08 AM)
I haven't tried using any Kingmax cards on my 5600, but Sandisk 1gb SD and CF haven't worked for me. Perhaps the Z has a size limit for expansion cards at 512 MB?
*



I sold the 1GB SD to a guy with a new digital camera.

I replaced it with a 12x speed Kingston 256MB SD, and then bought a 1GB Kington Elite Pro CF card. All is working fine now.

I have OZ 64-0 (Hentges) installed and it seems fine compared to running any of the 32-0 kernels. The Cacko 64-0 did seem slow though, but I think that might have been a cacko problem.
Omicron
QUOTE(Droopdude @ Jan 26 2005, 08:29 PM)
QUOTE(h4rdc0d3 @ Jan 27 2005, 01:08 AM)
I haven't tried using any Kingmax cards on my 5600, but Sandisk 1gb SD and CF haven't worked for me. Perhaps the Z has a size limit for expansion cards at 512 MB?
*



I sold the 1GB SD to a guy with a new digital camera.

I replaced it with a 12x speed Kingston 256MB SD, and then bought a 1GB Kington Elite Pro CF card. All is working fine now.

I have OZ 64-0 (Hentges) installed and it seems fine compared to running any of the 32-0 kernels. The Cacko 64-0 did seem slow though, but I think that might have been a cacko problem.
*




Gotta say, I used my kingmax 60X card with no problems on a C860 and I think my 5500 as well. But I ALWAYS format from the Zaurus. Formatting from XP is a crapshoot.
tumnus
QUOTE(Omicron @ Jan 31 2005, 09:02 AM)
But I ALWAYS format from the Zaurus.  Formatting from XP is a crapshoot.
*

I agree, Windows doesn't always format the card properly.

I have no problems with my 512MB Kingmaz MMC card on my 5600. There's no point getting a super duper fast SD card anyway as no Zaurus model currently uses the full SD speed.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.