Help - Search - Members - Calendar
Full Version: Can't Mount Samba Shares On My Z
OESF Forums > General Forums > Desktop Operating Systems Issues > Linux Issues
Fraggy
Finally I got my very own SL-5500, which makes me extremely happy... Got some nice stuff working (prBoom, ScummVM, qpdf2, embedded console...) but I can't mount Samba shares mad.gif although I've been fighting with it for a whole day now...

I downloaded and installed smbmount, but the page where I downloaded said I had to install Libncurses5 by remounting the root as rw (mount -o remount,rw /) but alas, no success...

The libncurses5_5.0-6.0potato1_arm.ipk doesn't install correctly (extraction error) and the libncurses_5.0_arm.ipk does only work for user "zaurus", which is of no use, because shares need to be mounted as user "root": as soon as I do a smbmount as superuser, then it starts to complain about missing libraries...

I guess the root filesystem needs indeed to be mounted as "rw" in order to get those libs in the correct location, but it's a cramfs filesystem!!!! These can only be "ro", right???

I got Sharp Rom 3.1 running on my Z... would the Crow ROM solve these problems? I'm thinking about switching over to the crow rom anyway, because due to some severe hangups (double reboot bug, I suppose), I lost all my configs, and since I'm experimenting a lot, this means a lot of reinstalls smile.gif

(I'll switch to the Crow rom or openZ in order to preserve my configs, even after a full reset...)

So can anyone help me out with this samba thing???? Apparently a lot of people got it working, so what am I doing wrong? pls. help

JM.
Jcroto1
Try doing this as root instead of installing libncurses5

CODE
ln -s /lib/libncurses.so.4.2 /usr/lib/libncurses.so.5


Hope it works
Fraggy
... ok I'll try ...
Fraggy
I followed your advise.
Well, there's good news and bad news... The good news is that I don't get any errors anymore... When I issue a smbmount command as root, it returns the prompt without complaining. However... the bad news is that all applications that want to browse the mountpoint immediatly hang... eg "ls /mnt/card/mnt/winshare/" won't return the prompt, and when browsing to that directory using texteditor, texteditor hangs!

I thought this might be because /mnt/card/mnt/winshare/ is a fat partition???? I think the SD Card is fat16 but I'm not sure... But when I mounted it on /home/ the result was the same... btw if I mount as root and try to browse the mountpoint then I get a "Segmentation fault" ... any ideas?
Fraggy
QUOTE(Jcroto1 @ Jan 20 2005, 05:40 PM)
Try doing this as root instead of installing libncurses5

CODE
ln -s /lib/libncurses.so.4.2 /usr/lib/libncurses.so.5


Hope it works
*



Thanks, it works now!!!!
now I have the crow rom installed but what went wrong last time on my Sharp 3.1 rom I think was that I forgot to uninstall libncurses5 so the together with the symbolic link I got this segfault.

So indeed the solution is to NOT install libncurses and to make a symbolic link.

And I do have write access, yeeeha! So finally it's working!!!!

One happy Zaurus user smile.gif

(but now my kismet won't work anymore, but that's for another thread)
Fraggy
It works, but... Where the hell do I mount a windows share in order to be "picked up" by the document browser and other applications????

For example the mediaplayer (and many other apps for that matter) don't allow me to open a user specified directory!!!!

I tried "mpegplayer /path/to/my/mp3file.mp3" and that works, but on a per file basis...

I would have created my mount points on /mnt/card/winshares/ but my SD card is "disabled" since I'm running the crow / Cacko rom now, so...

... so I need to know (the exact path, pls.) where media files are normally stored on the Zaurus (SD is seen as RAM).
Fraggy
Alright, I found out the answer myself!

I put the mountpoint in /home/zaurus/winshare/ and then the Z scans automatically for media files smile.gif

NB: Watch out with the number of files and directories per share, because the Z can take quite some time to scan all directories!!!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.