Help - Search - Members - Calendar
Full Version: Usb Storage Mode Not Working!
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
scoutme
I made one fat partition and one ext2, being fat the first.

I can open the fat partition through a card reader, without problems.

But when I try to connect my zaurus to a pc usb, even if I active the usb storage option, when I try to open the volume I receive a "please insert a disk" message under windows, and something analogue under debian.

Any new bug in RC8? Any hint?

Consider I used USB Storage feature some time ago without problems
scoutme
...?

any suggestion?
scoutme
no usb storage function, neither in RC9

I had it in RC3, maybe in RC5

what happened?
Reaper
I've encountered the same problem as well. The best possible workaround I've found so far is to use CF, not SD. And USB storage won't run at all if your Z is overclocked even a little bit. I've tried it on RC8&9, but it may be true for other releases.
plcg
Hi,

For me, USB storage mode works with windows XP and RC9.1.
It worked with RC5 but not with RC8 and RC9.

Between the tests of RC9 and RC9.1, I've just configured my XP in order to do some ssh stuff.
So here are the properties of the USB connection :
IP Address : 192.168.129.1
Mask : 255.255.255.0
Default gateway : 192.168.129.201

Hope it helps.
plcg
scoutme
I actually solved the problem... I had to replace the cable sad.gif
I had two cables, BOTH not functioning properly

going to receive the replacement from brando

everything works with anoter cable
Leomar
I also had some problems with the usb-storage in RC8.
When I connect my zaurus with the usb-cable to the windows I always get a message to insert a card into the card reader (I always used an sd-card).

I fixed the problem by changing the variable STORAGE_OPTS in the file /usr/bin/usbfunction.
This Variable contains the wrong devicefile for the sd-card (wrong path: "/dev/mmcd0").
To correct the script you only have to change the path to ("/dev/mmcd/disc0/part1").


--------------------------------------
Leomar
zaurus 860, gericom masterpiece
alexei
I fixed the above (changing "/dev/mmcd0" to "/dev/mmcd/disc0/part1"). When I plug in the
zaurus I get "kernel: USB Mass Storage device found at 3" appearing in the syslogs so things are good ... but I get "mount: /dev/sda1 is not a valid block device" errors whenever I try to mount the zauru's SD card as a usb drive. I've tried this for both an msdos and ext2 formatted SD cards with the same result. I can mount a standard usb drive without any problems

Help!!
Leomar
there are some things i have to add to my Post from 2005-2-25

1. This change in the usbfunction.py is only useful if you are using a sd-card.

2. If you mount the zaurus card-reader as usb-storage then it is better to unmount the usb-card on your zaurus. I have allredy lost some data because I had forgotten to unmount.

3. I had some problems mounting the zaurus usb-card-reader at the same time as some other usb-devices.

4. I don't know why, but I couldn't mount the zaurus card-reader as usb-storage with the command:
"mount -t vfat /dev/sda1 /mnt/storage"
So I always used:
"mount -t vfat /dev/sda /mnt/storage"

(I'll hope you excause my poor english)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.