Help - Search - Members - Calendar
Full Version: Damaged C700 Power Inverted
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Cxx0 Hardware
drakecoldwinter
ok, here is the deal, my power adaptor broke, so I got a new one, I putted the good voltage and plugged the c700 in. badly, the power was inverted, the c700 started blinking, now no matter how I plug the c700 it blinks and of course it doesn't boot up at all (no D+M tricks or nothing).

It has no warranty so I have several choices :
- throw it into garbage
- to let my dog have a new toy
- open it and try to repair it

I will choose the 3rd option as my dog has enough toys. I supose that a diode or resistor has been broken by the power inversion, also I believe I am not the only one with this trouble, so could anyone please point me to web pages of people that may have repaired his zaurus after a power inversion ???

thanks a lot

Drake Coldwinter
clofland
Other option is to buy a battery charger and charge your battery externally.

Amazon.com sells them as well as batteries.

I've heard of this happening to others on the forum. You might do a search. I don't think anyone has fixed one yet though.
zbones
Just a thought,
has anybody tried recharging through the serial port after frying their circuit?

I presume it would still give the same results, but it is worth a try just in case it's only the power socket that's affected.

Peter
drakecoldwinter
Ok it is not dead yet.

for all people with trouble on their Zaurus try to be patient. yesterday after a lot of test and try's, suddently the DM menu appeared...

It's alive !
I'm charging my battery externally to try to do a voltage adjustement and see if my charger circuit is fried or not.

Drake Coldwinter
V-Man
From my understanding, the charging circuit is the only thing "fried". I know of no one that has been able to fix this without going back to Sharp though. . .

I've heard that the Z will still work, you just need to charge the battery externally. You will probably need two batteries so you can swap them out. I think the backup battery will not last long enough to maintain power while the main battery is out of the unit for charging.

Good Luck
sbbloom69
Hi,
Not all of the charging circuit is in the Zaurus. Half of it is actually INSIDE the BL-0X battery. There is a current regulator and a temperature sensor in the battery on a tiny circuit card just under the 3 battery contacts (ever notice the +, the - and the unlabled contact??). The reason these little high-powered batteries can be charged so quickly is that the charger circuit measures actual bettery cell temperature and controls the current into the battery to keep the temperature below some setpoint to prevent damage.

Try another battery too. I got my first Zaurus (SL-5500) around Christmas 2002 for $25, and that's all that was wrong (that and I had to re-flash the ROM). I still have it.

My SL-C700 (got it March 2003) had a couple of nasty problems that took 3 trips over 18 months to Japan (warranty from Dynamism) to finally fix (intermittant bad ROM chip), but my work paid for several batteries. I have since had a second (out of 5) BL-06 batteries go "bad". A bad or flaky battery can give cause the unit to not work at all, cause flaky symptoms, or even cause the need to reflash. The second battery, which had died / shorted? gave my 5500 fits. It origianlly tried to work, then the charge lite would go on for 4 seconds and go off, then blink. I had to reflash the ROM off the CF card to get it to work again.

Stu
waalkman
QUOTE(sbbloom69 @ Feb 10 2005, 08:53 AM)
Hi,
Not all of the charging circuit is in the Zaurus.  Half of it is actually INSIDE the BL-0X battery.  There is a current regulator and a temperature sensor in the battery on a tiny circuit card just under the 3 battery contacts (ever notice the +, the - and the unlabled contact??).  The reason these little high-powered batteries can be ...
*


Very informative post! Thanks.

Based on your post I tried a simple test to see if I could determine if the charging circuitry was working without the battery installed.

I pulled the battery and plugged in the charger. Then I measured the voltage across the + and - charging posts on my C860 running cacko 1.22 (it's not likely that the ROM makes a difference, but other ROMs might give different results).

I measured between .35 and .65 volts (using a Fluke 87 IV). Useless.

I then tried it again, but this time I pulled the battery while the charger was plugged in (after turning the Z off).

Measuring the voltage this time I got 4.2 volts with .002 volts ripple. I repeated this test twice.

Just the charger itself (an EA-72) was putting out 5.15 volts with .008 volts ripple (open circuit obviously).

Then I unplugged the charger before replacing the battery.


So apparently:

1) there is regulation being done in the Z. And,

2) You can possibly use this test to see if it's a battery problem or a Z problem.


Please be careful as this might be a silly thing to do to a working Z.

And it goes without saying, but I'm not responsible for anything (just ask my Mom) especially anything that happens to your Z.

And be sure to unplug the charger before replacing the battery.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.