Help - Search - Members - Calendar
Full Version: Sd Card Mounted Read-only
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 5x00 Hardware
HearWa
Hello,
I just bought a 5500 from ebay and it is working great. Earlier today I put some MP3s on an SD card to listen to with the Sharp ROM 2.38. Unfortunately I now can't seem to do any writing operations on the SD card. Every time I insert it it automatically mounts as read-only.

Does anyone know what's going on? Thank you.
JohnKiniston
Is the card formated FAT or EXT2?

It may need to be fsck'd so its clean.
HearWa
I'm still toying aroun with it and I can unmount the card no problem. Is there a special way I should mount it?

Here's what 'mount' gives me before this:
/dev/mmcda1 on /usr/mnt.rom/card type vfat (ro)
HearWa
Wow, I didn't see your post after I wrote the second! What fsck command should I use, exactly? It has a vfat partition on it.
lardman
Assuming the partition table has the correct partition type set than a simple:

umount /mnt/card
fsck /dev/mmcda1

should do the trick. Otherwise try fsck.msdos or fsck.vfat


Si
craigtyson
If your using the SD card in another machine to copy your files onto be shure to eject(MS) or unmount(Linux) the card before taking it out of the reader or else you run the risk of corruptin the file allocation table and or not writing all the data to the card. Then when you put it into your Z it will only mount read only.

if you use the tkc rom v1 then there is a gui utility to to the fsck for you
HearWa
Thank you everyone. biggrin.gif It's working now.
tbok
QUOTE(HearWa @ Feb 11 2005, 04:25 PM)
Thank you everyone. biggrin.gif It's working now.
*


I've got the same problem as you - could you say what fixed it?

I'm not a Zaurus geek yet - I've only just got my 5500 (dead cheap - I'm short of cash!), but I'm very familiar with *nix on bigger kit.

The card I have is a Kingston 512Mb SD which was brand new and pre-formatted as FAT. It mounted OK, but I couldn't write to it. I fdisked it and reformatted it as extfs and I wrote to it successfully once using terminal access (created a directory), but now any time I try I get a message that there's no file space available, even though df says there is. By the way, I'm still running ROM 2.35 - I've not dared to try flashing it yet!!

I'm stumped!!

Thanks in advance,

tbok
Timothy
I picked up my Zaurus yesterday after a long absence and plugged in my SD card, I had the same issue. For the life of Me I couldn't figure it out. Finally I ejected the card to realize there is a little switch on the sd card itself that will switch it to read only.

maybe obvious but easier to overlook. Perhaps yours has one too.
tbok
QUOTE(Timothy @ Jul 20 2005, 03:03 PM)
. . . there is a little switch on the sd card itself that will switch it to read only.

maybe obvious but easier to overlook. Perhaps yours has one too.
*


Thanks for the thought, but it isn't that.

I've since tried to reformat the disk back to FAT via the card reader on my PC, but that didn't fix it.

I've also bitten the bullet and reflashed to OZ 3.5.3 with Opie - I hoped it might have different (better!) drivers. The problem's still there, but now manifests as loads of spurious files on the SD disk. I think I'll just have to give this card up as a bad job, and try another manufacturer.

By the way, the card works like a dream on the PC!

tbok
Mickeyl
Unfortunately no distribution has better drivers since we all are forced to use the binary only Sharp SD driver on SL5500 and SL5000.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.