Help - Search - Members - Calendar
Full Version: Bluetooth Dun - The Final Step?
OESF Forums > General Forums > General Support and Discussion > Security and Networking
rogerbowering
I've got C750 with Cacko Rom 1.22 and Bluemonkey card (the latest one) from Shirtpocket.

I'm also using a Sony Ericsson P910i

I'm horrendously non-technical, so this has been a long arduous task getting to the point I am at now....which is

I've set up a Bluetooth-PPP dial up Network and when I select 'Connect' the phone lights up and asks for a Passkey. I've been typing 0000 on the phone which, I believe, is its Passkey although maybe the phone wants the Zaurus Passkey?

So...

What/Where is the Passkey for the Zaurus?
What do I need to complete the dial up process now that the Zaurus appears to be communicating with the phone?

I've modified:
hcid.conf - and set security to none (I don't use Bluetooth that much to be worried about security and I want to take any stumbling blocks out of making this process work:
===========================================
#
# HCI daemon configuration file.
#
# $Id: hcid.conf,v 1.3 2002/07/18 18:12:46 maxk Exp $
#

# HCId options
options {
# Automatically initialize new devices
autoinit yes;

# Security Manager mode
# none - Security manager disabled
# auto - Use local PIN for incoming connections
# user - Always ask user for a PIN
#
security none;

# Pairing mode
# none - Pairing disabled
# multi - Allow pairing with already paired devices
# once - Pair once and deny successive attempts
pairing multi;

# PIN helper
pin_helper /etc/bluetooth/givepin;
}

# Default settings for HCI devices
device {
# Local device name
# %d - device id
# %h - host name
name "%h";

# Local device class
class 0x120114;

# Default packet type
#pkt_type DH1,DM1,HV1;

# Inquiry and Page scan
iscan enable; pscan enable;

# Default link mode
# none - no specific policy
# accept - always accept incoming connections
# master - become master on incoming connections,
# deny role switch on outgoing connections
#
#lm accept,master;
#
lm accept;

# Default link policy
# none - no specific policy
# rswitch - allow role switch
# hold - allow hold mode
# sniff - allow sniff mode
# park - allow park mode
#
#lp hold,sniff;
#
lp hold,sniff,park;

# Authentication and Encryption
#auth enable;
encrypt disable;
}
==============================================
bluetooth.conf looks like this
==============================================
[Common]
Available = y
[Help]
[Info]
;InterfaceType = bluetooth
Id = BLUETOOTH1108089116
Info = bthw
Infolabel = Details
Layer = TCP/IP
Name = SonyEricsson Bluetooth
Type = bluetooth
[Properties]
Auto = 0
AutoConnect = 1
CardType = bluetooth
Device = ppp
IPADDR =
NETMASK =
atdial = ATZ
autoip = 1
btdevice = /dev/rfcomm0
bthw = 00:0E:07:97:FF:02, 7
connectdelay = 180000
crtscts = 1
defaultroute = 1
dialGroup = 1
dialmode = 0
dns1 =
dns2 =
gateway =
idletime = 120
initcmd = ATZ
password = xxxxxxx
phone = 08457560000
speed = 115200
usepeerdns = 1
username = My Username
winppp = 0
[Proxy]
autoconfig =
ftphost =
ftpport = 8080
httphost =
httpport = 8080
noproxies =
type = 0
=====================================
I modified my rfcomm.conf (although I keep typing "Sony Ericsson Bluetooth" in the comments and something keeps reverting it to "Generated by BT dial-up network applet"
=====================================
rfcomm0 {
bind yes;
device 00:0E:07:97:FF:02;
channel 7;
comment "Generated by BT dial-up network applet.";
}
======================================
I wasn't able (on the Zaurus) to modify givepin, but I did so on the PC using Notepad and copying it back:
======================================
##############givepin#########
#!/bin/sh
echo "PIN:0000"
################
=======================================
I even changed a file 'PIN' to say '0000'

Believe me I've been through all the How-Tos and FAQ but quite a bit of it doesn't work, like
"* Restart Bluetooth on your Zaurus using
/etc/rc.d/init.d/bluetooth restart"

I discovered there is no file in that folder called 'bluetooth'

Also, how do you suspend/resume...I've installed the ipkgs, but I can't find any program icons for them?

Most frustrating

Once again, I'm a techno-neanderthal - be gentle with me as I love my Zaurus
rogerbowering
...and just for completeness (and to see if I can fill a whole page on this site smile.gif , the stptool browse (or whatever it was) gives me:
Browsing 00:0E:07:97:FF:02
Service Name: Voice Gateway
Service Description: Voice gateway
Service Provider: Sony Ericsson
Service RecHandle: 0x10000
Service Class ID List:
"Headset Audio Gateway" (0x1112)
"Generic Audio" (0x1203)
Protocol Descriptor List:
"L2CAP" (0x0100)
"RFCOMM" (0x0003)
Channel: 8
Language Base Attr List:
code_ISO639: 0x656e
encoding: 0x6a
base_offset: 0x100
Profile Descriptor List:
"Headset" (0x1108)
Version: 0x0100

Service Name: HF Voice Gateway
Service Description: HF Voice gateway
Service Provider: Sony Ericsson
Service RecHandle: 0x10001
Service Class ID List:
"Handfree Audio Gateway" (0x111f)
"Generic Audio" (0x1203)
Protocol Descriptor List:
"L2CAP" (0x0100)
"RFCOMM" (0x0003)
Channel: 9
Language Base Attr List:
code_ISO639: 0x656e
encoding: 0x6a
base_offset: 0x100
Profile Descriptor List:
"Handsfree" (0x111e)
Version 0x0100

Servcie Name: OBEX Object Push
Service RecHandle: 0x10004
Service Class ID List:
"OBEX Object Push" (0x1105)
Protocol Descriptor List:
"L2CAP" (0x0100)
"RFCOMM" (0x0003)
Channel: 1
Profile Descriptor List:
"OBEX Object Push" (0x1105)
Version: 0x0100

Service Name: OBEX File Transfer
Service RecHandle: 0x100005
Service Class ID List:
"OBEX File Transfer" (0x1105)
Protocol Descriptor List:
"L2CAP" (0x0100)
"RFCOMM" (0x0003)
Channel: 2
"OBEX" (0x0008)

Service Name: Dial-up Networking
Service Description: Dial-up Networking
Service Provider: Sony Ericsson
Service RecHandle: 0x10006
Service Class ID List:
"Dialup Networking" (0x1103)
Protocol Descriptor List:
"L2CAP" (0x0100)
"RFCOMM" (0x0003)
Channel: 7
Language Base Attr List:
code_ISO639: 0x656e
encoding: 0x6a
base_offset: 0x100
Profile Descriptor List:
"Dialup Networking" (0x1103)
Version: 0x0100

Service Name: Bluetooth Serial Port
Service Description: Bluetooth Serial Port
Service Provider: Symbian Ltd.
Service RecHandle: 0x10007
Service Class ID List:
"Serial Port" (0x1101)
Protocol Descriptor List:
"L2CAP" (0x0100)
"RFCOMM" (0x0003)
Channel: 3
Language Base Attr List:
code_ISO639: 0x656e
encoding: 0x6a
base_offset: 0x100
zmiq2
Hi roger,

1) to me, it looks like the password issue you are having is regarding the access to tmobile, not the pairing between the zaurus and the phone; can you verify this? I would suggest to access the phone's bluetooth paired devices, and see if a zaurus entry is there

2) thanks for posting all that info, for troubleshooting; next time, though, don't post usernames/passwords that can be sensitive; just erase/edit those fields when posting.

I have a C750+SEK700i, and it works great !
rogerbowering
zmig2, thanks.

1) Slightly bizarre. Yes the phone sees the Zaurus in its list of devices. Bizarre because when I have my USB Bluetooth in the PC, the phone sees Zaurus and the PC. I can click on the PC entry and see information. Also, I've used the PC to dial the phone. If I click on the Zaurus entry then it immediately disappears from the list on the phone. Just in case there's any confusion - the phone doesn't dial when I try it from the Zaurus. And to make matters worse, now the phone is not responding to the Zaurus at all (a backward step), even tho' everything's rebooted several times.
2) Yes, silly posting the usernames and passwords: Just so keen to not post and find I've missed some information that would be needed to troubleshoot. Can I get the mod to modify my post?

Thanks again for your help. As I said, I'm a hopeless techno-imbecile. I just want to be productive with my PDA
rogerbowering
Actually, I was just wondering.....assuming I can get back to the point where the Zaurus 'did something' with the phone whether, as the step it got to was:
"Initializing Modem...."
(Phone asked for a Passkey) - what is this bl**dy passkey?

I only needed to modify the modem initialisation string. Currently it's ATZ which is OK for Irda
rogerbowering
Me again! unsure.gif

I changed the Mac address string in the Network app to lower case and now the Zaurus 'talks' to the phone

When I select Connect, the Zaurus connecting dialup ("Initializing Modem") 'wakes up' the phone which displays:

"To connect to zaurus, you must enter a passkey

Passkey: ______"

I've tried 0000 which, I think, is the phone's Passkey.
I've tried 1234 which, I think, is the Zaurus's Passkey.

Then the phone goes back to its default display and does nothing, while the Zaurus continues to try to "Initialize Modem"

I did a search on this board for "passkey" and found one other post which suggests running syslog and checking Messages.

The relevant part of 'Messages' (by God, it's big!!!) says:
===================================================
....
Feb 11 18:56:37 zaurus kern.alert qpe: [smartNaviBase][Auto Connect][10][(null)]
Feb 11 18:56:37 zaurus kern.alert qpe: [smartNaviBase][Auto Connect][8][(null)]
Feb 11 18:56:37 zaurus kern.alert qpe: [smartNaviBase][Auto Connect][40][(null)]
Feb 11 18:56:37 zaurus kern.alert qpe: [smartNaviBase][Auto Connect][40][(null)]
Feb 11 18:56:37 zaurus kern.alert qpe: [smartNaviBase][Auto Connect][10][(null)]
Feb 11 18:56:40 zaurus kern.alert qpe: [smartNaviBase][Auto Connect][4][(null)]
Feb 11 18:56:40 zaurus kern.crit qpe: vpnStaff::down ()
Feb 11 18:56:40 zaurus kern.alert qpe: [smartNaviBase][Auto Connect][4][(null)]
Feb 11 18:56:40 zaurus kern.alert qpe: [smartNaviBase][Auto Connect][2][(null)]
Feb 11 18:56:40 zaurus kern.crit qpe: vpnStaff::down ()
Feb 11 18:56:40 zaurus local2.notice pppd[1033]: pppd 2.4.0 started by root, uid 0
Feb 11 18:56:48 zaurus daemon.info hcid[719]: pin_code_request (sba=00:02:72:81:31:99, dba=00:0E:07:97:FF:02)
Feb 11 18:56:48 zaurus daemon.err hcid[1034]: PIN helper exited abnormally with code 32256
Feb 11 18:56:48 zaurus local2.err pppd[1033]: Failed to open /dev/rfcomm0: Connection refused
Feb 11 18:56:48 zaurus local2.info pppd[1033]: Exit.
Feb 11 18:56:50 zaurus kern.crit qpe: vpnStaff::down ()
Feb 11 18:56:52 zaurus kern.crit qpe: vpnStaff::down ()
Feb 11 18:56:53 zaurus kern.crit qpe: vpnStaff::down ()
Feb 11 18:56:53 zaurus local2.notice pppd[1038]: pppd 2.4.0 started by root, uid 0
Feb 11 18:56:58 zaurus daemon.info hcid[719]: pin_code_request (sba=00:02:72:81:31:99, dba=00:0E:07:97:FF:02)
Feb 11 18:56:59 zaurus daemon.err hcid[1039]: PIN helper exited abnormally with code 32256
Feb 11 18:56:59 zaurus local2.err pppd[1038]: Failed to open /dev/rfcomm0: Connection refused
Feb 11 18:56:59 zaurus local2.info pppd[1038]: Exit.
Feb 11 18:57:02 zaurus kern.crit qpe: vpnStaff::down ()
Feb 11 18:57:06 zaurus daemon.debug atd[185]: okay. Alarm rang.
...
===============================================

I've spotted PIN helper somewhere, (hcid.conf?), but what should I do with it? And, PLEASE ph34r.gif , what's the Zaurus's passkey?

A WinCE beckons...........only joking
speculatrix
QUOTE(rogerbowering @ Feb 11 2005, 07:09 PM)
I've spotted PIN helper somewhere, (hcid.conf?), but what should I do with it? And, PLEASE  ph34r.gif , what's the Zaurus's passkey?

A WinCE beckons...........only joking
*


Hi,
there are TWO places to put in a pin.

The first place is the pin that the zaurus presents when connecting to another device. The location of this pin is specified in hcid.conf (you will need to reload hcid to make changes have an effect), the setting is called pin_helper, and an example would be /bin/givepin which would just echo "PIN:1234" for example.

The second place is the pin that the zaurus requires when a device connects to it. This is the file /etc/bluetooth/pin, and is *just* the pin e.g. "1234", NOT "PIN:1234"!

Now, clearly when setting up, it makes life much easier to make both pins the same, in which case the /bin/givebluepin could do this
echo -n 'PIN:'
cat /etc/bluetooth/pin

CHECK THE FILE PERMISSIONS! Ensure the pin helper program has execute! Check the pin file is readable by root!

Paul
Bombur
Your problem is that you need an accepted login for your GPRS network. Go to here and look it up. You should put the accepted usrename and password in the Account tab of your bluetooth dialup configuration.

J.
rogerbowering
I don't see how that solves my problem.

The phone displays: Enter PIN [_______]

I have to open the phone keyboard and tap in the number, then tap [return], then ......nothing.

I mean, it's not as though it's dialling and not able to connect (don't get me started on dialling via IR to my GMS phone!!!), it never gets to start the dial up
rogerbowering
In addition, in the Network, Bluetooth set up dialogue, there's a box for phone number: there's no phone number (UK Vodafone, Contract) on that web page. Also there's no field in the Network, Bluetooth dialogue to enter an SMTP

In any case, I want to connect to my regular ISP, whom I use from home (via Broadband on the PC), and via dial-up (when a phone socket is available) on the Zaurus using a 56k modem at work.

In these instances I use my ISP's dial-up & broadband numbers plus their POP/SMTP details. It would be no use using the mobile phone operator as I wouldn't get to my email.

I want to use Bluetooth with the phone for times when I am out of the office or no phone line is available
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.