Help - Search - Members - Calendar
Full Version: Managing tabs in 3.3.6?
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
undrwater
I've noticed that the tabs section in Launcher is greyed out. I did a search and found tabmanager for opie for familiar...but couldn't get it to work with OpenZaurus.

Is there a tabmanager application...?

TIA
zenyatta
Do you mean the New and Delete buttons in Settings > Launcher > Tabs? Because other than that, nothing is greyed out in my case (the Edit button and the two checkboxes at the bottom).

By the way, if you want to create a new tab (let's call it Example) by hand, open Konsole and do this:

cd /opt/QtPalmtop/apps
mkdir Example
mv Applications/some_app.desktop Example

Then, exit Konsole and go Settings > Shutdown > Restart Opie. The new tab will not have an icon and it will have the outrageous Blue Nebula background. To change the background, go Settings > Launcher > Tabs. The new tab will not be listed but you can select All Tabs, then choose Edit > Background and do what you need. This will affect all tabs, of course.

Removing the tab is similar (move .desktop files to a safe place, remove the directory, restart Opie).

Hope this helps a bit.

z.
Greg2
QUOTE
Hope this helps a bit.
z.


That helps a lot, I was also trying to make the Familiar version tabmanager function on OZ.

Thanks

Greg smile.gif
undrwater
Thank you!! Now i can clean up my Applications tab...getting too cluttered wink.gif
VeeDubb
The tabmanager app works just rfine under OZ with the compat libs. I find that;s the easiest way. The only problem is that sometimes afterinstalling software, it will duplicate programes, but removing them with tabmanageronly takle amoment.
Greg2
Thanks VeeDubb

That's even better, and now qpaint works also

Greg :roll:
zenyatta
Looks like i'll be checking out this tabmanager thing :grin: - that is, after I figure out why I can't install the compat libs...

z.
VeeDubb
Let me guess, you're trying to instll the compat libs to an SD card and the SD card is formatted vfat right?

The problem is that the ipk try's to create some symlink INSIDE the install directory BEFORE linking to root, but the vfat file system doesn't support symlinks.

Format your card ext2 and try again, then open up a console and enter this :

ipkg-link mount /mnt/card/
zenyatta
Actually, I have an ext2 CF card so that wouldn't be an issue.

My problem is much weirder: I cannot put the oz-compat package anywhere else than root! This happens with the GUI installer as well as plain old ipkg. Whatever destination I choose, I get "Installing package oz-compat to root..." and since root has only ~1800K of free space it hangs.

The only legacy app I want to run is hancomsheet which I don't need that much so for the moment I'm leaving it as it is. Puzzling nevertheless...

z.
VeeDubb
That's VERY strange. i don't have that problem, and i can't imagine the cause. You might try the ones in the OZ fee at http://openzaurus.org/official if you are using something else.
zenyatta
Well, in the end I created a symlink to my CF card:

/opt/QtPalmtop.compat > /mnt/cf/opt/QtPalmtop.compat

Since the actual compat libraries go to /opt/QtPalmtop.compat, this allowed me to install to root without running out of space.

HancomSheet runs fine now.

z.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.