Help - Search - Members - Calendar
Full Version: Oe Build Problems
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > OpenZaurus/Opie/Qtopia
radioz
I'm trying to set up a build environment for OE on my Mandrake 10.0 machine.
I kicked off a build with 'bitbake task-bootstrap' and eventually got the following error:

NOTE: package bison-native-2.0: started
NOTE: package bison-native-2.0-r0: task do_fetch: started
NOTE: fetch ftp://ftp.gnu.org/gnu/bison/bison-2.0.tar.gz
--14:43:57-- ftp://ftp.gnu.org/gnu/bison/bison-2.0.tar.gz
=> `/home/keithg/Zaurus/oe/sources/bison-2.0.tar.gz'
Resolving ftp.gnu.org... 199.232.41.7
Connecting to ftp.gnu.org[199.232.41.7]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done. ==> PWD ... done.
==> TYPE I ... done. ==> CWD /gnu/bison ... done.
==> PASV ... done. ==> RETR bison-2.0.tar.gz ... done.
Length: 1,163,590 (unauthoritative)

100%[==============================================>] 1,163,590 67.38K/s ETA 00:00

14:44:17 (64.13 KB/s) - `/home/keithg/Zaurus/oe/sources/bison-2.0.tar.gz' saved [1163590]

NOTE: package bison-native-2.0-r0: task do_fetch: completed
NOTE: package bison-native-2.0-r0: task do_unpack: started
NOTE: Unpacking /home/keithg/Zaurus/oe/sources/bison-2.0.tar.gz to /home/keithg/Zaurus/oe/build/tmp/work/bison-native-2.0-r0/
NOTE: package bison-native-2.0-r0: task do_unpack: completed
NOTE: package bison-native-2.0-r0: task do_patch: started
NOTE: Applying patch 'm4'
NOTE: package bison-native-2.0-r0: task do_patch: completed
NOTE: package bison-native-2.0-r0: task do_configure: started
ERROR: function do_configure failed
ERROR: log data follows (/home/keithg/Zaurus/oe/build/tmp/work/bison-native-2.0-r0/temp/log.do_configure.18358)
| NOTE: Executing autoreconf --verbose --install --force --exclude=autopoint -I /home/keithg/Zaurus/oe/build/tmp/work/bison-native-2.0-r0/bison-2.0/data/ -I /home/keithg/Zaurus/oe/build/tmp/work/bison-native-2.0-r0/bison-2.0/m4/ -I /home/keithg/Zaurus/oe/build/tmp/work/bison-native-2.0-r0/bison-2.0/tests/ -I /home/keithg/Zaurus/oe/build/tmp/staging/i686-linux/share/aclocal
| Usage: autoreconf [-f] [-h] [--help] [-m dir] [--macrodir=dir]
| [-l dir] [--localdir=dir] [--force] [--verbose] [--version]
| [--cygnus] [--foreign] [--gnits] [--gnu] [-i] [--include-deps]
| FATAL: autoreconf execution failed.
NOTE: Task failed:
NOTE: package bison-native-2.0-r0: task do_configure: failed
ERROR: TaskFailed event exception, aborting
NOTE: package bison-native-2.0: failed
ERROR: Build of task-bootstrap failed


It looks as though it is complaining that the arguments to the autoreconf command were invalid. Does anyone have a suggestion on how to attack this?

radioz
lardman
Check you have all of the software listed on the Requirements page. Also check that the versions are high enough, etc. For starters I'd try updating Autoconf.

I've just set up a Mandrake 10 box and it works fine (though I used some packages from the 10.1 'feed' on the web).

If you've still got problems then post again and we can compare versions of various things.


Si
radioz
I've verified the versions of tools that have version numbers described on the web page. Version numbers are missing from some of them, so I don't know which versions I should use.

Which version of autoconf should I have? I've got autoconf-2.13-19mdk.

Any other suggestions?

thanks,

radioz
Mickeyl
I strongly recommend the 2.5x tools, the other ones are hopelessly outdated. Since Mandrake hacks something around to support both tool versions, I also recommend just to install them manually into /usr/local/ and adjust your PATH.

For everything else, oe@handhelds.org is the support list - please don't use this forum.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.