Help - Search - Members - Calendar
Full Version: Pdaxrom For 5500?
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Pages: 1, 2
victorhooi
Hi,

I was just wondering if anybody had any word on progress on pdaXrom for the Zaurus 5500? Is there any chance of a RC/beta release, or something similar?

thanks,
Victor
Mickeyl
If you're just after the X server, there is an X based ROM for the 5500 - it's called OpenZaurus / GPE.
victorhooi
Hi,

thanks, but yeah I've tried that biggrin.gif (actually, I'm trying the 3.5.3 pre-release right now...*fingers crossed*)

but no, I'm looking specifically for pdaxrom...with quake *gasp* hehe

any word from developers or anybody in the know?

bye,
Victor
lardman
QUOTE
but no, I'm looking specifically for pdaxrom...with quake *gasp* hehe


Does Quake not run on GPE?

Si
mmoralls
Looking at the screenshots, does this ROM come with extras like ABI word? I have an SL5500 with OZ 3.5.2 right now and am having to alter some programs (Hancom) to make them install correctly. I don't have a Liunx box right now and can't seem to locate a public one to do this. If this pdaxROM comes with some software loaded or if the ROM package manager loads other software without any hitches I'm willing to wait. Or are they going to concentrate on developing for the later models of the Zaurus? dry.gif

Thx
omega
There was a post from laze that there will be some effort put towards making pdaxrom run on the 5000, 6000 and 3000 series...
auauhiro
I have made a hd-image of ext2 file system of pdaXrom for SL-C3000 which can be used by chroot command from native console mode and Qt console mode. This image can be also used on SL-C700 and SL-C760. But, using on SL-5500, an error "Illegural Instructions" occurs when I attept to chroot to pdaXrom. Some applications wriiten for japanese SL-serises shows same error on SL-5500. I consider that these are due to the machine codes which are optimized for Xscale processors. Thus, almost all of the pdaXrom should be recompiled for SL-5500.
victorhooi
Hi,

Still no word on anything, huh? wink.gif Well, fingers crossed, but I've heard absolutely nothing on any new developments...

To the poster above, who asked why I might want to run pdaXrom, it's for the X server...lol. And I've tried GPE 3.5.2 and 3.5.3 (pre-release), but they're both a bit unpolished and laggy (at least for me).

cya,
Victor
Mickeyl
How about joining the crew to polish and improve GPE ?
technojunkie
Just my 2 cents but I think that a 5500 running GPE can't help but be a bit laggy. Consider this: You're running an X server on a device with a 266Mhz ARM processor, which by nature is a bit limited in capability. Not to mention you really only have 32-64MB of RAM to work with.(If you count swap you introduce even more speed reduction)

On top of that any extra 'polish' is going to place that much more load on the processor.
victorhooi
Hi,

Mickeyl: I'd be more than happy to join up and help the pdaXrom project. I assume you're associated with the project, right? If so, please contact me (PM or email is fine - victorhooi (at) yahoo (dot) com), and tell me what areas I can help out with. I'm definitely not a brilliant programmer - bit of C/C++, some Java etc - but I wouldn't mind doc-writing, testing betas, bug-quashing etc.

technojunkie: I don't think it's some kind of inherent limitation of either the GTK+ toolkit, or or X that somehow makes the Zaurus "laggy". X runs fine on a 100Mhz processor with 16Mb of ram (my secondary system), so I don't see why it has to be laggy on a Zaurus (100Mhz on x86 doesn't convert into 100Mhz on ARM, obviously, but you get the idea).

The recent reductions in the memory footprint of Matchbox are a good example. I doubt we've reached the end of the road to optimising all the stuff in GPE (note: I'm not a programmer) - hopefully, we'll be able to push it further, and bring it up to par with say, the Qtopia releases. Speaking of which - does anybody know why the (very spartan) unofficial pdaXrom QTopia 2.1 releases were so damn fast? I mean seriously seriously fast. I'd be willing to put up with quite a drop in functionality if I could get something like that kind of speed = rolleyes.gif.

bye,
Victor
Jinidog
What about the SL5600?
It has a 400 MHz CPU and it's a XScale. (so is the CPU of the SL5500, why should there be illegal instructions then?)
kahm
QUOTE(Jinidog @ Apr 27 2005, 09:31 AM)
What about the SL5600?
It has a 400 MHz CPU and it's a XScale. (so is the CPU of the SL5500, why should there be illegal instructions then?)
*


The 5000D/5500 are Strongarm SA-1110 processors running at 206mhz.

The 5600 and up run on XScale PXA250, PXA255, or PXA270 processors at 400 and 416 mhz.

They are *definitely* different. The XScale's include a Strongarm compatibility instruction set, but there are additional native instructions as well.
Jinidog
So the image should be at least binary-compatible with the SL5600?
odubtaig
I'd like to point out that I have gpe-collie running on a 5000d with absolutely no lag whatsoever (rosetta works and everything!). I'd also like to point out that many of the X11 compiled apps ( here ) also run (having shifted /usr to the SD card) including Abiword and Gaim.

That said, most of these apps have not been compiled with the miniscule 320x240 resolution in mind so running Abiword and ScummVM is technically possible but not very practical (I still haven't figured out how I'd change the font and when you close only the 'cancel' and 'save' buttons are visible on the quit dialog, the only way to quit without saving is to use the program manager).

Asides from this I also have got minimo up and running (usability to be tested when my WiFI bridge arrives) but Inkscape doesn't seem to work (I've yet to figure out why).

All in all, I'm glad to ditch Opie.

regards, Paul
victorhooi
hi,

QUOTE
Ohhh - we are very close to release - i have attached some screenshots :-)


Link (10 February, 2005

Anybody have any idea on the progress of pdaXrom for the 5500? According to Laze, they defineltey had working code in February, and were close to releasing - what became of that?

Well, keeping my fingers crossed for new biggrin.gif.

cya,
Victor
adf
QUOTE(victorhooi @ May 14 2005, 09:57 AM)
hi,

QUOTE
Ohhh - we are very close to release - i have attached some screenshots :-)


Link (10 February, 2005

Anybody have any idea on the progress of pdaXrom for the 5500? According to Laze, they defineltey had working code in February, and were close to releasing - what became of that?

Well, keeping my fingers crossed for new biggrin.gif.

cya,
Victor
*




I have the same interest i the 6000.

My guess is that they said they'd work on the 5.xk and 6k series and found that there was a real need for them to get the 1k and 3k out fast..and they got really busy.
then the whole kernel 2.6 thing came along.... and they probably would rather not hear us bitch about iffy stuff that would happen if they relesae early, etc....
Laze
We still hope to have some 6000 betas out this weekend :-)

The 5000/5500 roms are pretty usable by now and will maybe also be released this weekend.
miskinis
Wow, I've got an SL-5500, and would really love to try/use this
ROM. If it's usuable, I'm anxious to get it...

Thanks in advance!

John
miskinis
I'm willing to try unofficial/early releases of the SL-5500 pdaXrom,
I was looking forward to trying to setup an X11 based system
again over the weekend...

Many thanks in advance,

John
andrewwoods
QUOTE(miskinis @ May 21 2005, 02:50 AM)
I'm willing to try unofficial/early releases of the SL-5500 pdaXrom,
*



Yes, me too. I have RC10 working on my 860 and would be very happy to help test on my old 5500. Will have to blow some dust off it first!!
miskinis
Any news?
Laze
Yes but at the moment Sash has gone missing.. So again please wait :-/
andrewwoods
QUOTE(Laze @ Jun 5 2005, 10:06 AM)
Yes but at the moment Sash has gone missing.. So again please wait :-/
*


Still waiting, still hoping.
My 860 is BRILLIANT (with xfce4 now) but my 5500 is still a dusty brick.

Beta code would do. Alpha code would do. Lots of keen testers out here.

Please please please.
victorhooi
Any further word at all?

I'd have to concur with andrewwoods, I personally would be more than happy to test out alpha code, anything at all.

Even the code you guys said you had in February, even that I'd be happy with it, even if it's totally alpha/buggy - just something to see how it's coming along.

Anyway, kudos for the great work so far, you guys have done fine things for the Z community. Hope sSach is back soon.

cya,
Victor
nothing
Жду прошивку с самого-того момента, когда Laze сказал, что она появится возможно к концу недели...
Думаю, жду не один... Ребята, всё конечно супер, но... сообщите нам, хотя бы, стоит ждать? или начинать пользоваться GPE?

Похоже для SL-5500 так и не выходило ни одного удачного рома.... sad.gif
Обидно.
sashz
well, there pdaXrom for Collie devices, as is.

http://212.10.30.205/rc10/Zaurus-Collie/

Current problems - default ROM havent preinstalled settings utils, they all in the feed. For install need SD/MMC or CF card because internal flash small. Later, when we rewrite all pyhton utils to native GTK2 we will place it inside rom.

For install software edit /etc/ipkg.conf with vi for right feed path (url) and use command line ipkg utils, or ipkg-install (ipkg-remove):

ipkg-install /mnt/card minimo
andrewwoods
That sounds great. I'm next at work on Wednesday and you can bet I'll be trying it.

Thanks
Andrew
bsaunder2002
Great progress!

I've loaded it twice now(something about setting the root password in aterm, I couldnt log in again, weird)

Some questions:
I thought some of pdaXrom's features were: 1- runs off of SD, 2- comes with qtopia compiled for X11 so I can run both X11 and qtopia apps at the same time

1- how do I install pdaXrom to the SD card. The 5500 feed has initrd.bin and zImage but no updater.sh so it doesn't automagically install to SD.

2- does the 5500 version support qtopia over X11?

(more basically how do I install the 5500 feed (I did copy initrd.bin and zImage to CF, hold c and d keys down, press reset button until both lights on, release c and d keys, wait till lights go off, press reset button, close up, power on) is this right?)

Bill
miskinis
Hi!

I've been checking this topic every couple days, and was very surprised
and very thankful, to see the news!

I will be trying this on an SL-5500 a little later tonight. Perhaps this
"release" deserves a dedicated topic, which might make getting
started easier for others.

I intend to try to display lots of remote X clients on the Z first, and will
post my results later...

Again, thanks for this! _John_
pgas
QUOTE
1- runs off of SD


As it is the first release that is out for 5500, nobody exept sashz and laze know about this, the documentation is limited to what sashz as posted so far...

QUOTE
2- does the 5500 version support qtopia over X11


short answer: no.

I compiled qtopia with the patches from yopy (search this forum), so that it is possible to run qtopia over X11. But I'm not really interested into this so it is not packaged, tested and probably won't let you run ipkg for the sharp rom as is.

Moreover as it is compiled for xscale, it probably won't run at all on the 5500....
miskinis
Hi,

I installed this on an SL-5500 last night, but have not installed anything
on top of it yet, as I need to free up some disk space to create a local
feed.

I was able to use aterm to check out a few things, and experienced no
crashes or hangs so far!

_John_
law
little bug :-)

gaim needs libao, add this to the ipk deps :-)

it is realy fast :-)
andrewwoods
Hey this is great. Well done chaps.

I've installed it, but forgot to bring my spare sd card so can't do much else yet.
Absolute Nirvana
I know you have to install the system tools (sleep, button config) on your own, but which ipk(s) contain the system tools?

Is is this ipk: python-distutils_2.3.4_arm.ipk ?
miskinis
I've tried to check out this ROM a few times, but each time I
was unsure of what packages I needed to install. Some instructions
as to what is needed, to achieve a WIFI connection (with WEP
preferred), and an ssh connection into the device would be
a great help.

Getting that far, would allow me to use a (full size) terminal to
experiment and install other packages as needed.

Many thanks in advance,

John
miskinis
QUOTE(miskinis @ Jul 13 2005, 05:34 PM)
I've tried to check out this ROM a few times...


Oh yeh, another really useful piece of information, would be
how to run the pdaXrom (optionally) from SD. That would allow
experimentation, while still allowing the ability to boot back to
a more comfortable (understood from experience) OS.

I was hoping to get pdaXrom up, then persue a JAVA VM this
weekend, but it looks like it will be quite a struggle without a
few hints on what packages are needed to configure and
get WIFI to work.

Help would be cool,

John
miskinis
QUOTE(miskinis @ Jul 13 2005, 05:34 PM)
I've tried to check out this ROM a few times...


Well, I spent many hours this weekend, and got very far with this ROM
on my SL-5500. I turned off WEP and enabled ESID broadcast on my
WIFI router, and was able to get a WIFI connection. It appears I have to
hunt down info on the "iwconfig" command, which I have never needed to use before.

Unfortunately, I was using a 128MB SD card, and although I was able
to get a lot of things running (openbox, etc.), and many X clients to
display remotely on the Z, I ran out of space while installing
"gcc_headers", so it looks like I must start all over.

In any case, I figured I'd post my results, in case others are trying to
use this, and are interested...

John
miskinis
I forgot to ask if anyone knows how to get the
screen to rotate to the portrait orientation. The
rotate.sh script tries to invoke some "*clamshell*"
script that is not there.

Many thanks in advance for a solution,
John
nauj27
QUOTE(miskinis @ Jul 19 2005, 02:06 AM)
I forgot to ask if anyone knows how to get the
screen to rotate to the portrait orientation.  The
rotate.sh script tries to invoke some "*clamshell*"
script that is not there.

Many thanks in advance for a solution,
John
*


Hi,

yep, i have change the rotate.sh script.
Change actions in case statement to use xrandr directly.

xrandr -o [normal | left | right | inverted]

Works for me.
miskinis
Hi,

Thanks! It works perfectly.

[[ I deleted my "space on / issue" from this reply, until I scan the forum
to see if others know what can safely be moved to SD ]]

Again, this ROM is really nice, and thanks!

John
mmoralls
Ok...I'd like to settle on a ROM and think this is the one. I previously checked out and liked the feeds and screenshots of the interface but when I went to install it appears pretty plain without the bells and whistles of others. But I guess that's what was intended. I don't mind doing a little detective work to figure out how things work without bugging people for answers. But from time to time I'd like to think that I can call on them when I do. So with that...

What is the utilities package for the configuration of the GUI (i.e. Network, screen look, time, etc.) called so I can fetch it?

and

Can any ipk work on any of these ROM's?

Thanks for the help.
miskinis
After several iterations of re-flashing, and experimenting, I
have managed to get a somewhat decent configuration on the
SL-5500 with this ROM.

I have the blackdown JAVA VM running, but it is painfully slow.
Is this expected? For instance in the swing ColorChooser demo,
it takes over a minute to update the screen when selecting a radio
button that changes the mode (and destroys/creates new components).

I moved the /usr/ X11R6 directory to SD, to free up / space, so perhaps
this is contributing.

John
miskinis
A screenshot of a few X programs, and a JAVA swing application
on my SL-5500. The 240x320 resolution is so darn limiting, but it works...
miskinis
Darn, I installed xmms, but it will not load files into the playlist.
The files are on SD, I hope that is supported!

Even if I specify the file on the command line, it brings up the
playlist (add) window. sad.gif

Perhaps the GUI errors below are related, but I doubt it. sad.gif

CODE
# xmms a.mp3                                  

Gdk-WARNING **: Missing charsets in FontSet creation


Gdk-WARNING **:     ISO8859-1


** WARNING **: Failed to open font: "-adobe-helvetica-bold-r-*-*-10-*".
#
miskinis
I did not have xmms-mad installed, which was preventing
xmms from being able to decode the .mp3 files. In any
case all is well with xmms now! smile.gif
miskinis
Does anyone have a program (like xloadimage) for the SL-5500 that
allows the user to place an image in the root window? I currently
use the openbox WM.

To date, I have not tried installing anything outside of the feed that
was published near the start of this thread. I'm confused as to what
(if anything) from other feeds would run OK on the 5500-pdaXrom.

I have managed to natively compile and link some example
GTK+ programs which is amazing by the way. I ran into some linking
issues with Motif and (straight) X11 programs, which I can provide
more detail on when I get home.

John
Snappy
QUOTE(miskinis @ Aug 3 2005, 08:34 PM)
Does anyone have a program (like xloadimage) for the SL-5500 that
allows the user to place an image in the root window?  I currently
use the openbox WM.

To date, I have not tried installing anything outside of the feed that
was published near the start of this thread.  I'm confused as to what
(if anything) from other feeds would run OK on the 5500-pdaXrom.

I have managed to natively compile and link some example
GTK+ programs which is amazing by the way.  I ran into some linking
issues with Motif and (straight) X11 programs, which I can provide
more detail on when I get home.

John
*


Hi there! So did you manage to find the ipkgs to install to get things like GUI system tools running?
miskinis
QUOTE
Hi there! So did you manage to find the ipkgs to install to get things like GUI system tools running?


Well, some of them. In order to get a specific ESSID and WEP for a
WIFI connection, I needed to be able to get network.py to run.

I believe there were other deps, I have notes at home. But I believe
there was a "*unixadmin*" ipk, and lanconfig, and matchbox-pdaXrom
which supplied another missing file.

It was not my goal to install the matchbox WM, and "panel", as I wish
to use openbox, and potentially something else in the future.

I looked though the "Filelist" and "Packages" in the feed, to try to
determine what ipks I needed to install.

John
Lawrence
What updater.sh should I use? there does not seem to be one on the download page? Miskinis, How did you install it? I am sitting here trying to install pdaXrom on my 5600. But I am just a little more stupid than the rest of you because I can't figure it out. I downloaded zImage.SL-5500 (renamed to zImage) and initrd.bin, and tried to flash with the OZ GPE updater.sh. It flashes OK, but when I reset it and turn it on, the power led goes out, and then back on and that's it blink.gif I then tried the 6000 pdaXrom, with and with-out resizing and have the same problem. I do have a nand backup so I can restore. And what would likely need changing on the 6000 rom so it would install on a 5600 (Mine has the pxa255)? I bet I could learn how to do it with a few pointers. I would love to help this project!
BTW I am a 4 year debian luser! biggrin.gif WINDOWS FREE FOR FOUR YEARS!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.