Help - Search - Members - Calendar
Full Version: D-link Dcf-650w ; Kismet ; Sharp Rom 2.38
OESF Forums > General Forums > General Support and Discussion > Security and Networking
conn-fused
I have a D-Link DCF-650W CF wireless card that I'd like to use with Kismet on a Zaurus (Sharp Rom 2.38).

I've tried (in kismet.conf):
source=wlanng,eth0,wlanngsource
And:
source=wlanng_legacy,eth0,wlanngsource

The first won't start kismet:
FATAL: pcap reported netlink type 1 (EN10MB) for eth0. This probably means you're not in RFMON mode or your drivers are reporting a bad value. Make sure you have the correct drivers and that entering monitor mode succeeded.

The second starts kismet, but I detect nothing from a known active AP (LOS, about 1 foot away from the Z).

Is my source line wrong?

How can I check that rfmon was entered? How can I instruct the card to enter rfmon mode manually?

Incidently, I've tried the 2005 and 2004 releases of kismet. Results are unchanged. I'd be happy to change to an OZ (or alt.) rom if someone can confirm kismet with this card under OZ.

Thanks for your help!
jfv
I have the same card and a C860 Sharp ROM. Kismet works fine for me. I tried to look at my kismet.conf file but couldn't find it. I did install kismet-qt (a GUI for Kismet) and configured from there. I recall that the first few times I had trouble saving the configuration (but eventually it got saved) and also that I need to run it as root. There only a few options on the GUI and after a few tries it all worked. I think it's configured as Sharp3x-prism2.

Felipe
conn-fused
Thanks for the reassuring news; I'll keep working on it. I've looked at the Sharp's 3.x rom, however, and if I have to change roms, I'd rather go to OZ 3.5.2.

Perhaps it's possible to install the (hostap?) drivers used by OZ - or whatever drivers are used by 3.x - under 2.38? Does anyone know how I might approach this?

BTW, you can find your kismet.conf file by entering "find / -name kismet.conf" at a terminal. If you could post the source= line you'll find in that file, I'd appreciate it. Also, do you know what version of libpcap (and what version of kismet) you installed? Thanks again.
orange
All I know is that the sharp rom does not support monitor mode so you have to create a dummy Networkprofile in adhoc mode

Take a look here

kismet.conf source sould be: source=prism2,wlan0,prism2source for the DLink Card
jfv
Found the file. I had looked only in /etc not /usr/etc.
Kismet is version 2.8.1
source=prism2_legacy,eth0,Kismet
libpcap.so.0.7.2

Felipe
conn-fused
Thanks everyone for your help. I got it working as follows:

Install:
libstdc++2.10-glibc2.2_2.95.4-15_arm.ipk (Repackage it for a sharp rom with ar -x filename, then tar it back up; the install reports an error, which you can ignore)
libpcap0_0.7.2-20031220_arm.ipk
libncurses5_5.0-6.0potato1_arm.ipk
kismet_3.0.1c-20031228_arm.ipk (this method may work with a newer versions too, and when I test this, I'll let you know)
kismet-qt_2.0.0_arm.ipk

Then edit the configuration file:
vi /home/root/usr/local/etc/kismet.conf
source=prism2_legacy,eth0,prism2 (<-- Thanks for this jfv)
(While you're at it: configdir=/home/root/.kismet/)

Then set up a symbolic link as follows, or kismet will complain:
ln -s libstdc++-libc6.2-2.so.3 libstdc++-libc6.1-2.so.3 (the link and the file are in /home/root/usr/lib/)

Kismet (console version) still did not detect my test network until I configured kismet-qt to use Sharp-prism2. Thereafter, kismet-qt immediately detected test network, as did kismet.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.